Kerberos for Windows 3.0/3.1 - Kerberos

This is a discussion on Kerberos for Windows 3.0/3.1 - Kerberos ; I upgraded my Kfw from 2.6.5 to 3.0 and found out that I could not add an identity, so I could not log in to my realm. I then installed kfw 3.1 beta and the openafs module. I could login ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Kerberos for Windows 3.0/3.1

  1. Kerberos for Windows 3.0/3.1

    I upgraded my Kfw from 2.6.5 to 3.0 and found out that I could not add an
    identity, so I could not log in to my realm. I then installed kfw 3.1 beta
    and the openafs module. I could login in, but after I logged in the program
    would perform an illegal operation and crash. I looked at the problem and
    it was the afsauthent.dll Anyone have any ideas? Thanks

    Jeff Hagley
    System Administrator

    Internet2

    1000 Oakbrook Dr., Suite 300
    Ann Arbor, MI 48104

    (734) 352-4247 - Office
    (734) 652-4687 - Mobile
    (734) 913-4255 - Fax


    ________________________________________________
    Kerberos mailing list Kerberos@mit.edu
    https://mailman.mit.edu/mailman/listinfo/kerberos


  2. Re: Kerberos for Windows 3.0/3.1

    Be sure you are using the version of the afs plugin that matches
    KFW 3.1 Beta 1. You can obtain it from https://www.secure-endpoints.com

    The actual problem is an error in OpenAFS. OpenAFS does not properly
    clean up its resources when its libraries are unloaded before the
    termination of the process. This causes the exception. NetIDMgr 1.1
    provides a work around by allowing plug-ins to request that they not
    be unloaded. The most recent AFS plug-in makes the request. The older
    plug-in does not.

    Jeffrey Altman


    Jeff Hagley wrote:
    > I upgraded my Kfw from 2.6.5 to 3.0 and found out that I could not add an
    > identity, so I could not log in to my realm. I then installed kfw 3.1 beta
    > and the openafs module. I could login in, but after I logged in the program
    > would perform an illegal operation and crash. I looked at the problem and
    > it was the afsauthent.dll Anyone have any ideas? Thanks
    >
    > Jeff Hagley
    > System Administrator
    >
    > Internet2
    >
    > 1000 Oakbrook Dr., Suite 300
    > Ann Arbor, MI 48104
    >
    > (734) 352-4247 - Office
    > (734) 652-4687 - Mobile
    > (734) 913-4255 - Fax
    >
    >
    > ________________________________________________
    > Kerberos mailing list Kerberos@mit.edu
    > https://mailman.mit.edu/mailman/listinfo/kerberos
    >


  3. Re: Kerberos for Windows 3.0/3.1

    Jeff

    I am running the latest NetIDMgr release I think (file version 1.1.0.1) and
    afs plugin but the NetIDMgr is still crashing. Are there any debug files
    that would help? The afs version is a little olf 1.5.0.5 I think so I will
    upgrade that to see if that helps.


    Cheers

    Matt

    On 7/28/06, Jeffrey Altman wrote:
    >
    > Be sure you are using the version of the afs plugin that matches
    > KFW 3.1 Beta 1. You can obtain it from https://www.secure-endpoints.com
    >
    > The actual problem is an error in OpenAFS. OpenAFS does not properly
    > clean up its resources when its libraries are unloaded before the
    > termination of the process. This causes the exception. NetIDMgr 1.1
    > provides a work around by allowing plug-ins to request that they not
    > be unloaded. The most recent AFS plug-in makes the request. The older
    > plug-in does not.
    >
    >

    ________________________________________________
    Kerberos mailing list Kerberos@mit.edu
    https://mailman.mit.edu/mailman/listinfo/kerberos


+ Reply to Thread