Re: KfW 3.2.2 and plink on Vista - Kerberos

This is a discussion on Re: KfW 3.2.2 and plink on Vista - Kerberos ; On Wed, 30 Jul 2008, Jeffrey Altman wrote: > petesea@bigfoot.com wrote: > >> If it's plink (and I'm not saying it isn't), then why does plink work >> fine on Vista using KfW 3.1.0? It's only Vista using KfW 3.2.2 ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Re: KfW 3.2.2 and plink on Vista

  1. Re: KfW 3.2.2 and plink on Vista

    On Wed, 30 Jul 2008, Jeffrey Altman wrote:

    > petesea@bigfoot.com wrote:
    >
    >> If it's plink (and I'm not saying it isn't), then why does plink work
    >> fine on Vista using KfW 3.1.0? It's only Vista using KfW 3.2.2 that
    >> triggers the problem. In other words, what's different between 3.1.0
    >> and 3.2.2 that triggers the problem... and only on Vista?

    >
    > Its not Vista. Its KFW 3.1 vs 3.2.


    So how come 3.2 works fine with my existing plink on XP? Sorry, not
    trying to be difficult, I just need to be able to clarify (to my
    management) why we only see this on Vista and what it will take to fix it.

    > The GSSAPI implementation was replaced between those releases. In 3.1 a
    > single mechanism GSSAPI implementation was included. In 3.2 a
    > multi-mechanism implementation is included. In 3.1 the GSSAPI could
    > refuse to deallocate memory that wasn't allocated by the mechanism. In
    > 3.2 the GSSAPI does not.
    >
    > plink/putty has a bug. I know it has a bug because the bug was fixed a
    > long time ago. the bug was masked by KFW 3.1 and is not masked by 3.2.


    OK. I wasn't trying to dispute the possibility of a bug in plink/putty...
    I was just looking for a more detailed explanation. Thanks for providing
    it. But I still would like to see a reason for why 3.2 works on XP if you
    know.

    > Please get a new putty.


    Unfortunately, since the GSSAPI patch I have is for 0.58, I'll need to do
    quite a bit of work to get it into 0.60 (the latest version of PuTTY).
    Since this problem only seems to occur with KfW 3.2.2, I need to weight
    the advantages of upgrading to 3.2.2 vs the time it will take to adapt my
    patch to PuTTY 0.60 and test.

  2. Re: KfW 3.2.2 and plink on Vista

    petesea@bigfoot.com wrote:
    > Unfortunately, since the GSSAPI patch I have is for 0.58, I'll need to do
    > quite a bit of work to get it into 0.60 (the latest version of PuTTY).
    > Since this problem only seems to occur with KfW 3.2.2, I need to weight
    > the advantages of upgrading to 3.2.2 vs the time it will take to adapt my
    > patch to PuTTY 0.60 and test.


    The version I have at http://matthew.loar.name/software/putty/ might
    save you some effort. I started with the GSSAPI patch from
    http://sweb.cz/v_t_m and have been following PuTTY trunk. I don't have
    a Vista box with KFW 3.2, so I'm afraid I can't speak to whether it
    would solve your problem.

    Matt Loar

+ Reply to Thread