Questions relating to Apache and SSL have nothing to do with
Kerberos. I think you would get much better help from a RedHat or
Apache list.

Once you get Apache+SSL working, I suggest you ask on modauthkerb-help@lists.sourceforge.net
about any mod_auth_kerb issues.

Is there a reason you're not using the Apache+SSL+mod_auth_kerb that
already are provided by RedHat? This is still probably not your best
forum, but I don't want to cut you off too short.

On Jun 30, 2008, at 5:45 AM, kul gupta wrote:
> On 6/30/08, kul gupta wrote:
> Hello
>
> I want to use the module "mod_auth_kerb" for the web authentication .
> Currently i m trying on RedHat enterprise linix 5.0
>
> I have Openssl 0.9.8 g installed on it
> But when i m trying to install "apachae with ssl " (apache 2.2.8 ),i
> m getting some error.
> Without ssl apache is getting installed properly
>
> i did
> ./configure --enable-ssl --enable-mods-shared=all
>
> then
>
> make
>
> Now i m getting following errors
> /ab.c:382:undefined reference to`BIO_get_callback_arg'
> /ab.c:1144: undefined reference to`BIO_set_callback'
> /ab.c:1144: undefined reference to`BIO_set_callback'
> /ab.c:1145: undefined reference to`BIO_set_callback_arg'
> .libs/ab.o: In function `main':
> ab.c:2154: undefined reference to`SSL_CTX_set_info_callback'
>
> Please help me out in resloving this issue
> Thanks
> kul
>
>
>
>
>
>
>
>
> On 6/30/08, Henry B. Hotz wrote:
> On Jun 29, 2008, at 9:15 AM, krbdev-request@mit.edu wrote:
>
> Message: 1
> Date: Sun, 29 Jun 2008 16:31:17 +0530
> From: "kul gupta"
> Subject: mod_auth_kerb+ apacahe+kerberos
> To: kerberos@mit.edu, krbdev@mit.edu, "Russ Allbery"
> , "Tadoori (EXT), Vilas"
> , "Jeffrey Hutzelman"
> >

> Message-ID:
> <2203f95e0806290401u7ce56bd7j3cd1532c811de8c2@mail. gmail.com>
> Content-Type: text/plain; charset=ISO-8859-1
>
> Hello
>
> I want to use the module "auth_mod_kerb" for the web authentication .
> Currently i m trying on RedHat enterprise linix 5.0
>
> I have Openssl 0.9.8 g installed on it
> But when i m trying to install "apachae with ssl " ,i m getting some
> error.
> Without ssl apache is getting installed properly
>
> Is it necessary to have "apache with ssl " for working with
> "auth_mod_kerb" ??
> If yes ,how can i proceed for the same
>
> I will highly appreciate if someone can help me on this issue.
>
>
> Thanks
> Regards
> KUL
>
> Not in the sense of just making the software work. It's a very good
> idea though.
>
> I'd say get ssl working first in a build with mod_so (dynamically
> loadable modules). Then add mod_auth_kerb afterwards.
>
> ------------------------------------------------------
> The opinions expressed in this message are mine,
> not those of Caltech, JPL, NASA, or the US Government.
> Henry.B.Hotz@jpl.nasa.gov, or hbhotz@oxy.edu
>
>
>
>
>