It looks like your /usr/lib/tclConfig.sh or your configure script is
corrupt.

"configure" is a script, which you can read. Looking through it you will
see it finds and runs /usr/lib/tclConfig.sh
which sets among other things:
TCL_PREFIX

.... then it runs this bit of code:
if test -n "$tcl_ok_conf" ; then
. $tcl_ok_conf
TCL_INCLUDES=
for incdir in "$TCL_PREFIX/include/tcl$v" "$TCL_PREFIX/include" ; do
if test -r "$incdir/tcl.h" -o -r "$incdir/tcl/tcl.h" ; then
if test "$incdir" != "/usr/include" ; then
TCL_INCLUDES=-I$incdir
fi
break
fi
done
....

you are looking for tcl.h and tcl/tcl.h instead of
/usr/include/tcl.h and /usr/include/tcl/tcl.h

You can run util/reconf from your source directory to rebuild configure
(probably best to unpack your kerberos download first so you have a
fresh version of kerberos with no cache files in it)

Padmavathi Dt wrote:
> [safeTgram (optim1) receive status: NOT encrypted, NOT signed.]
>
>
> Hii List,
>
> I am trying to install krb5-1.6.3 on RHEL4.I have read the install guide
> and following that.I have following tcl packages installed on our sytem:
>
> tcl-8.4.7-2
> tclx-doc-8.3.5-4
> tcl-devel-8.4.7-2
> tclx-8.3.5-4
> tclx-devel-8.3.5-4
> tcl-html-8.4.7-2
>
> I am stuck in the very first step itself.
> When I run:
> [root@as3 src]# ./configure -- with-tcl=/usr --without-krb4
> the last few lines of output are:
>
> checking for pthread_once... (cached) no
> checking for pthread_rwlock_init... (cached) no
> configure: rechecking with PTHREAD_... options
> checking for pthread_rwlock_init in -lc... (cached) yes
> checking for library containing dlopen... (cached) -ldl
> checking for keyutils.h... (cached) no
> configure: disabling static libraries
> configure: enabling shared libraries
> checking for tclConfig.sh... /usr/lib/tclConfig.sh
> checking Tcl info in /usr/lib/tclConfig.sh... 8.4 - working
> checking for tcl.h... (cached) no
> checking for tcl/tcl.h... (cached) no
> configure: error: Could not find Tcl
>
> It reported that configure couldnot find tcl..
> The config.log regarding TCL says:
>
> SS_LIB=''
> SS_VERSION='k5'
> STLIBEXT='.a'
> STOBJEXT='.o'
> SUPPORTLIB_MAJOR='0'
> S_TOP='/home/access/LDAPSOFTWARES/krb5-1.6.3/src/.'
> TCL_INCLUDES=''
> TCL_LIBPATH='-L/usr/lib'
> TCL_LIBS='-L/usr/lib -ltcl8.4 -ldl -lieee -lm -ldl'
> TCL_MAYBE_RPATH=''
> TCL_RPATH=':/usr/lib'
> THREAD_SUPPORT='1'
> YACC='byacc'
> Then I tried configure as:
>
> [root@as3 src]# ./configure --with-tcl=/usr --without-krb4
> CPPFLAGS='-I/usr/include' LDFLAGS='-L/usr/lib'
>
> Even then I got the same error and the config.log now says:
> SS_LIB=''
> SS_VERSION='k5'
> STLIBEXT='.a'
> STOBJEXT='.o'
> SUPPORTLIB_MAJOR=''
> S_TOP=''
> TCL_INCLUDES=''
> TCL_LIBPATH='-L/usr/lib'
> TCL_LIBS='-L/usr/lib -ltcl8.4 -ldl -lieee -lm -ldl'
> TCL_MAYBE_RPATH=''
> TCL_RPATH=':/usr/lib'
> THREAD_SUPPORT='1'
> YACC=''
>
> In both the cases,according to config.log,thehighlighted values are same
> irrespective of the options given along with configure command
>
> (our "tcl.h" is present in /usr/incude which I passed through CPPFLAGS)
>
> Anyone please help me as soon as possible how to solve the above problem
>
> Waiting for help...
>
> Padmavathi
> =====-----=====-----=====
> Notice: The information contained in this e-mail
> message and/or attachments to it may contain
> confidential or privileged information. If you are
> not the intended recipient, any dissemination, use,
> review, distribution, printing or copying of the
> information contained in this e-mail message
> and/or attachments to it are strictly prohibited. If
> you have received this communication in error,
> please notify us by reply e-mail or telephone and
> immediately and permanently delete the message
> and any attachments. Thank you
>
>
> ________________________________________________
> Kerberos mailing list Kerberos@mit.edu
> https://mailman.mit.edu/mailman/listinfo/kerberos
>
>
>
>