"J D Cassidy" writes:

> I am trying to set up a minimal Kerberos configuration on a Debian
> 64-bit, Kernel 2.6.23 Intel box. When I run the usual apt-get commands
> (apt-get install krb5-{admin-server,kdc}), I am seeing the following
> error(s):
>
> Unpacking krb5-kdc (from .../krb5-kdc_1.6.dfsg.3~beta1-4_amd64.deb) ...
> Selecting previously deselected package krb5-admin-server.
> Unpacking krb5-admin-server (from
> .../krb5-admin-server_1.6.dfsg.3~beta1-4_amd64.deb) ...
> Setting up krb5-kdc (1.6.dfsg.3~beta1-4) ...
> Setting up krb5-admin-server (1.6.dfsg.3~beta1-4) ...
> kadmind: Improper format of Kerberos configuration file while initializing
> context, aborting
> Europa:~# uname -ars
> Linux Europa 2.6.23.14 #3 SMP Sat Feb 9 15:40:09 CET 2008 x86_64 GNU/Linux
>
> At this stage, I have NOT changed / edited the config file - etc/krb5.conf.


I don't see anything obviously wrong with that file, but I would still
start by deleting /etc/krb5.conf and running dpkg-reconfigure krb5-config
to create a new one to see if that helps.

--
Russ Allbery (rra@stanford.edu)