Fedora Core 3 Unofficial KDE RPM dependency issues - KDE

This is a discussion on Fedora Core 3 Unofficial KDE RPM dependency issues - KDE ; Hello all! I'm a semi-new Linux user (about 9ish months). I've used Mandrake and I'm currently running Fedora Core 3. I wanted to upgrade to the newest version of KDE (3.3.2, and I'm currently running 3.1.1). I downloaded the unofficial ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Fedora Core 3 Unofficial KDE RPM dependency issues

  1. Fedora Core 3 Unofficial KDE RPM dependency issues

    Hello all!

    I'm a semi-new Linux user (about 9ish months). I've used Mandrake and
    I'm currently running Fedora Core 3. I wanted to upgrade to the newest
    version of KDE (3.3.2, and I'm currently running 3.1.1). I downloaded
    the unofficial KDE RPMs off of KDE's website and I attempted to install
    them. I got a list of dependency issues, and I began to try to resolve
    them. I ran into an issue which I'm unsure how to resolve. This is
    the list of dependency errors I received:

    [KDE]$ rpm -ivh *
    warning: arts-1.3.2-1.0.3.kde.i386.rpm: V3 DSA signature: NOKEY, key ID
    ff6382fa
    error: Failed dependencies:
    libmad.so.0 is needed by arts-1.3.2-1.0.3.kde.i386
    libHalf.so.2 is needed by kdegraphics-3.3.2-1.0.3.kde.i386
    libIex.so.2 is needed by kdegraphics-3.3.2-1.0.3.kde.i386
    libIlmImf.so.2 is needed by kdegraphics-3.3.2-1.0.3.kde.i386
    libImath.so.2 is needed by kdegraphics-3.3.2-1.0.3.kde.i386
    libfribidi.so.0 is needed by kdegraphics-3.3.2-1.0.3.kde.i386
    liblcms.so.1 is needed by kdegraphics-3.3.2-1.0.3.kde.i386
    libHalf.so.2 is needed by kdelibs-3.3.2-1.2.3.kde.i386
    libIex.so.2 is needed by kdelibs-3.3.2-1.2.3.kde.i386
    libIlmImf.so.2 is needed by kdelibs-3.3.2-1.2.3.kde.i386
    libImath.so.2 is needed by kdelibs-3.3.2-1.2.3.kde.i386
    libjasper-1.701.so.1 is needed by kdelibs-3.3.2-1.2.3.kde.i386
    libmad.so.0 is needed by kdemultimedia-3.3.2-1.0.3.kde.i386
    libmp3lame.so.0 is needed by kdemultimedia-3.3.2-1.0.3.kde.i386
    libmusicbrainz.so.4 is needed by
    kdemultimedia-3.3.2-1.0.3.kde.i386
    libtag.so.1 is needed by kdemultimedia-3.3.2-1.0.3.kde.i386
    libtunepimp.so.2 is needed by
    kdemultimedia-3.3.2-1.0.3.kde.i386
    libxine.so.1 is needed by kdemultimedia-3.3.2-1.0.3.kde.i386
    libslp.so.1 is needed by kdenetwork-3.3.2-1.0.3.kde.i386
    /usr/bin/pinentry-qt is needed by kdepim-3.3.2-1.2.3.kde.i386
    libgnokii.so.2 is needed by kdepim-3.3.2-1.2.3.kde.i386
    libgpgme.so.11 is needed by kdepim-3.3.2-1.2.3.kde.i386
    libgpgme.so.11(GPGME_1.0) is needed by
    kdepim-3.3.2-1.2.3.kde.i386
    libmal.so.0 is needed by kdepim-3.3.2-1.2.3.kde.i386
    graphviz is needed by kdesdk-3.3.2-1.0.3.kde.i386
    valgrind >= 0:2.0.0 is needed by kdesdk-3.3.2-1.0.3.kde.i386
    fortune-mod is needed by kdetoys-3.3.2-1.0.3.kde.i386
    libmysqlclient.so.10 is needed by
    qt-MySQL-3.3.3-15.1.3.kde.i386
    libodbc.so.1 is needed by qt-ODBC-3.3.3-15.1.3.kde.i386
    libpq.so.3 is needed by qt-PostgreSQL-3.3.3-15.1.3.kde.i386

    I found the libmad with the file to resolve the arts dependency issue,
    compiled the library from the sources, install it (no issues), but when
    I reran the install, I received the same dependency issue. How do I
    get RPM to pick up the installed .so?

    Thanks!


  2. Re: Fedora Core 3 Unofficial KDE RPM dependency issues

    On Fri, 25 Feb 2005 at 03:10 GMT, Johnathon Tieman eloquently wrote:
    > Hello all!
    >
    > I'm a semi-new Linux user (about 9ish months). I've used Mandrake and
    > I'm currently running Fedora Core 3. I wanted to upgrade to the newest
    > version of KDE (3.3.2, and I'm currently running 3.1.1). I downloaded
    > the unofficial KDE RPMs off of KDE's website and I attempted to install
    > them. I got a list of dependency issues, and I began to try to resolve
    > them. I ran into an issue which I'm unsure how to resolve. This is
    > the list of dependency errors I received:

    FC3 uses yum. Add a yum repo for http://kde-redhat.sourceforge.net/
    and use yum to do the upgrade. Yum will solve the dependency issue
    for you.

    N.Emile...
    --
    Registered Linux User # 125653 (http://counter.li.org) | Please remove
    Certified: 75% bastard, 42% of which is tard. | '.invalid'
    http://www.thespark.com/bastardtest | to reply.
    Switch to: http://www.speakeasy.net/refer/190653

  3. Re: Fedora Core 3 Unofficial KDE RPM dependency issues

    Wow, that worked great! Had to figure out what public key I needed,
    but then yum took care of the rest. Thanks!


  4. Re: Fedora Core 3 Unofficial KDE RPM dependency issues: OPT-GET + SYNAPTIC (GUI).

    Also Fedora, has rpms for ap-get and synaptic (a GUI front-end to apt-get).
    Synaptic is great to install & reslove dependencies: clean and esy to use
    GUI, nice features like broken links detection.

    YUM is great (similar to apt-get), GYUM (GUI front-end) is new... and green,
    so far not as good as Synaptic, but it kust came out.

    AFC3
    ------------------------------------------
    ne... wrote:

    > On Fri, 25 Feb 2005 at 03:10 GMT, Johnathon Tieman eloquently wrote:
    >> Hello all!
    >>
    >> I'm a semi-new Linux user (about 9ish months). I've used Mandrake and
    >> I'm currently running Fedora Core 3. I wanted to upgrade to the newest
    >> version of KDE (3.3.2, and I'm currently running 3.1.1). I downloaded
    >> the unofficial KDE RPMs off of KDE's website and I attempted to install
    >> them. I got a list of dependency issues, and I began to try to resolve
    >> them. I ran into an issue which I'm unsure how to resolve. This is
    >> the list of dependency errors I received:

    > FC3 uses yum. Add a yum repo for http://kde-redhat.sourceforge.net/
    > and use yum to do the upgrade. Yum will solve the dependency issue
    > for you.
    >
    > N.Emile...



+ Reply to Thread