Re: OpenBSD 4.2 upgrade to 4.3 breaks kde and konqueror - KDE

This is a discussion on Re: OpenBSD 4.2 upgrade to 4.3 breaks kde and konqueror - KDE ; dfeustel@mindspring.com wrote: > I just upgraded 64-bit AMD OpenBSD 4.2 to 4.3. The upgrade breaks kde > (startkde fails even when started from X) and konqueror (konqueror will > not start in X). Several undefined symbols were reported by the ...

+ Reply to Thread
Results 1 to 7 of 7

Thread: Re: OpenBSD 4.2 upgrade to 4.3 breaks kde and konqueror

  1. Re: OpenBSD 4.2 upgrade to 4.3 breaks kde and konqueror

    dfeustel@mindspring.com wrote:
    > I just upgraded 64-bit AMD OpenBSD 4.2 to 4.3. The upgrade breaks kde
    > (startkde fails even when started from X) and konqueror (konqueror will
    > not start in X). Several undefined symbols were reported by the loader.


    Think it's easier to say if we would get that error list. Most likely
    some library that hasn't been properly installed, could it be that wrong
    version of QT is installed ?



    --

    //Aho

  2. Re: OpenBSD 4.2 upgrade to 4.3 breaks kde and konqueror

    J.O. Aho wrote:
    > dfeustel@mindspring.com wrote:
    >> I just upgraded 64-bit AMD OpenBSD 4.2 to 4.3. The upgrade breaks kde
    >> (startkde fails even when started from X) and konqueror (konqueror will
    >> not start in X). Several undefined symbols were reported by the loader.

    >
    > Think it's easier to say if we would get that error list. Most likely
    > some library that hasn't been properly installed, could it be that wrong
    > version of QT is installed ?
    >
    >

    At this point I have no idea what went wrong. The last 4 or so updates
    of OpenBSD I've done have just worked. Firefox works so I have decided
    to just use Firefox in X rather than doing a completely fresh install to
    get a working kde/konqueror.

    Here is the error log:

    (from an xterm window)

    2/home/daf}startkde
    kde-config:/usr/local/lib/libqt-mt.so.31.1: undefined symbol
    '__cxa_atexit'
    lazy binding failed!
    Segmentation fault (core dumped)
    startkde: Starting up...
    ksplash:/usr/local/lib/libqt-mt.so.31.1: undefined symbol '__cxa_atexit'
    lazy binding failed!
    Segmentation fault (core dumped)
    /usr/local/bin/kdeinit:/usr/X11R6/lib/libX11.so.11.1: undefined symbol
    'recalloc'
    /usr/local/bin/kdeinit:/usr/lib/libstdc++.so.44.0: undefined symbol
    '__cxa_atexit'
    /usr/local/bin/kdeinit:/usr/local/lib/libqt-mt.so.31.1: undefined symbol
    '__cxa_atexit'
    /usr/local/bin/kdeinit:/usr/local/lib/libfam.so.0.0: undefined symbol
    '__cxa_atexit'
    Segmentation fault (core dumped)
    startkde: Could not start kdeinit. Check your installation.
    Warning: connect() failed: : No such file or directory
    ksmserver:/usr/local/lib/libqt-mt.so.31.1: undefined symbol
    '__cxa_atexit'
    lazy binding failed!
    Segmentation fault (core dumped)
    dcop:/usr/local/lib/libqt-mt.so.31.1: undefined symbol '__cxa_atexit'
    lazy binding failed!
    Segmentation fault (core dumped)
    startkde: Shutting down...
    Warning: connect() failed: : No such file or directory
    Error: Can't contact kdeinit!
    startkde: Running shutdown scripts...
    startkde: Done.
    2/home/daf}


  3. Re: OpenBSD 4.2 upgrade to 4.3 breaks kde and konqueror

    dfeustel@mindspring.com wrote:
    > J.O. Aho wrote:
    >> dfeustel@mindspring.com wrote:
    >>> I just upgraded 64-bit AMD OpenBSD 4.2 to 4.3. The upgrade breaks kde
    >>> (startkde fails even when started from X) and konqueror (konqueror will
    >>> not start in X). Several undefined symbols were reported by the loader.

    >> Think it's easier to say if we would get that error list. Most likely
    >> some library that hasn't been properly installed, could it be that wrong
    >> version of QT is installed ?
    >>
    >>

    > At this point I have no idea what went wrong. The last 4 or so updates
    > of OpenBSD I've done have just worked. Firefox works so I have decided
    > to just use Firefox in X rather than doing a completely fresh install to
    > get a working kde/konqueror.


    Try to reinstall KDE (remove the packages you already downloaded), I
    think it's something wrong with the version of KDE you installed.

    --

    //Aho

  4. Re: OpenBSD 4.2 upgrade to 4.3 breaks kde and konqueror

    J.O. Aho wrote:
    > dfeustel@mindspring.com wrote:
    >> J.O. Aho wrote:
    >>> dfeustel@mindspring.com wrote:
    >>>> I just upgraded 64-bit AMD OpenBSD 4.2 to 4.3. The upgrade breaks kde
    >>>> (startkde fails even when started from X) and konqueror (konqueror will
    >>>> not start in X). Several undefined symbols were reported by the loader.
    >>> Think it's easier to say if we would get that error list. Most likely
    >>> some library that hasn't been properly installed, could it be that wrong
    >>> version of QT is installed ?
    >>>
    >>>

    >> At this point I have no idea what went wrong. The last 4 or so updates
    >> of OpenBSD I've done have just worked. Firefox works so I have decided
    >> to just use Firefox in X rather than doing a completely fresh install to
    >> get a working kde/konqueror.

    >
    > Try to reinstall KDE (remove the packages you already downloaded), I
    > think it's something wrong with the version of KDE you installed.


    I tried to do a "pkg_add -u -i kdebase". The log is attached. Sorry about
    the ctl-Ms. I have forgotten how to convert them to carriage returns.


    Script started on Fri May 30 15:26:23 2008
    2:/root#pkg_add -u -i kdebase
    Looking for updates|No need to update fam-2.7.0p3 Looking for updates|No need to update gettext-0.16.1 Candidates for updating kdebase-3.5.7p0 -> kdebase-3.5.8p1
    Candidates for updating openldap-client-2.3.33 -> openldap-client-2.3.39
    Looking for updates|No need to update arts-1.5.8 Looking for updates|No need to update libiconv-1.9.2p5 Looking for updates|No need to update cyrus-sasl-2.1.22p2 Looking for updates|No need to update libusb-0.1.12 Looking for updates|No need to update qt3-mt-3.8p0 Looking for updates|No need to update jpeg-6bp3 Candidates for updating libxml-2.6.29 -> libxml-2.6.30
    Looking for updates|No need to update libmng-1.0.9p1 Looking for updates|No need to update libmad-0.15.1bp1 Looking for updates|No need to update OpenEXR-1.2.2p3 Candidates for updating kdelibs-3.5.7 -> kdelibs-3.5.8p3
    Candidates for updating libgcrypt-1.2.0p1 -> libgcrypt-1.2.4
    Candidates for updating lcms-1.15 -> lcms-1.15
    Not updating .libs-pcre-7.1, remember to clean it
    Looking for updates|No need to update esound-0.2.34p1v0 Looking for updates|No need to update png-1.2.22 Looking for updates|No need to update aspell-0.50.5p4 Looking for updates|No need to update libaudiofile-0.2.6p0 Looking for updates|No need to update libogg-1.1.3 Not updating .libs-glib2-2.12.12p1, remember to clean it
    Candidates for updating libxslt-1.1.21 -> libxslt-1.1.22
    Looking for updates|No need to update jasper-1.900.1 Candidates for updating libart-2.3.19p1 -> libart-2.3.20
    Looking for updates|No need to update bzip2-1.0.4 Looking for updates|No need to update glib2-2.14.5 Candidates for updating libgpg-error-1.1p0 -> libgpg-error-1.5
    Looking for updates|No need to update tiff-3.8.2p0 Not updating .libs-png-1.2.18, remember to clean it
    Not updating .libs-gettext-0.14.6p0, remember to clean it
    Candidates for updating hicolor-icon-theme-0.10p0 -> hicolor-icon-theme-0.10p1
    Looking for updates|No need to update pcre-7.6 Looking for updates|No need to update libvorbis-1.2.0 Looking for updates|No need to update libidn-1.1 Looking for updates: complete
    Running the equivalent of pkg_add -r kdebase-3.5.8p1 openldap-client-2.3.39 libxml-2.6.30 kdelibs-3.5.8p3 libgcrypt-1.2.4 lcms-1.15 libxslt-1.1.22 libart-2.3.20 libgpg-error-1.5 hicolor-icon-theme-0.10p1
    New package kdebase-3.5.8p1 contains potentially unsafe operations
    @exec /usr/local/bin/update-desktop-database
    proceed with update anyways? [y/N/a]
    Can't safely update to kdebase-3.5.8p1 (use -F update to force it)
    /usr/sbin/pkg_add: kdebase-3.5.8p1:Fatal error
    2:/root#exit

    Script done on Fri May 30 15:27:29 2008

  5. Re: OpenBSD 4.2 upgrade to 4.3 breaks kde and konqueror

    I removed all the kde modules and tried to reinstall kde with
    the command pkg_add -i kdelibs. That failed, log follows:

    Script started on Fri May 30 16:34:00 2008
    2:/root#pkg_add -i kdelibs
    Can't install kdelibs-3.5.8p3: lib not found art_lgpl_2.5.20
    Dependencies for kdelibs-3.5.8p3 resolve to: qt3-mt-3.8p0, fam-2.7.0p3, bzip2-1.0.4, tiff-3.8.2p0, arts-1.5.8, hicolor-icon-theme-0.10p0, aspell-0.50.5p4, pcre-7.6, OpenEXR-1.2.2p3, desktop-file-utils-0.14p1, libxslt-1.1.21, libidn-1.1, jasper-1.900.1, libart-2.3.19p1
    Full dependency tree is fam-2.7.0p3,lcms-1.15,gettext-0.16.1,esound-0.2.34p1v0,png-1.2.22,arts-1.5.8,libiconv-1.9.2p5,libaudiofile-0.2.6p0,aspell-0.50.5p4,libogg-1.1.3,libxslt-1.1.21,libart-2.3.19p1,jasper-1.900.1,bzip2-1.0.4,qt3-mt-3.8p0,jpeg-6bp3,glib2-2.14.5,libgpg-error-1.1p0,tiff-3.8.2p0,libxml-2.6.29,.libs-gettext-0.14.6p0,libmng-1.0.9p1,hicolor-icon-theme-0.10p0,pcre-7.6,libmad-0.15.1bp1,libvorbis-1.2.0,OpenEXR-1.2.2p3,desktop-file-utils-0.14p1,libgcrypt-1.2.0p1,libidn-1.1
    art_lgpl_2.5.20: partial match in /usr/local/lib: major=5, minor=19 (minor not large enough)
    Can't install kdelibs-3.5.8p3: lib not found xml2.9.7
    xml2.9.7: partial match in /usr/local/lib: major=9, minor=6 (minor not large enough)
    Can't install kdelibs-3.5.8p3: lib not found xslt.3.5
    xslt.3.5: partial match in /usr/local/lib: major=3, minor=4 (minor not large enough)
    2:/root#exit

    Script done on Fri May 30 16:34:21 2008

  6. Re: OpenBSD 4.2 upgrade to 4.3 breaks kde and konqueror

    YANSWBVCG wrote:
    > I removed all the kde modules and tried to reinstall kde with
    > the command pkg_add -i kdelibs. That failed, log follows:
    >
    > Script started on Fri May 30 16:34:00 2008
    > 2:/root#pkg_add -i kdelibs
    > Can't install kdelibs-3.5.8p3: lib not found art_lgpl_2.5.20
    > Dependencies for kdelibs-3.5.8p3 resolve to: qt3-mt-3.8p0, fam-2.7.0p3, bzip2-1.0.4, tiff-3.8.2p0, arts-1.5.8, hicolor-icon-theme-0.10p0, aspell-0.50.5p4, pcre-7.6, OpenEXR-1.2.2p3, desktop-file-utils-0.14p1, libxslt-1.1.21, libidn-1.1, jasper-1.900.1, libart-2.3.19p1
    > Full dependency tree is fam-2.7.0p3,lcms-1.15,gettext-0.16.1,esound-0.2.34p1v0,png-1.2.22,arts-1.5.8,libiconv-1.9.2p5,libaudiofile-0.2.6p0,aspell-0.50.5p4,libogg-1.1.3,libxslt-1.1.21,libart-2.3.19p1,jasper-1.900.1,bzip2-1.0.4,qt3-mt-3.8p0,jpeg-6bp3,glib2-2.14.5,libgpg-error-1.1p0,tiff-3.8.2p0,libxml-2.6.29,.libs-gettext-0.14.6p0,libmng-1.0.9p1,hicolor-icon-theme-0.10p0,pcre-7.6,libmad-0.15.1bp1,libvorbis-1.2.0,OpenEXR-1.2.2p3,desktop-file-utils-0.14p1,libgcrypt-1.2.0p1,libidn-1.1
    > art_lgpl_2.5.20: partial match in /usr/local/lib: major=5, minor=19 (minor not large enough)
    > Can't install kdelibs-3.5.8p3: lib not found xml2.9.7
    > xml2.9.7: partial match in /usr/local/lib: major=9, minor=6 (minor not large enough)
    > Can't install kdelibs-3.5.8p3: lib not found xslt.3.5
    > xslt.3.5: partial match in /usr/local/lib: major=3, minor=4 (minor not large enough)
    > 2:/root#exit
    >
    > Script done on Fri May 30 16:34:21 2008


    Somehow it seems like you package manager don't download the files
    again, sadly I don't know much about the package manager in OpenBSD, I
    would suggest you take a look at alt.os.openbsd or/and
    comp.unix.bsd.openbsd.misc (not sure if they are active).

    --

    //Aho

  7. Re: OpenBSD 4.2 upgrade to 4.3 breaks kde and konqueror

    J.O. Aho wrote:
    > YANSWBVCG wrote:
    >> I removed all the kde modules and tried to reinstall kde with
    >> the command pkg_add -i kdelibs. That failed, log follows:
    >>
    >> Script started on Fri May 30 16:34:00 2008
    >> 2:/root#pkg_add -i kdelibs
    >> Can't install kdelibs-3.5.8p3: lib not found art_lgpl_2.5.20
    >> Dependencies for kdelibs-3.5.8p3 resolve to: qt3-mt-3.8p0, fam-2.7.0p3, bzip2-1.0.4, tiff-3.8.2p0, arts-1.5.8, hicolor-icon-theme-0.10p0, aspell-0.50.5p4, pcre-7.6, OpenEXR-1.2.2p3, desktop-file-utils-0.14p1, libxslt-1.1.21, libidn-1.1, jasper-1.900.1, libart-2.3.19p1
    >> Full dependency tree is fam-2.7.0p3,lcms-1.15,gettext-0.16.1,esound-0.2.34p1v0,png-1.2.22,arts-1.5.8,libiconv-1.9.2p5,libaudiofile-0.2.6p0,aspell-0.50.5p4,libogg-1.1.3,libxslt-1.1.21,libart-2.3.19p1,jasper-1.900.1,bzip2-1.0.4,qt3-mt-3.8p0,jpeg-6bp3,glib2-2.14.5,libgpg-error-1.1p0,tiff-3.8.2p0,libxml-2.6.29,.libs-gettext-0.14.6p0,libmng-1.0.9p1,hicolor-icon-theme-0.10p0,pcre-7.6,libmad-0.15.1bp1,libvorbis-1.2.0,OpenEXR-1.2.2p3,desktop-file-utils-0.14p1,libgcrypt-1.2.0p1,libidn-1.1
    >> art_lgpl_2.5.20: partial match in /usr/local/lib: major=5, minor=19 (minor not large enough)
    >> Can't install kdelibs-3.5.8p3: lib not found xml2.9.7
    >> xml2.9.7: partial match in /usr/local/lib: major=9, minor=6 (minor not large enough)
    >> Can't install kdelibs-3.5.8p3: lib not found xslt.3.5
    >> xslt.3.5: partial match in /usr/local/lib: major=3, minor=4 (minor not large enough)
    >> 2:/root#exit
    >>
    >> Script done on Fri May 30 16:34:21 2008

    >
    > Somehow it seems like you package manager don't download the files
    > again, sadly I don't know much about the package manager in OpenBSD, I
    > would suggest you take a look at alt.os.openbsd or/and
    > comp.unix.bsd.openbsd.misc (not sure if they are active).


    I deleted the qt package and its dependents and then added them again.
    Then I tried to add kdebase again. The pkg_add for kdebase failed.
    As best I can tell there are 2 packages needed by kdebase that are not
    available in the package repository. There also is a warning message
    about an unsafe operation detected by the package manager which caused
    me to abort the install. I'm now in the process of switching to FreeBSD
    for graphics apps like Maxima and TeX.

+ Reply to Thread