libkdnssd.so.1.0.0 is wrongly requiring a devel file libdns_sd.so, so this =

causes that rpm kdelibs packages require a mdns devel package, please check:

64]# ldd /usr/lib64/libkdnssd.so.1.0.0
libkdecore.so.4 =3D> /usr/lib64/libkdecore.so.4 (0x00002aaaaabf0000)
libqt-mt.so.3 =3D> /usr/lib/qt3/lib64/libqt-mt.so.3 (0x00002aaaaaf9=
a000)
libpthread.so.0 =3D> /lib64/tls/libpthread.so.0 (0x00002aaaab89a000)
libdns_sd.so =3D> /usr/lib64/libdns_sd.so (0x00002aaaab9b0000)
libstdc++.so.6 =3D> /usr/lib64/libstdc++.so.6 (0x00002aaaabab5000)
libc.so.6 =3D> /lib64/tls/libc.so.6 (0x00002aaaabcb0000)
libDCOP.so.4 =3D> /usr/lib64/libDCOP.so.4 (0x00002aaaabee9000)
libart_lgpl_2.so.2 =3D> /usr/lib64/libart_lgpl_2.so.2 =

(0x00002aaaac025000)
libidn.so.11 =3D> /usr/lib64/libidn.so.11 (0x00002aaaac13c000)
libkdefx.so.4 =3D> /usr/lib64/libkdefx.so.4 (0x00002aaaac26e000)
libdl.so.2 =3D> /lib64/libdl.so.2 (0x00002aaaac39b000)
libz.so.1 =3D> /lib64/libz.so.1 (0x00002aaaac49e000)
libX11.so.6 =3D> /usr/X11R6/lib64/libX11.so.6 (0x00002aaaac5b4000)
libSM.so.6 =3D> /usr/X11R6/lib64/libSM.so.6 (0x00002aaaac794000)
libICE.so.6 =3D> /usr/X11R6/lib64/libICE.so.6 (0x00002aaaac89e000)
libm.so.6 =3D> /lib64/tls/libm.so.6 (0x00002aaaac9ba000)
libaudio.so.2 =3D> /usr/X11R6/lib64/libaudio.so.2 (0x00002aaaacb100=
00)
libXt.so.6 =3D> /usr/X11R6/lib64/libXt.so.6 (0x00002aaaacc29000)
libmng.so.1 =3D> /usr/lib64/libmng.so.1 (0x00002aaaacd8b000)
libjpeg.so.62 =3D> /usr/lib64/libjpeg.so.62 (0x00002aaaacef8000)
libpng.so.3 =3D> /usr/lib64/libpng.so.3 (0x00002aaaad01a000)
libXrender.so.1 =3D> /usr/X11R6/lib64/libXrender.so.1 =

(0x00002aaaad142000)
libXrandr.so.2 =3D> /usr/X11R6/lib64/libXrandr.so.2 (0x00002aaaad24=
b000)
libXcursor.so.1 =3D> /usr/X11R6/lib64/libXcursor.so.1 =

(0x00002aaaad34e000)
libXinerama.so.1 =3D> /usr/X11R6/lib64/libXinerama.so.1 =

(0x00002aaaad459000)
libXft.so.2 =3D> /usr/X11R6/lib64/libXft.so.2 (0x00002aaaad55b000)
libfreetype.so.6 =3D> /usr/lib64/libfreetype.so.6 (0x00002aaaad66f0=
00)
libfontconfig.so.1 =3D> /usr/lib64/libfontconfig.so.1 =

(0x00002aaaad7e3000)
libXext.so.6 =3D> /usr/X11R6/lib64/libXext.so.6 (0x00002aaaad922000)
libgcc_s.so.1 =3D> /lib64/libgcc_s.so.1 (0x00002aaaada33000)
/lib64/ld-linux-x86-64.so.2 (0x0000555555554000)
liblcms.so.1 =3D> /usr/lib64/liblcms.so.1 (0x00002aaaadb41000)
libXfixes.so.3 =3D> /usr/X11R6/lib64/libXfixes.so.3 (0x00002aaaadc7=
3000)
libexpat.so.0 =3D> /usr/lib64/libexpat.so.0 (0x00002aaaadd79000)

As the output we can see that is requiring the devel file :
libdns_sd.so =3D> /usr/lib64/libdns_sd.so (0x00002aaaab9b0000)

Theres also a similar case for kdepim but now i dont remember wich file is, =

but later after check i can report it.

greetings,
-- =

Z=E9
Linux user #378762
MDE Developer - www.mde.djura.org
=

>> Visit http://mail.kde.org/mailman/listinfo/kde-devel#unsub to unsubscrib=

e <<