--===============0898311157==
Content-Type: multipart/signed;
boundary="nextPart6899329.c78QgtpvtS";
protocol="application/pgp-signature";
micalg=pgp-sha1
Content-Transfer-Encoding: 7bit

--nextPart6899329.c78QgtpvtS
Content-Type: text/plain;
charset="utf-8"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

On Saturday 01 April 2006 13:36, Armine Karami wrote:
> Hi !
>
> I want to develop an application for KDE, but I don't know which version =

of
> Qt I must use for the GUI of the application.


If you want to release it short/mid-term (i.e. in the next weeks/months) an=
d=20
want it to be used by people before KDE4 release, use either Qt4 only, or, =
if=20
you want to use KDE libraries, KDE3 + Qt3 (>=3D3.3.2)
Writing new KDE4 applications at this point will be frustrating, as a) the=
=20
libs are changing constantly, and b) nobody will be able to actually use yo=
ur=20
software for quite some time.

If you decide to use Qt3, you might nevertheless have a look at Qt4 docs an=
d =20
http://doc.trolltech.com/4.1/porting4.html from time to time. There are som=
e=20
things one can do writing Qt3 code to make porting to Qt4 later easier (for=
=20
example, don't use QPtrList but QValueList).

Regards,

=46rank

--nextPart6899329.c78QgtpvtS
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQBELqn/FZrnbFOwfvQRAosFAJ0Xz+fsjG6tS1Yft8CW5o+UQkKsmACeNC s6
1zywXpkE9vYCzqQDc4ChgrY=
=vT8P
-----END PGP SIGNATURE-----

--nextPart6899329.c78QgtpvtS--

--===============0898311157==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline


>> Visit http://mail.kde.org/mailman/listinfo/kde-devel#unsub to unsubscribe <<


--===============0898311157==--