On Mon, Sep 12, 2005 at 11:40:46AM -0400, Benjamin Reed wrote:
> getting a strange build error in kdebase:
> =


> ---(snip!)---
> g++-3.3 -DHAVE_CONFIG_H -I. -I. -I../../.. -I./..
> -I../../../khotkeys/shared -I/sw/include -I/sw/include/qt
> -I/usr/X11R6/include -I/sw/include -DQT_THREAD_SUPPORT
> -I/sw/lib/system-openssl/include -I/sw/lib/freetype219/include/freetype2
> -I/sw/lib/freetype219/include -I/sw/lib/flex/include -fno-common
> -no-cpp-precomp -DMACOSX -DARTS_NO_ALARM -I/sw/include
> -I/usr/X11R6/include -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W
> -Wpointer-arith -Wno-non-virtual-dtor -Os -Os -fPIC -fno-exceptions
> -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST
> -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -D_GNU_SOURCE -c
> windowdef_simple_widget_ui.cpp -fno-common -DPIC -o
> .libs/windowdef_simple_widget_ui.o
> g++-3.3 -DHAVE_CONFIG_H -I. -I. -I../../.. -I./..
> -I../../../khotkeys/shared -I/sw/include -I/sw/include/qt
> -I/usr/X11R6/include -I/sw/include -DQT_THREAD_SUPPORT
> -I/sw/lib/system-openssl/include -I/sw/lib/freetype219/include/freetype2
> -I/sw/lib/freetype219/include -I/sw/lib/flex/include -fno-common
> -no-cpp-precomp -DMACOSX -DARTS_NO_ALARM -I/sw/include
> -I/usr/X11R6/include -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W
> -Wpointer-arith -Wno-non-virtual-dtor -Os -Os -fPIC -fno-exceptions
> -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST
> -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -D_GNU_SOURCE -c
> windowdef_list_widget_ui.cpp -fno-common -DPIC -o
> .libs/windowdef_list_widget_ui.o
> make[4]: *** [windowdef_list_widget_ui.lo] Error 1
> make[4]: *** Waiting for unfinished jobs....
> make[3]: *** [all-recursive] Error 1
> make[2]: *** [all-recursive] Error 1
> make[1]: *** [all-recursive] Error 1
> make: *** [all] Error 2
> ---(snip!)---
> =


> the perpetrator seems to be the line:
> =


> khotkeys::khlistview.h
> =


> ...in windowdef_list_widget_ui.ui. If I comment that out, the build
> continues.
> =


> I'm using Qt 3.3.5, could it be an issue with the new Qt? I know I've
> built this same thing a few weeks ago without incident, Qt is the only
> thing that's changed...
> =


> =



Yes, visit KDE bug 112550 (IIRC) for a patch or downgrade Qt to version
3.3.4
=

>> Visit http://mail.kde.org/mailman/listinfo/kde-devel#unsub to unsubscrib=

e <<