When I try to compile kdemultimedia first it fails to find akode during the =

configure phase:
....
checking for akode-config... no
....
aKode was not found. Without it the aKode aRts-plugin
will not be installed, and aRts will be.
unable to play many music formats.

And then during compilation I get this error:
In file included =

from /home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_im=
pl.cpp:41:
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/arts_inputstream.h:31:2=
4: =

bytebuffer.h: No such file or directory
In file included =

from /home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_im=
pl.cpp:41:
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/arts_inputstream.h:38: =

error: using-declaration for non-member at class scope
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/arts_inputstream.h:38: =

error: expected `;' before '*' token
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/arts_inputstream.h:43: =

error: `aKode::ByteBuffer' has not been declared
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/arts_inputstream.h:44: =

error: ISO C++ forbids declaration of `buffer' with no type
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/arts_inputstream.h: In =

constructor `Arts_InputStream::Arts_InputStream(Arts::InputStr eam, int*)':
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/arts_inputstream.h:45: =

error: class `Arts_InputStream' does not have any field named `m_buffer'
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/arts_inputstream.h: In =

member function `virtual long int Arts_InputStream::read(char*, long int)':
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/arts_inputstream.h:70: =

error: `m_buffer' undeclared (first use this function)
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/arts_inputstream.h:70: =

error: (Each undeclared identifier is reported only once for each function =
it =

appears in.)
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/arts_inputstream.h: In =

member function `virtual bool Arts_InputStream::seek(long int, int)':
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/arts_inputstream.h:101: =

error: `m_buffer' undeclared (first use this function)
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/arts_inputstream.h: In =

member function `virtual bool Arts_InputStream::eof() const':
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/arts_inputstream.h:134: =

error: `m_buffer' undeclared (first use this function)
In file included =

from /home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_im=
pl.cpp:57:
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.h:=
At =

global scope:
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.h:=
92: =

error: using-declaration for non-member at class scope
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.h:=
92: =

error: expected `;' before '*' token
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.cp=
p: =

In constructor `akodePlayObject_impl::akodePlayObject_impl(const =

std::string&)':
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.cp=
p:74: =

error: class `akodePlayObject_impl' does not have any field named =

`m_bytebuffer'
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.cp=
p: =

In member function `virtual bool =

akodePlayObject_impl::streamMedia(Arts::InputStrea m)':
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.cp=
p:97: =

error: `m_bytebuffer' undeclared (first use this function)
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.cp=
p:97: =

error: `aKode::ByteBuffer' has not been declared
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.cp=
p: =

In member function `void akodePlayObject_impl::unload()':
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.cp=
p:215: =

error: `m_bytebuffer' undeclared (first use this function)
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.cp=
p: =

In member function `bool akodePlayObject_impl::readFrame()':
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.cp=
p:306: =

error: `m_bytebuffer' undeclared (first use this function)
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.cp=
p: =

In member function `virtual void =

akodePlayObject_impl:rocess_indata(Arts:ataPacket*)':
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.cp=
p:463: =

error: `m_bytebuffer' undeclared (first use this function)
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.cp=
p: =

In member function `void akodePlayObject_impl:rocessQueue()':
/home/kdedev/src/kde/kdemultimedia/akode_artsplugin/akodePlayObject_impl.cp=
p:470: =

error: `m_bytebuffer' undeclared (first use this function)
make[2]: *** [akodePlayObject_impl.lo] Error 1
make[2]: Leaving directory =

`/home/kdedev/src/kde/build/kdemultimedia/akode_artsplugin'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/kdedev/src/kde/build/kdemultimedia'
make: *** [all] Error 2

The last time kdemultimedia compiled without a problem was on July 13th. Th=
is =

is with clean build, with automake. I guess this is caused by the recent mo=
ve =

of akode.

-- =

JLP's Blog - http://jrepin.blogspot.com/
=

>> Visit http://mail.kde.org/mailman/listinfo/kde-devel#unsub to unsubscrib=

e <<