QMQRY cannot find alias filed and dumps - IBM AS400

This is a discussion on QMQRY cannot find alias filed and dumps - IBM AS400 ; Hi all, A strange problem at my client's: We have 12 imlementations of the same software package, on the same OS/400 version (V5R3) and at the same level (both OS/400 and software package. The software uses QM Queries driven from ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: QMQRY cannot find alias filed and dumps

  1. QMQRY cannot find alias filed and dumps

    Hi all,

    A strange problem at my client's:
    We have 12 imlementations of the same software package, on the same
    OS/400 version (V5R3) and at the same level (both OS/400 and software
    package. The software uses QM Queries driven from ILECBL to obtain
    filtered data from a set of files. The files were compiled from DDS.

    On 2 systems, the software behaves as designed.
    On 10 systems, one of the QMQueries dumps with an SQL system error.

    The error message is: cannot find FIELD_1 in FILE_A. On DSPFFD, FIELD_1
    shows as an alias field (alternative name) for FIELD1.

    Using query, I cannot access FIELD_1, but I can access FIELD1.
    Using STRSQL, FIELD_1 is there and can be queried.

    What could be causing the differences in QMQuery behavior, given that
    all environments are supposedly identical, and the software is the same
    (rolled out through a CVS).

    Thanks

    --
    Vriendelijke groeten / Best regards,

    René H. Hartman
    www.hac-maarssen.nl

  2. Re: QMQRY cannot find alias filed and dumps

    Do all 12 AS/400s have exactly the same set of PTFs applied?


+ Reply to Thread