XML-Into: Tags with hyphen - IBM AS400

This is a discussion on XML-Into: Tags with hyphen - IBM AS400 ; The new "XML-into" verb in V5R4 makes it fairly easy to parse xml messages. BUT we have a problem: Many of the tags in the xml messages are named with hyphen (not underscore) as some standard AND as I see ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: XML-Into: Tags with hyphen

  1. XML-Into: Tags with hyphen

    The new "XML-into" verb in V5R4 makes it fairly easy to parse xml
    messages. BUT we have a problem:

    Many of the tags in the xml messages are named with hyphen (not
    underscore) as some standard AND as I see it there is a requirement
    that the term name in the datastructure matches the tag name exactly.

    Example:

    It the tag is I need to have a field in my DS as

    D customer-address

    BUT hyphen is not a valid character in the D-spec.

    Any work around?

    Ake


  2. Re: XML-Into: Tags with hyphen

    I haven't tried this, but could you use an ALIAS on the D spec ?


  3. Re: XML-Into: Tags with hyphen

    Checked the ile-rpg reference manual.

    No such keyword (ALIAS) available for the D spec.

    arrowcomputer@bigfoot.com wrote:
    > I haven't tried this, but could you use an ALIAS on the D spec ?



  4. Re: XML-Into: Tags with hyphen


    Load your tags in a compile time arrary or a database file. I like
    database files though.


  5. Re: XML-Into: Tags with hyphen

    AhaOhio wrote:
    >
    > Many of the tags in the xml messages are named with hyphen (not
    > underscore) as some standard AND as I see it there is a requirement
    > that the term name in the datastructure matches the tag name exactly.
    > ...


    Unfortunately, it is not possible to use XML-INTO with an XML document
    where the tags have characters that can't be used for RPG variable
    names.

+ Reply to Thread