HP vPAR Booting via Ignite server - HP UX

This is a discussion on HP vPAR Booting via Ignite server - HP UX ; Hi All, We are working on project where we are automating the capture and install of Golden Master image with Ignite-UX on HP endpoints. We require your help in this regards. We are creating a script to install golden master ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: HP vPAR Booting via Ignite server

  1. HP vPAR Booting via Ignite server

    Hi All,

    We are working on project where we are automating the capture and
    install of Golden Master image with Ignite-UX on HP endpoints.

    We require your help in this regards.

    We are creating a script to install golden master image on a bare
    metal vPAR.

    For this, we are considering the following scenario:
    1. We will configure the DHCP configuration (/etc/bootptab) to make
    entry for the new vPAR.
    2. vparboot -p - I command will be invoked.
    3. DHCP service running on Ignite server will capture DHCP request
    broadcasted by vPAR client and provide the booting file.
    4. vPAR receives boot file from Ignite server and starts booting.

    Here the booting process stops at the prompt, asking which version of
    OS to be installed on endpoint.
    - We need your inputs on how can we carry out image installation from
    Ignite server on a bare metal HP/vPAR machine, without any manual
    intervention.
    - We need to use command line interface instead of UI, as we want to
    automate it through scripts.

    Also please suggest, if there is any other alternative by which we can
    install golden master image on a bare metal vPAR or HP machine without
    involving Ignite server.
    - Is there any possibility to clone the image deployed on one vpar to
    the other which is yet to be booted. Or Can we configure Ignite server
    to pick some default values which could be mentioned before starting
    the image installation on bare metal machine like kickstart.

    Note: We are using vPAR on Itanium Hardware.

    Thanking you in anticipation,
    Pushkaraj

  2. Re: HP vPAR Booting via Ignite server

    On Tue, 29 Jul 2008 03:39:32 -0700 (PDT), Pushkaraj
    wrote:


    >Here the booting process stops at the prompt, asking which version of
    >OS to be installed on endpoint.
    >- We need your inputs on how can we carry out image installation from
    >Ignite server on a bare metal HP/vPAR machine, without any manual
    >intervention.
    >- We need to use command line interface instead of UI, as we want to
    >automate it through scripts.
    >
    >Also please suggest, if there is any other alternative by which we can
    >install golden master image on a bare metal vPAR or HP machine without
    >involving Ignite server.
    >- Is there any possibility to clone the image deployed on one vpar to
    >the other which is yet to be booted. Or Can we configure Ignite server
    >to pick some default values which could be mentioned before starting
    >the image installation on bare metal machine like kickstart.



    Have a look at these threads on itrc.hp.com:

    http://forums11.itrc.hp.com/service/...readId=1202705
    http://forums11.itrc.hp.com/service/...readId=1227498
    http://forums11.itrc.hp.com/service/...readId=1169318


  3. Re: HP vPAR Booting via Ignite server

    On Jul 29, 10:21*pm, Robert Klute wrote:
    > On Tue, 29 Jul 2008 03:39:32 -0700 (PDT),Pushkaraj
    >
    >
    >
    >
    >
    > wrote:
    > >Here the booting process stops at the prompt, asking which version of
    > >OS to be installed on endpoint.
    > >- We need your inputs on how can we carry out image installation from
    > >Ignite server on a bare metal HP/vPAR machine, without any manual
    > >intervention.
    > >- We need to use command line interface instead of UI, as we want to
    > >automate it through scripts.

    >
    > >Also please suggest, if there is any other alternative by which we can
    > >install golden master image on a bare metal vPAR or HP machine without
    > >involving Ignite server.
    > >- Is there any possibility to clone the image deployed on one vpar to
    > >the other which is yet to be booted. Or Can we configure Ignite server
    > >to pick some default values which could be mentioned before starting
    > >the image installation on bare metal machine like kickstart.

    >
    > Have a look at these threads on itrc.hp.com:
    >
    > http://forums11.itrc.hp.com/service/...o?threadId...- Hide quoted text -
    >
    > - Show quoted text -


    Hi Robert,

    Thank-you very much, I was successfully able to install a GM image on
    a baremetal HPUX machine.

    Hi All,
    I have a query on this, hope anyone can answer:
    In case, if client is not added on ignite server i.e. the client
    machine is totally new and its profile is not present under - /var/opt/
    ignite/client/0x{LLA}/.
    Then, the installation with same way fails with following error:

    * NFS mounting clients directory.
    * Using client directory: /var/opt/ignite/clients/
    0x0017087C4A3A
    ERROR: copy_file: Cannot open
    "/var/opt/ignite/clients/0x0017087C4A3A/install.log":
    Permission
    denied (errno = 13)
    ERROR: Could not move file: /tmp/install.log to
    /var/opt/ignite/clients/0x0017087C4A3A/install.log:
    Permission denied
    (errno = 13)
    ERROR: copy_file: Cannot open
    "/var/opt/ignite/clients/0x0017087C4A3A/config.sys":
    Permission denied
    (errno = 13)
    ERROR: Could not copy file: /tmp/config.sys to
    /var/opt/ignite/clients/0x0017087C4A3A/config.sys: Permission
    denied
    (errno = 13)
    ERROR: copy_file: Cannot open
    "/var/opt/ignite/clients/0x0017087C4A3A/hw.info": Permission
    denied
    (errno = 13)
    ERROR: Could not copy file: /tmp/hw.info to
    /var/opt/ignite/clients/0x0017087C4A3A/hw.info: Permission
    denied
    (errno = 13)
    ERROR: copy_file: Cannot open
    "/var/opt/ignite/clients/0x0017087C4A3A/io.info": Permission
    denied
    (errno = 13)
    ERROR: Could not copy file: /tmp/io.info to
    /var/opt/ignite/clients/0x0017087C4A3A/io.info: Permission
    denied
    (errno = 13)
    ERROR: copy_file: Cannot open
    "/var/opt/ignite/clients/0x0017087C4A3A/host.info":
    Permission denied
    (errno = 13)
    ERROR: Could not copy file: /tmp/host.info to
    /var/opt/ignite/clients/0x0017087C4A3A/host.info: Permission
    denied
    (errno = 13)
    ERROR: Could not create the client specific directory.
    Will switch to an interactive installation.
    Press Return to continue:

    Is there any other way by which we can install an image on baremetal
    machine which is not added on Ignite server, I am creating 'config'
    file under the client directory.


    Thanking you in anticipation,
    [Pushkaraj]




  4. Re: HP vPAR Booting via Ignite server

    On Thu, 28 Aug 2008 03:57:02 -0700 (PDT), Pushkaraj
    wrote:


    >Hi All,
    >I have a query on this, hope anyone can answer:
    >In case, if client is not added on ignite server i.e. the client
    >machine is totally new and its profile is not present under - /var/opt/
    >ignite/client/0x{LLA}/.
    >Then, the installation with same way fails with following error:
    >
    > * NFS mounting clients directory.
    > * Using client directory: /var/opt/ignite/clients/
    >0x0017087C4A3A
    >ERROR: copy_file: Cannot open
    > "/var/opt/ignite/clients/0x0017087C4A3A/install.log":
    >Permission
    > denied (errno = 13)


    This is a permissions problem. Check the owner and permissions on the
    /var/opt/ignite/clients directory.

  5. Re: HP vPAR Booting via Ignite server

    On Aug 28, 9:20*pm, Robert Klute wrote:
    > On Thu, 28 Aug 2008 03:57:02 -0700 (PDT), Pushkaraj
    >
    > wrote:
    > >Hi All,
    > >I have a query on this, hope anyone can answer:
    > >In case, if client is not added on ignite server i.e. the client
    > >machine is totally new and its profile is not present under - /var/opt/
    > >ignite/client/0x{LLA}/.
    > >Then, the installation with same way fails with following error:

    >
    > > * * * * NFS mounting clients directory.
    > > * * * * Using client directory: /var/opt/ignite/clients/
    > >0x0017087C4A3A
    > >ERROR: * copy_file: Cannot open
    > > * * * * "/var/opt/ignite/clients/0x0017087C4A3A/install.log":
    > >Permission
    > > * * * * denied (errno = 13)

    >
    > This is a permissions problem. *Check the owner and permissions on the
    > /var/opt/ignite/clients directory.


    Hi Robert,

    The baremetal image installation with igntie was successfully
    completed!, but we are kind of dependent on - "client should be
    preregistered with Ignite before going for image installaiton", else
    the image installation process fails in between.
    For adding the client at runtime I have gone through script -
    add_new_client, but I was helpless to reverse engg. for how to
    compose hw.info, host.info and io.info files. add_new_client uses /
    opt/ignite/lbin/rescan_hw_host for composing those files.
    In our case HP machine will be totally new (baremetal) in this case I
    cannot run this command.

    Is there any way by which we install a image on client which is not
    registered on ignite.

    Thanks,
    Pushkaraj

  6. Re: HP vPAR Booting via Ignite server

    On Wed, 3 Sep 2008 06:51:49 -0700 (PDT), Pushkaraj
    wrote:

    >Hi Robert,
    >
    >The baremetal image installation with igntie was successfully
    >completed!, but we are kind of dependent on - "client should be
    >preregistered with Ignite before going for image installaiton", else
    >the image installation process fails in between.
    >For adding the client at runtime I have gone through script -
    >add_new_client, but I was helpless to reverse engg. for how to
    >compose hw.info, host.info and io.info files. add_new_client uses /
    >opt/ignite/lbin/rescan_hw_host for composing those files.
    >In our case HP machine will be totally new (baremetal) in this case I
    >cannot run this command.
    >
    >Is there any way by which we install a image on client which is not
    >registered on ignite.


    Got me. I don't have the problem with my set up. I just do a lanboot
    select from the EFI prompt, the host PXE boots install, I fill in the
    pertinent info from the console and Ignite 'discovers' the new client
    for me.

    Perhaps registering and posing your question over at the itrc.hp.com
    HP-UX forum may get you an answer.

    http://forums12.itrc.hp.com/service/...categoryId=209

    Robert.

+ Reply to Thread