Q: PSF os_release - HP UX

This is a discussion on Q: PSF os_release - HP UX ; Hi, I had a similar question some time ago (which remained unanswered): In my HP-UX software package I use os_release B.11.23|B.11.31 According to the documentation (man 4 sd) this is perfectly OK, but swinstall doesn't list the software package as ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Q: PSF os_release

  1. Q: PSF os_release

    Hi,

    I had a similar question some time ago (which remained unanswered):
    In my HP-UX software package I use
    os_release B.11.23|B.11.31
    According to the documentation (man 4 sd) this is perfectly OK, but swinstall
    doesn't list the software package as installable.

    In a different package that can be installed I used
    os_release ?.11.[123]*

    As the documentation is so wrong, does anybody know whether I'll ahve to use
    "\|" instead of "|" (like in egrep) to make that work.

    A lot of documentation is rather worthless if it's wrong.

    Who can clarify?

    Regards,
    Ulrich

  2. Re: Q: PSF os_release

    Yesterday I did not write the truth:

    > Hi,
    >
    > I had a similar question some time ago (which remained unanswered):
    > In my HP-UX software package I use
    > os_release B.11.23|B.11.31
    > According to the documentation (man 4 sd) this is perfectly OK, but swinstall
    > doesn't list the software package as installable.
    >
    > In a different package that can be installed I used
    > os_release ?.11.[123]*
    >
    > As the documentation is so wrong, does anybody know whether I'll have to use
    > "\|" instead of "|" (like in egrep) to make that work.
    >

    [...]
    That's not true: Both variants work. My mistake was that I had used a depot
    that still had the old versions of the products that doid not know about HP-UX
    11.31.

    Sorry,
    Ulrich

+ Reply to Thread