New-ish to HPUX having a problem with depots..... - HP UX

This is a discussion on New-ish to HPUX having a problem with depots..... - HP UX ; Im trying to add the HPUX Sofftare Package builder to a depot on 11.23 running on Itanium, and am running into errors. I have java 1.3, 1.4 and 1.5 installed in /opt. the PATH and JAVA_HOME vars are set to ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: New-ish to HPUX having a problem with depots.....

  1. New-ish to HPUX having a problem with depots.....

    Im trying to add the HPUX Sofftare Package builder to a depot on 11.23
    running on Itanium, and am running into errors.

    I have java 1.3, 1.4 and 1.5 installed in /opt. the PATH and JAVA_HOME
    vars are set to /opt/java1.4 and /opt/java1.4/bin respectively. which
    java replies with:
    java version "1.4.2.07"
    Java(TM) 2 Runtime Environment, Standard Edition (build
    1.4.2.07-050121-15:53)

    I have the java depots for 1.4.01(min req for SPB) for Ia in
    /home/depots/IA/ and the depot for PA in /home/depots/PA. Im trying to
    add the SPB to /home/depots/PA+IA.

    now thing is i dont understand the depot mechanisms that well. Im not
    sure when im adding it to the depot, and it looks at its dependencies,
    whether it is suppsoed to be looking at installed software (which would
    be jre 1.4.2) or for other depots (jre 1.4.01). Anyways, when i add the
    software, it gives a dependency error when it is marked for copying,
    but says that these dependencies will be checked again at analysis
    stage. At the analysis stage the errors reported are:

    * Reading source for file information.
    The corequisite "Jre14.JRE14-COM,r>=1.4.0.01.00" for fileset
    "SwPackager.SPB-LIB,r=A.02.00.09.431" cannot be successfully
    resolved.
    The corequisite "Jre14.JRE14-IPF64,r>=1.4.0.01.00" for fileset
    "SwPackager.SPB-LIB,r=A.02.00.09.431" cannot be successfully
    resolved.
    The corequisite "Jre14.JRE14-IPF64-HS,r>=1.4.0.01.00" for
    fileset "SwPackager.SPB-LIB,r=A.02.00.09.431" cannot be
    successfully resolved.
    The corequisite "Jre14.JRE14-IPF32,r>=1.4.0.01.00" for fileset
    "SwPackager.SPB-LIB,r=A.02.00.09.431" cannot be successfully
    resolved.
    The corequisite "Jre14.JRE14-IPF32-HS,r>=1.4.0.01.00" for
    fileset "SwPackager.SPB-LIB,r=A.02.00.09.431" cannot be
    successfully resolved.
    The corequisite "Jre14.JRE14-PA11,r>=1.4.0.01.00" for fileset
    "SwPackager.SPB-LIB,r=A.02.00.09.431" cannot be successfully
    resolved.
    The corequisite "Jre14.JRE14-PA11-HS,r>=1.4.0.01.00" for
    fileset "SwPackager.SPB-LIB,r=A.02.00.09.431" cannot be
    successfully resolved.
    ERROR: The dependencies for fileset
    "SwPackager.SPB-LIB,r=A.02.00.09.431" cannot be resolved (see
    previous lines).
    You must resolve the above dependencies before operating on
    this fileset or change the "enforce_dependencies" option to
    "false".
    The corequisite "Jre14.JRE14-IPF64,r>=1.4.0.01.00" for fileset
    "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be successfully
    resolved.
    The corequisite "Jre14.JRE14-IPF64-HS,r>=1.4.0.01.00" for
    fileset "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be
    successfully resolved.
    The corequisite "Jre14.JRE14-IPF32,r>=1.4.0.01.00" for fileset
    "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be successfully
    resolved.
    The corequisite "Jre14.JRE14-IPF32-HS,r>=1.4.0.01.00" for
    fileset "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be
    successfully resolved.
    The corequisite "Jre14.JRE14-PA11,r>=1.4.0.01.00" for fileset
    "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be successfully
    resolved.
    The corequisite "Jre14.JRE14-PA11-HS,r>=1.4.0.01.00" for
    fileset "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be
    successfully resolved.
    The corequisite "SwPackager.SPB-LIB,r>=A.02.00.09.431" for
    fileset "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be
    successfully resolved.
    ERROR: The dependencies for fileset
    "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be resolved (see
    previous lines).
    You must resolve the above dependencies before operating on
    this fileset or change the "enforce_dependencies" option to
    "false".
    The corequisite "Jre14.JRE14-PA11,r>=1.4.0.01.00" for fileset
    "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be successfully
    resolved.
    The corequisite "Jre14.JRE14-PA20,r>=1.4.0.01.00" for fileset
    "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be successfully
    resolved.
    The corequisite "Jre14.JRE14-PA20W,r>=1.4.0.01.00" for fileset
    "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be successfully
    resolved.
    The corequisite "Jre14.JRE14-PA11-HS,r>=1.4.0.01.00" for
    fileset "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be
    successfully resolved.
    The corequisite "Jre14.JRE14-PA20-HS,r>=1.4.0.01.00" for
    fileset "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be
    successfully resolved.
    The corequisite "Jre14.JRE14-PA20W-HS,r>=1.4.0.01.00" for
    fileset "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be
    successfully resolved.
    The corequisite "SwPackager.SPB-LIB,r>=A.02.00.09.431" for
    fileset "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be
    successfully resolved.
    ERROR: The dependencies for fileset
    "SwPackager.SPB-RUN,r=A.02.00.09.431" cannot be resolved (see
    previous lines).
    You must resolve the above dependencies before operating on
    this fileset or change the "enforce_dependencies" option to
    "false".
    NOTE: The used disk space on filesystem "/home" is estimated to
    increase by 4704 Kbytes.
    This will leave 9004128 Kbytes of available user disk space
    after the installation.

    * Summary of Analysis Phase:
    ERROR: Exclude SwPackager.SPB-LIB,r=A.02.00.09.431
    ERROR: Exclude SwPackager.SPB-RUN,r=A.02.00.09.431
    ERROR: Exclude SwPackager.SPB-RUN,r=A.02.00.09.431
    ERROR: 3 of 5 filesets had Errors.
    * 2 of 5 filesets had no Errors or Warnings.
    ERROR: The Analysis Phase had errors. See the above output for
    details.

    Im using sam to copy the software to the depot. Any help will be much
    appreciated.

    B


  2. Re: New-ish to HPUX having a problem with depots.....


    "bomahony" ha scritto nel messaggio
    news:1169813140.058727.315820@v45g2000cwv.googlegr oups.com...
    > Im trying to add the HPUX Sofftare Package builder to a depot on 11.23
    > running on Itanium, and am running into errors.
    >
    > I have java 1.3, 1.4 and 1.5 installed in /opt. the PATH and JAVA_HOME
    > vars are set to /opt/java1.4 and /opt/java1.4/bin respectively. which
    > java replies with:
    > java version "1.4.2.07"
    > Java(TM) 2 Runtime Environment, Standard Edition (build
    > 1.4.2.07-050121-15:53)
    >
    > I have the java depots for 1.4.01(min req for SPB) for Ia in
    > /home/depots/IA/ and the depot for PA in /home/depots/PA. Im trying to
    > add the SPB to /home/depots/PA+IA.
    >
    > now thing is i dont understand the depot mechanisms that well. Im not
    > sure when im adding it to the depot, and it looks at its dependencies,
    > whether it is suppsoed to be looking at installed software (which would
    > be jre 1.4.2) or for other depots (jre 1.4.01). Anyways, when i add the
    > software, it gives a dependency error when it is marked for copying,
    > but says that these dependencies will be checked again at analysis
    > stage. At the analysis stage the errors reported are:
    >
    > * Reading source for file information.
    > The corequisite "Jre14.JRE14-COM,r>=1.4.0.01.00" for fileset
    > "SwPackager.SPB-LIB,r=A.02.00.09.431" cannot be successfully
    > resolved.


    [cut]


    > You must resolve the above dependencies before operating on
    > this fileset or change the "enforce_dependencies" option to
    > "false".
    > NOTE: The used disk space on filesystem "/home" is estimated to
    > increase by 4704 Kbytes.
    > This will leave 9004128 Kbytes of available user disk space
    > after the installation.
    >
    > * Summary of Analysis Phase:
    > ERROR: Exclude SwPackager.SPB-LIB,r=A.02.00.09.431
    > ERROR: Exclude SwPackager.SPB-RUN,r=A.02.00.09.431
    > ERROR: Exclude SwPackager.SPB-RUN,r=A.02.00.09.431
    > ERROR: 3 of 5 filesets had Errors.
    > * 2 of 5 filesets had no Errors or Warnings.
    > ERROR: The Analysis Phase had errors. See the above output for
    > details.
    >
    > Im using sam to copy the software to the depot. Any help will be much
    > appreciated.
    >
    > B
    >




    As the output from copy depot say:


    You must resolve the above dependencies before operating on
    this fileset or change the "enforce_dependencies" option to
    "false".

    Try to change dependencies analisys to false, analisys would be fine with
    warning.

    Antonio



+ Reply to Thread