10.10 - HP UX

This is a discussion on 10.10 - HP UX ; All, I have to set up an old HP9000/D210 system with 10.10, for compatibility with an existing application. (I don't have the source code for the application, so recompiling to work with a more recent version unfortunately isn't an option.) ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: 10.10

  1. 10.10

    All,

    I have to set up an old HP9000/D210 system with 10.10, for
    compatibility with an existing application. (I don't have the source
    code for the application, so recompiling to work with a more recent
    version unfortunately isn't an option.)

    Does anyone have a suggestion where I could look for media? I've
    struck out with the usual sources such as ebay and the resellers I
    know.

    Thanks in advance!


  2. Re: 10.10

    jcneumann@prodigy.net wrote:
    > I have to set up an old HP9000/D210 system with 10.10, for
    > compatibility with an existing application. (I don't have the
    > source code for the application, so recompiling to work with a more
    > recent version unfortunately isn't an option.)


    However, likely as not, a binary compiled on 10.10 would run on 10.20.

    > Does anyone have a suggestion where I could look for media? I've
    > struck out with the usual sources such as ebay and the resellers I
    > know.


    Might try a museum. FWIW, and IIRC 10.10 was sort of an "interim"
    release - not quite as interim as 10.01 mind you, but when 10.20
    came-out, I believe HP made that a "push" release and got (or tried to
    get) everyone to upgrade.

    Frankly, not having the source code for the application sounds like a
    _MUCH_ bigger problem than finding 10.10 install media...

    rick jones
    --
    portable adj, code that compiles under more than one compiler
    these opinions are mine, all mine; HP might not want them anyway...
    feel free to post, OR email to rick.jones2 in hp.com but NOT BOTH...

  3. Re: 10.10

    jcneumann@prodigy.net wrote:
    > All,
    >
    > I have to set up an old HP9000/D210 system with 10.10, for
    > compatibility with an existing application. (I don't have the source
    > code for the application, so recompiling to work with a more recent
    > version unfortunately isn't an option.)
    >
    > Does anyone have a suggestion where I could look for media? I've
    > struck out with the usual sources such as ebay and the resellers I
    > know.
    >
    > Thanks in advance!


    From this it looks like the application is as old as or older than
    (HP-UX) 10.10. If so, then why do you think you need to recompile it
    to work with a more recent (what is "recent"?) version (of HP-UX)?

    HP(-UX) has a very good track record for old->new (i.e. old software
    on new releases of HP-UX) compatibility. For example I have run
    (possibly pre) 3.0 software on 10.20 without any problems.

    So specific questions: On/for which version of HP-UX was the
    application compiled and on which version(s) of HP-UX would you like
    to run it? What kind of application is it? Only executables or also
    libraries (if so, archive or shared?)? Other? Etc..

  4. Re: 10.10

    Frank Slootweg wrote:
    > jcneumann@prodigy.net wrote:
    >
    >>All,
    >>
    >>I have to set up an old HP9000/D210 system with 10.10, for
    >>compatibility with an existing application. (I don't have the source
    >>code for the application, so recompiling to work with a more recent
    >>version unfortunately isn't an option.)
    >>
    >>Does anyone have a suggestion where I could look for media? I've
    >>struck out with the usual sources such as ebay and the resellers I
    >>know.
    >>
    >>Thanks in advance!

    >
    >
    > From this it looks like the application is as old as or older than
    > (HP-UX) 10.10. If so, then why do you think you need to recompile it
    > to work with a more recent (what is "recent"?) version (of HP-UX)?
    >
    > HP(-UX) has a very good track record for old->new (i.e. old software
    > on new releases of HP-UX) compatibility. For example I have run
    > (possibly pre) 3.0 software on 10.20 without any problems.
    >
    > So specific questions: On/for which version of HP-UX was the
    > application compiled and on which version(s) of HP-UX would you like
    > to run it? What kind of application is it? Only executables or also
    > libraries (if so, archive or shared?)? Other? Etc..

    If it runs under 10.10 it should run under 10.20, wasn't .10 when they
    started to integrate 700 and 800? I was trying to find the timeline on
    the itrc but they moved it....

  5. Re: 10.10

    Alan D Johnson wrote:
    > If it runs under 10.10 it should run under 10.20, wasn't .10 when
    > they started to integrate 700 and 800? I was trying to find the
    > timeline on the itrc but they moved it....


    IIRC re-integration of "server" and "workstation" HP-UX lines began
    with the 10.X stuff. However, even as late as 10.20, while the source
    trees were basically merged, there were still two sets of install
    media - one for workstations and the other for servers.

    HP-UX 11.0 is when the media merged.

    Then someone decided to create "Mission Critical" and "Technical
    Computing" OE media. The sources though remain fully merged.


    rick jones
    --
    The glass is neither half-empty nor half-full. The glass has a leak.
    The real question is "Can it be patched?"
    these opinions are mine, all mine; HP might not want them anyway...
    feel free to post, OR email to rick.jones2 in hp.com but NOT BOTH...

  6. Re: 10.10

    Thanks for all the responses.

    Frank, AFAIK the application was compiled to 10.10, which is what it
    currently runs on. Apologies for the vague response, but I don't have
    access to the developer, and there is very little documentation. One
    bit of information I do have is that someone (yes, that vague
    'someone'...) tried to run the application several years ago on 10.20,
    and was not able to do so. Again, this is secondhand, and I don't have
    any documentation of what the errors were... :Grrrrrrrrr

    It's basically an inventory and process control app for a small
    munfacturing concern, it does have libraries - I am just getting my
    hands around the structure, so I don't have a whole lot of details. I
    am going to very hands-on with application for the next few weeks, so I
    should know a great deal more then.

    As to what I'd like it to run on, I'd like to run on at least 11.0. I
    will have my hands on the D210 quite shortly, which is supposed to come
    with 11.0. It's worth a try to see if it will run, as perhaps I have
    fallen into the trap of assuming without verifying.

    Again, thanks all for the advice.


+ Reply to Thread