Strange behaviour of MY HP48GX - Hewlett Packard

This is a discussion on Strange behaviour of MY HP48GX - Hewlett Packard ; I use my HP48GX a lot while teaching Physics labs, etc. I keep student example data sets as well as data sets I create for exams and Recitation Sessions stored on the calculator. One of the labs we do is ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Strange behaviour of MY HP48GX

  1. Strange behaviour of MY HP48GX

    I use my HP48GX a lot while teaching Physics labs, etc.
    I keep student example data sets as well as data sets I create for
    exams and Recitation Sessions stored on the calculator.

    One of the labs we do is Projectile Motion. In the first part of the
    lab we find the muzzle velocity. In part two we set the spring gun to
    an angle other that zero and get the student to predict the X distance
    traveled. Their grade is based on how close they come to their
    predicted distance.

    I was using the Projectile Motion part of the equation library today
    and noticed that it was giving me the wrong results for the time and
    the X distance. Both were negative values.I cleared all the variables
    in the solver for P.M and it still gave the wrong answers
    I then did an ON-A-F clear memory and everything seemed to work fine.
    Does anyone have an idea as to what was happening in the first case to
    give the wrong answers. Would another variable interfere with the
    solver? Do I just have too much junk stored on the calc?
    Harold A. Climer
    Dept Of Physics Geology & Astronomy
    U.T. Chattanooga
    Room 406A Engineering,Math & Computer Sicence Building
    615 McCallie Ave.
    Chattanooga TN 37403
    Harold-Climer@utc.edu

  2. Re: Strange behaviour of MY HP48GX

    On Thu, 03 Jul 2008 11:34:52 -0500, Harold A. Climer wrote:

    > I was using the Projectile Motion part of the Equation Library today
    > and noticed that it was giving me the wrong results for the time and
    > the X distance. Both were negative values. I cleared all the variables
    > in the solver for P.M and it still gave the wrong answers.
    > I then did an ON-A-F clear memory and everything seemed to work fine.


    > Would another variable interfere with the solver?Do I just have too much junk stored on the calc?


    How did you clear all variables? Did you clear all ten variables?
    Did you clear the 'Mpar' (solver state) variable as well?
    (or reset the entire state to its original conditions?)

    The Equation Library uses the Multiple Equation Solver (MES),
    which is a numeric solver. "Projectile Motion" has five equations
    in ten variables. Some initial conditions and/or initial guesses,
    or values left over from previous solutions,
    as well as settings of which variables are user-specified
    and which others are to be calculated
    (yet another potential source of problem set-up error),
    could conceivably give rise to finding a negative value
    which balances some equation(s), and once the MES
    has picked one such value to balance one equation,
    then uses it while hunting to balance other equations,
    that might in turn cause other negative values to be found,
    in a kind of "chain reaction."

    Barring genuine memory _corruption_ (e.g. by bad SysRPL/ML program),
    "other variables" or "too much junk" are not responsible;
    lack of memory would simply generate a normal
    "Insufficient Memory" error.

    If you had recorded every keystroke and screen image on video,
    the operational error might possibly be reconstructed,
    but who ever anticipates needing an "instant replay"
    to settle a possible dispute,
    before executing calculator plays?

    Best wishes.

+ Reply to Thread