New firmware failure - Liteon DVD burner, pavillion pc - Hewlett Packard

This is a discussion on New firmware failure - Liteon DVD burner, pavillion pc - Hewlett Packard ; Hi, I got a firmware update from the HP website for my pavillion pcs dvd burner (a liteon 8x drive). I am SURE I picked the right patch (1 of 3 available). See link below: - http://h10025.www1.hp.com/ewfrf/wc/s...n&cc=uk&os=228 File = Lite-On ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: New firmware failure - Liteon DVD burner, pavillion pc

  1. New firmware failure - Liteon DVD burner, pavillion pc

    Hi,

    I got a firmware update from the HP website for my pavillion pcs dvd
    burner (a liteon 8x drive). I am SURE I picked the right patch (1 of 3
    available). See link below: -

    http://h10025.www1.hp.com/ewfrf/wc/s...n&cc=uk&os=228

    File = Lite-On SOHW-832S 8X DVD+/-R/RW Drive Firmware Update

    I produced a bootable CD by following the instructions, but the disc
    has now rendered my DVD dead. It is a dead drive (hello polly parrot).

    Damn.

    Has anyone else had this problem? Can the firmware be retro-installed /
    rolled back somehow (despite what the software may say)?

    I am in touch with HP with regards to their "helpful" patch they
    supplied me, but I was just wondering how big a problem this has been.

    THANKS


  2. Re: New firmware failure - Liteon DVD burner, pavillion pc

    I have reflashed numerous times with the help of these guys (from
    original site CDFreaks)
    I have the 4X drive reflashed to 8X (832S)
    This would NOT be recommended by Lite-ON or HP...but what have you got
    to lose!
    (A new 16X drive is about $40)

    http://codeguys.rpc1.org/firmwares.html

    b_d


  3. Re: New firmware failure - Liteon DVD burner, pavillion pc

    Thanks, but I actually got it to work (no thanks to HP)

    What actually went wrong is that the procedure tells the user to
    restart the machine WAYYYYY before it should.

    I reckon my drive was still doing christmas lights up to 90 seconds
    after the on screen message appered saying re-start. I hadn't noticed
    this first time round.


+ Reply to Thread