Help with console in x that has a different keymap in Slackware - Help

This is a discussion on Help with console in x that has a different keymap in Slackware - Help ; Hello peeps, Here is how it goes. I set up us-acentos.map as the loading keymap on startup in my slackware 9.1 kernel 2.6.2. If im in virtual tty i can write accents with deadkeys no problem....in X, i can do ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Help with console in x that has a different keymap in Slackware

  1. Help with console in x that has a different keymap in Slackware

    Hello peeps,

    Here is how it goes. I set up us-acentos.map as the loading keymap on
    startup in my slackware 9.1 kernel 2.6.2. If im in virtual tty i can
    write accents with deadkeys no problem....in X, i can do just the same
    in programs like abiword, in the browsers and the such... -----> יא

    The problem is in the console under X, the character set or something
    doesnt seem to be set correctly and i can't figure out what to
    modify!!!

    I can hit the deadkeys and they do act as deadkeys...but if i combine
    it with say "e" nothing happens, no character is printed on the
    console.

    Also, i tried a dumpkeys in the tty console outside of X and the
    keymap is fine, i can see the accentuated characters in the compose,
    but the keymap in the console under X is not right. The accentuated
    caracters show up as empty squares.

    I tried dumping with dumpkey from console under X into a file to see
    if it was a problem with X, but under abiword i can actually read the
    accentuated characters which means the right keymap has been loaded
    correctly. So it has to be a problem with bash configuration under X.

    Any ideas?

  2. Re: Help with console in x that has a different keymap in Slackware

    crypto_stonelock@sympatico.ca wrote:
    > Hello peeps,
    >
    > Here is how it goes. I set up us-acentos.map as the loading keymap on
    > startup in my slackware 9.1 kernel 2.6.2. If im in virtual tty i can
    > write accents with deadkeys no problem....in X, i can do just the same
    > in programs like abiword, in the browsers and the such... -----> יא
    >
    > The problem is in the console under X, the character set or something
    > doesnt seem to be set correctly and i can't figure out what to
    > modify!!!
    >
    > I can hit the deadkeys and they do act as deadkeys...but if i combine
    > it with say "e" nothing happens, no character is printed on the
    > console.
    >
    > Also, i tried a dumpkeys in the tty console outside of X and the
    > keymap is fine, i can see the accentuated characters in the compose,
    > but the keymap in the console under X is not right. The accentuated
    > caracters show up as empty squares.
    >
    > I tried dumping with dumpkey from console under X into a file to see
    > if it was a problem with X, but under abiword i can actually read the
    > accentuated characters which means the right keymap has been loaded
    > correctly. So it has to be a problem with bash configuration under X.
    >
    > Any ideas?


    The problem might be with your console font (not having the required
    glyphs). Try changing your console font to the font you use in AbiWord.

    --
    Ben M.

    ----------------
    What are Software Patents for?
    To protect the small enterprise from bigger companies.

    What do Software Patents do?
    In its current form, they protect only companies with
    big legal departments as they:
    a.) Patent everything no matter how general
    b.) Sue everybody. Even if the patent can be argued
    invalid, small companies can ill-afford the
    typical $500k cost of a law-suit (not to mention
    years of harassment).

    Don't let them take away your right to program
    whatever you like. Make a stand on Software Patents
    before its too late.

    Read about the ongoing battle at http://swpat.ffii.org/
    ----------------

  3. Re: Help with console in x that has a different keymap in Slackware

    Ben Measures wrote in message news:<02G0c.3353$X%.2612@news-binary.blueyonder.co.uk>...
    > crypto_stonelock@sympatico.ca wrote:
    > > Hello peeps,
    > >
    > > Here is how it goes. I set up us-acentos.map as the loading keymap on
    > > startup in my slackware 9.1 kernel 2.6.2. If im in virtual tty i can
    > > write accents with deadkeys no problem....in X, i can do just the same
    > > in programs like abiword, in the browsers and the such... -----> יא
    > >
    > > The problem is in the console under X, the character set or something
    > > doesnt seem to be set correctly and i can't figure out what to
    > > modify!!!
    > >
    > > I can hit the deadkeys and they do act as deadkeys...but if i combine
    > > it with say "e" nothing happens, no character is printed on the
    > > console.
    > >
    > > Also, i tried a dumpkeys in the tty console outside of X and the
    > > keymap is fine, i can see the accentuated characters in the compose,
    > > but the keymap in the console under X is not right. The accentuated
    > > caracters show up as empty squares.
    > >
    > > I tried dumping with dumpkey from console under X into a file to see
    > > if it was a problem with X, but under abiword i can actually read the
    > > accentuated characters which means the right keymap has been loaded
    > > correctly. So it has to be a problem with bash configuration under X.
    > >
    > > Any ideas?

    >
    > The problem might be with your console font (not having the required
    > glyphs). Try changing your console font to the font you use in AbiWord.


    Hmmm.. yeahs i tried loading the fonts manually with setfont....it
    worked and messed up my fonts ...but i have no idea which set of
    font i need.

    Usually though just loading the keymap to us-acentos.map.gz was enough
    to set everything up correctly so i have no idea which set of font i
    need. I guess the one i want is the same that is loaded to deal with
    us-acentos . I can't seem to find much information anywhere about
    this; I checked on the net through and through and every friggin time
    i type in us-acentos in google or yahoo pages in spanish come up ( i
    dont read spanish..well..i can decypher ) plus the info i want doesnt
    seem to come up.

    What i'm trying to set up is US international keyboard ( with deadkeys
    ). Any idea which set of font i need with my us-acentos key mapping?

    Thanks in advance

  4. Re: Help with console in x that has a different keymap in Slackware

    On 3 Mar 2004 17:40:53 -0800, crypto_stonelock@sympatico.ca wrote:

    >What i'm trying to set up is US international keyboard ( with deadkeys
    >). Any idea which set of font i need with my us-acentos key mapping?


    Try setting your language preference to English only. I found a
    number of references, although mostly to portuguese and nothing useful
    about slackware. I did, however, find a suggestion about using xev,
    which will give you a window showing you every event including
    keypresses. This might tell you what's actually happening, and give
    you an idea of how to get what you want.

    --
    Joe Zeff
    The Guy With the Sideburns
    Debating unix flavors in the context of anything Microsoft is like
    talking about which ice cream flavor tastes least like sawdust with
    turpentine sauce.
    http://www.lasfs.org http://home.earthlink.net/~sidebrnz

+ Reply to Thread