Help with LIRC - Help

This is a discussion on Help with LIRC - Help ; Hi all, I've got a weird problem - I can correctly train a remote control using irrecord, but when I copy the resultant config file to etc/lircd.conf and run lircd, then run irw to test the result, I get NO ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Help with LIRC

  1. Help with LIRC

    Hi all,

    I've got a weird problem - I can correctly train a remote control
    using irrecord, but when I copy the resultant config file to
    etc/lircd.conf and run lircd, then run irw to test the result, I get
    NO output onscreen.

    The exact same remote control and the same receiver hardware (Vishay
    TSOP1238 connected to the IR Rx data line) works perfectly on a
    nominally different, but *very* similar board (same CPU/video/superIO
    chips). I'm wondering if there's something I left out of my kernel
    configuration that is preventing irw from communicating with lircd
    correctly. Any ideas where I should look? Anything further I can do to
    debug this? I've tried several other remote controls with exactly the
    same symptom.

  2. Re: Help with LIRC

    Further info on this:

    > I've got a weird problem - I can correctly train a remote control
    > using irrecord, but when I copy the resultant config file to
    > etc/lircd.conf and run lircd, then run irw to test the result, I get
    > NO output onscreen.


    I checked /proc/{pid of lircd}/fd and I find that it doesn't have
    /dev/lirc open! I then strace lircd and find that it doesn't attempt to
    open that device even when I specify --device=/dev/lirc

    What on earth is going on?


+ Reply to Thread