Error when updating via Yum - Help

This is a discussion on Error when updating via Yum - Help ; Transaction Check Error: file /usr/share/man/man1/xmlcatalog.1.gz from install of libxml2-2.6.27-1.FC6 conflicts with file from package libxml2-2.6.26-2.1.1 file /usr/share/man/man1/xmllint.1.gz from install of libxml2-2.6.27-1.FC6 conflicts with file from package libxml2-2.6.26-2.1.1 This looks like yum is confused. So am I. Help please? Dave...

+ Reply to Thread
Results 1 to 7 of 7

Thread: Error when updating via Yum

  1. Error when updating via Yum

    Transaction Check Error: file /usr/share/man/man1/xmlcatalog.1.gz from
    install of libxml2-2.6.27-1.FC6 conflicts with file from package
    libxml2-2.6.26-2.1.1 file /usr/share/man/man1/xmllint.1.gz from install of
    libxml2-2.6.27-1.FC6 conflicts with file from package libxml2-2.6.26-2.1.1


    This looks like yum is confused. So am I.

    Help please?

    Dave

  2. Re: Error when updating via Yum

    CWO4 Dave Mann wrote:

    > Transaction Check Error: file /usr/share/man/man1/xmlcatalog.1.gz from
    > install of libxml2-2.6.27-1.FC6 conflicts with file from package
    > libxml2-2.6.26-2.1.1 file /usr/share/man/man1/xmllint.1.gz from install
    > of libxml2-2.6.27-1.FC6 conflicts with file from package
    > libxml2-2.6.26-2.1.1
    >
    >
    > This looks like yum is confused. So am I.


    Hmmm......... do you have perhaps a mixed mode environment???

    $ rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}.rpm\n" libxml2
    libxml2-2.6.27-1.FC6.x86_64.rpm
    libxml2-2.6.27-1.FC6.i386.rpm

    Sometimes it helps to specify;

    yum update libxml2*.x86_64 libxml2*.i386


  3. Re: Error when updating via Yum

    Lenard wrote:
    > CWO4 Dave Mann wrote:
    >
    >> Transaction Check Error: file /usr/share/man/man1/xmlcatalog.1.gz from
    >> install of libxml2-2.6.27-1.FC6 conflicts with file from package
    >> libxml2-2.6.26-2.1.1 file /usr/share/man/man1/xmllint.1.gz from install
    >> of libxml2-2.6.27-1.FC6 conflicts with file from package
    >> libxml2-2.6.26-2.1.1
    >>
    >>
    >> This looks like yum is confused. So am I.

    >
    > Hmmm......... do you have perhaps a mixed mode environment???
    >
    > $ rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}.rpm\n" libxml2
    > libxml2-2.6.27-1.FC6.x86_64.rpm
    > libxml2-2.6.27-1.FC6.i386.rpm
    >
    > Sometimes it helps to specify;
    >
    > yum update libxml2*.x86_64 libxml2*.i386
    >



    Here is the output from my workstation. I'm going to google the mixed
    mode environment to understand that after I post this.

    [root@localhost ~]# rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}.rpm\n" libxml2
    libxml2-2.6.26-2.1.1.x86_64.rpm
    libxml2-2.6.27-1.FC6.x86_64.rpm
    libxml2-2.6.26-2.1.1.i386.rpm
    [root@localhost ~]#


    Thanks!

    Dave

  4. Re: Error when updating via Yum

    Lenard wrote:
    > CWO4 Dave Mann wrote:
    >
    >> Transaction Check Error: file /usr/share/man/man1/xmlcatalog.1.gz from
    >> install of libxml2-2.6.27-1.FC6 conflicts with file from package
    >> libxml2-2.6.26-2.1.1 file /usr/share/man/man1/xmllint.1.gz from install
    >> of libxml2-2.6.27-1.FC6 conflicts with file from package
    >> libxml2-2.6.26-2.1.1
    >>
    >>
    >> This looks like yum is confused. So am I.

    >
    > Hmmm......... do you have perhaps a mixed mode environment???
    >
    > $ rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}.rpm\n" libxml2
    > libxml2-2.6.27-1.FC6.x86_64.rpm
    > libxml2-2.6.27-1.FC6.i386.rpm
    >
    > Sometimes it helps to specify;
    >
    > yum update libxml2*.x86_64 libxml2*.i386
    >



    Lo and Behold!

    This explains it all:

    http://www.linuxquestions.org/questi...d.php?t=465482

    Simply amazing what you find when you do a Google-Linux search. Doh!

    Cheers,

    Dave

  5. Re: Error when updating via Yum

    CWO4 Dave Mann wrote:
    > Lenard wrote:
    >> CWO4 Dave Mann wrote:
    >>
    >>> Transaction Check Error: file
    >>> /usr/share/man/man1/xmlcatalog.1.gz from install of
    >>> libxml2-2.6.27-1.FC6 conflicts with file from package
    >>> libxml2-2.6.26-2.1.1 file /usr/share/man/man1/xmllint.1.gz from
    >>> install of libxml2-2.6.27-1.FC6 conflicts with file from package
    >>> libxml2-2.6.26-2.1.1
    >>>
    >>>
    >>> This looks like yum is confused. So am I.

    >>
    >> Hmmm......... do you have perhaps a mixed mode environment???
    >>
    >> $ rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}.rpm\n" libxml2
    >> libxml2-2.6.27-1.FC6.x86_64.rpm libxml2-2.6.27-1.FC6.i386.rpm
    >>
    >> Sometimes it helps to specify;
    >>
    >> yum update libxml2*.x86_64 libxml2*.i386
    >>

    >
    >
    > Lo and Behold!
    >
    > This explains it all:
    >
    > http://www.linuxquestions.org/questi...d.php?t=465482
    >
    > Simply amazing what you find when you do a Google-Linux search. Doh!
    >
    >
    > Cheers,
    >
    > Dave



    I did some more work and found that out of a bunch of updates, only
    these failed due to the mixed mode environment yum update problem:

    gstreamer*
    libxml*

    I went ahead and upgrades all others with no problems. My question is
    "why" out of all the others do these fail?

    Cheers,

    Dave

  6. Re: Error when updating via Yum

    CWO4 Dave Mann wrote:

    > CWO4 Dave Mann wrote:
    >> Lenard wrote:
    >>> CWO4 Dave Mann wrote:
    >>>
    >>>> Transaction Check Error: file
    >>>> /usr/share/man/man1/xmlcatalog.1.gz from install of
    >>>> libxml2-2.6.27-1.FC6 conflicts with file from package
    >>>> libxml2-2.6.26-2.1.1 file /usr/share/man/man1/xmllint.1.gz from
    >>>> install of libxml2-2.6.27-1.FC6 conflicts with file from package
    >>>> libxml2-2.6.26-2.1.1
    >>>>
    >>>>
    >>>> This looks like yum is confused. So am I.
    >>>
    >>> Hmmm......... do you have perhaps a mixed mode environment???
    >>>
    >>> $ rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}.rpm\n" libxml2
    >>> libxml2-2.6.27-1.FC6.x86_64.rpm libxml2-2.6.27-1.FC6.i386.rpm
    >>>
    >>> Sometimes it helps to specify;
    >>>
    >>> yum update libxml2*.x86_64 libxml2*.i386
    >>>

    >>
    >>
    >> Lo and Behold!
    >>
    >> This explains it all:
    >>
    >> http://www.linuxquestions.org/questi...d.php?t=465482


    Yep, I know this every well, I'm Lenard both here and there.

    > I did some more work and found that out of a bunch of updates, only
    > these failed due to the mixed mode environment yum update problem:
    >
    > gstreamer*
    > libxml*
    >
    > I went ahead and upgrades all others with no problems. My question is
    > "why" out of all the others do these fail?


    Maybe because how yum works??? Like I said in the linuxquestions.org thread
    try keeping the updates minimized or as I said here specify.

    Now if you still have this issue(from your posting here);

    [root@localhost ~]# rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}.rpm\n" libxml2
    libxml2-2.6.26-2.1.1.x86_64.rpm
    libxml2-2.6.27-1.FC6.x86_64.rpm
    libxml2-2.6.26-2.1.1.i386.rpm

    Download the two updated libxml2 rpm packages to a common location and fix
    this issue;

    rpm -Uvh libxlm2*.rpm --force

    The force switch is needed because you already have the updated 64-bit
    package installed.



  7. Re: Error when updating via Yum

    Lenard wrote:
    > CWO4 Dave Mann wrote:
    >
    >> CWO4 Dave Mann wrote:
    >>> Lenard wrote:
    >>>> CWO4 Dave Mann wrote:
    >>>>
    >>>>> Transaction Check Error: file
    >>>>> /usr/share/man/man1/xmlcatalog.1.gz from install of
    >>>>> libxml2-2.6.27-1.FC6 conflicts with file from package
    >>>>> libxml2-2.6.26-2.1.1 file /usr/share/man/man1/xmllint.1.gz from
    >>>>> install of libxml2-2.6.27-1.FC6 conflicts with file from package
    >>>>> libxml2-2.6.26-2.1.1
    >>>>>
    >>>>>
    >>>>> This looks like yum is confused. So am I.
    >>>> Hmmm......... do you have perhaps a mixed mode environment???
    >>>>
    >>>> $ rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}.rpm\n" libxml2
    >>>> libxml2-2.6.27-1.FC6.x86_64.rpm libxml2-2.6.27-1.FC6.i386.rpm
    >>>>
    >>>> Sometimes it helps to specify;
    >>>>
    >>>> yum update libxml2*.x86_64 libxml2*.i386
    >>>>
    >>>
    >>> Lo and Behold!
    >>>
    >>> This explains it all:
    >>>
    >>> http://www.linuxquestions.org/questi...d.php?t=465482

    >
    > Yep, I know this every well, I'm Lenard both here and there.
    >
    >> I did some more work and found that out of a bunch of updates, only
    >> these failed due to the mixed mode environment yum update problem:
    >>
    >> gstreamer*
    >> libxml*
    >>
    >> I went ahead and upgrades all others with no problems. My question is
    >> "why" out of all the others do these fail?

    >
    > Maybe because how yum works??? Like I said in the linuxquestions.org thread
    > try keeping the updates minimized or as I said here specify.
    >
    > Now if you still have this issue(from your posting here);
    >
    > [root@localhost ~]# rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}.rpm\n" libxml2
    > libxml2-2.6.26-2.1.1.x86_64.rpm
    > libxml2-2.6.27-1.FC6.x86_64.rpm
    > libxml2-2.6.26-2.1.1.i386.rpm
    >
    > Download the two updated libxml2 rpm packages to a common location and fix
    > this issue;
    >
    > rpm -Uvh libxlm2*.rpm --force
    >
    > The force switch is needed because you already have the updated 64-bit
    > package installed.
    >
    >




    Well sir, that kicked it's ass! Worked perfectly -- now to tackle the
    gstreamer update> rpm -Uvh libxlm2*.rpm --force

    ..

    Hummmm, title for a new movie? The Gstreamer Conundrum"

    Never mind.

    Thanks for the help!

    Dave

+ Reply to Thread