Problem with SuperLoader3 (DLT-V4) on an Adaptec 29320A SCSI card... - Hardware

This is a discussion on Problem with SuperLoader3 (DLT-V4) on an Adaptec 29320A SCSI card... - Hardware ; Hello, I'm having some issues with a new SuperLoader3 that has a DLT-V4 tape drive on a Adaptec 29320A SCSI card. The system is running SuSE 10.0 (kernel 2.6.13-15.11). During boot I'm getting the error seen below. When backing up ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Problem with SuperLoader3 (DLT-V4) on an Adaptec 29320A SCSI card...

  1. Problem with SuperLoader3 (DLT-V4) on an Adaptec 29320A SCSI card...

    Hello,


    I'm having some issues with a new SuperLoader3 that has a DLT-V4 tape
    drive on a Adaptec 29320A SCSI card. The system is running SuSE 10.0
    (kernel 2.6.13-15.11). During boot I'm getting the error seen below.

    When backing up to the system, I write about an entire tape and then I
    get:

    "AttributeError: mtx instance has no attribute 'slots'"
    or
    "AttributeError: mtx instance has no attribute 'drives'"

    and the SuperLoader displays the error message

    So, trying to debug the problem and seeing if anyone's seen this
    before, has some suggestions, or can answer a few of my questions. I
    can't imagine this hardware not being compatible with my setup, but I
    could be wrong.

    1. The Adaptec card only has the SuperLoader on it. Should its module
    (aic79xx) be part of the initrd image? It currently is not.

    2. Should I try loading the Adaptec module before the 3Ware one?

    3. Should I try using a different module? aic7xxx or aic7xxx_old?


    Thank you!!!


    scsi5 : Adaptec AIC79XX PCI-X SCSI HBA DRIVER, Rev 1.3.11

    aic7901: Ultra320 Wide Channel A, SCSI Id=7, PCI-X 67-100Mhz,
    512 SCBs
    target5:0:5: asynchronous.
    Vendor: QUANTUM Model: DLT-V4 Rev: 0700
    Type: Sequential-Access ANSI SCSI revision: 02
    target5:0:5: Beginning Domain Validation
    target5:0:5: wide asynchronous.
    target5:0:5: Domain Validation skipping write tests
    target5:0:5: FAST-80 WIDE SCSI 160.0 MB/s DT (12.5 ns, offset 96)
    target5:0:5: Ending Domain Validation
    Attached scsi generic sg3 at scsi5, channel 0, id 5, lun 0, type 1
    Vendor: QUANTUM Model: UHDL Rev: 0031
    Type: Medium Changer ANSI SCSI revision: 02
    Attached scsi generic sg4 at scsi5, channel 0, id 5, lun 1, type 8
    st: Version 20050501, fixed bufsize 32768, s/g segs 256
    Attached scsi tape st0 at scsi5, channel 0, id 5, lun 0
    st0: try direct i/o: yes (alignment 512 B), max page reachable by HBA
    1048575
    st0: Block limits 2 - 16777214 bytes.
    (scsi5:A:5:0): Unexpected busfree in Command phase, 1 SCBs aborted,
    PRGMCNT == 0x194
    >>>>>>>>>>>>>>>>>> Dump Card State Begins <<<<<<<<<<<<<<<<<

    scsi5: Dumping Card State at program address 0x192 Mode 0x11
    Card was paused
    HS_MAILBOX[0x0] INTCTL[0x80]SWTMINTMASK) SEQINTSTAT[0x0]
    SAVED_MODE[0x11] DFFSTAT[0x13]CURRFIFO_NONE|FIFO0FREE)
    SCSISIGI[0x0]P_DATAOUT) SCSIPHASE[0x0] SCSIBUS[0x0]
    LASTPHASE[0x80]P_COMMAND) SCSISEQ0[0x0] SCSISEQ1[0x12]ENAUTOATNP|
    ENRSELI)
    SEQCTL0[0x0] SEQINTCTL[0x0] SEQ_FLAGS[0x0] SEQ_FLAGS2[0x0]
    SSTAT0[0x0] SSTAT1[0x8]BUSFREE) SSTAT2[0xc0]BUSFREE_DFF1)
    SSTAT3[0x0] PERRDIAG[0x0] SIMODE1[0xac]ENSCSIPERR|ENBUSFREE|
    ENSCSIRST|ENSELTIMO)
    LQISTAT0[0x0] LQISTAT1[0x0] LQISTAT2[0x0] LQOSTAT0[0x0]
    LQOSTAT1[0x0] LQOSTAT2[0x0]

    SCB Count = 4 CMDS_PENDING = 1 LASTSCB 0xffff CURRSCB 0x3 NEXTSCB 0x0
    qinstart = 589 qinfifonext = 589
    QINFIFO:
    WAITING_TID_QUEUES:
    Pending list:
    Total 0
    Kernel Free SCB list: 3 2 1 0
    Sequencer Complete DMA-inprog list:
    Sequencer Complete list:
    Sequencer DMA-Up and Complete list:

    scsi5: FIFO0 Free, LONGJMP == 0x80ff, SCB 0x0
    SEQIMODE[0x3f]ENCFG4TCMD|ENCFG4ICMD|ENCFG4TSTAT|ENCFG4ISTAT|
    ENCFG4DATA|ENSAVEPTRS)
    SEQINTSRC[0x0] DFCNTRL[0x0] DFSTATUS[0x89]FIFOEMP|HDONE|
    PRELOAD_AVAIL)
    SG_CACHE_SHADOW[0x2]LAST_SEG) SG_STATE[0x0] DFFSXFRCTL[0x0]
    SOFFCNT[0x0] MDFFSTAT[0x5]FIFOFREE|DLZERO) SHADDR = 0x00, SHCNT =
    0x0
    HADDR = 0x00, HCNT = 0x0 CCSGCTL[0x10]SG_CACHE_AVAIL)
    scsi5: FIFO1 Active, LONGJMP == 0x8063, SCB 0x3
    SEQIMODE[0x3f]ENCFG4TCMD|ENCFG4ICMD|ENCFG4TSTAT|ENCFG4ISTAT|
    ENCFG4DATA|ENSAVEPTRS)
    SEQINTSRC[0x0] DFCNTRL[0x4]DIRECTION) DFSTATUS[0x89]FIFOEMP|HDONE|
    PRELOAD_AVAIL)
    SG_CACHE_SHADOW[0x3]LAST_SEG_DONE|LAST_SEG) SG_STATE[0x0]
    DFFSXFRCTL[0x0] SOFFCNT[0x0] MDFFSTAT[0x14]DLZERO|LASTSDONE)
    SHADDR = 0x0a, SHCNT = 0x0 HADDR = 0x00, HCNT = 0x0
    CCSGCTL[0x10]SG_CACHE_AVAIL)
    LQIN: 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0
    0x0 0x0 0x0 0x0
    scsi5: LQISTATE = 0x0, LQOSTATE = 0x0, OPTIONMODE = 0x52
    scsi5: OS_SPACE_CNT = 0x20 MAXCMDCNT = 0x0
    SIMODE0[0xc]ENOVERRUN|ENIOERR)
    CCSCBCTL[0x4]CCSCBDIR)
    scsi5: REG0 == 0x3, SINDEX = 0x1c0, DINDEX = 0x10c
    scsi5: SCBPTR == 0x3, SCB_NEXT == 0xffc0, SCB_NEXT2 == 0xffb2
    CDB 34 0 0 0 0 0
    STACK: 0xc3 0x0 0x0 0x0 0x0 0x0 0x0 0x0
    <<<<<<<<<<<<<<<<< Dump Card State Ends >>>>>>>>>>>>>>>>>>
    st0: Error 70000 (sugg. bt 0x0, driver bt 0x0, host bt 0x7).
    .... (repeat of the previous line many many times)
    st0: Error on write filemark.


  2. Re: Problem with SuperLoader3 (DLT-V4) on an Adaptec 29320A SCSIcard...

    Jason wrote:
    > Hello,
    >
    >
    > I'm having some issues with a new SuperLoader3 that has a DLT-V4 tape
    > drive on a Adaptec 29320A SCSI card. The system is running SuSE 10.0
    > (kernel 2.6.13-15.11). During boot I'm getting the error seen below.
    >
    > When backing up to the system, I write about an entire tape and then I
    > get:
    >
    > "AttributeError: mtx instance has no attribute 'slots'"
    > or
    > "AttributeError: mtx instance has no attribute 'drives'"


    What's the output of the following commands?

    ls -l /dev/changer
    mtx status
    mtx -f /dev/sg4 status

    The first should show that either /dev/changer doesn't exist or is a
    symlink to /dev/sg4. Anything else would be an error. The last command
    should show you info about your changer (drives, slots, media status,
    etc). The middle command should fail if /dev/changer doesn't exist or
    should show the same as the last command if /dev/changer is a link to
    /dev/sg4.

    > and the SuperLoader displays the error message


    What error message does it display?

    > So, trying to debug the problem and seeing if anyone's seen this
    > before, has some suggestions, or can answer a few of my questions. I
    > can't imagine this hardware not being compatible with my setup, but I
    > could be wrong.
    >
    > 1. The Adaptec card only has the SuperLoader on it. Should its module
    > (aic79xx) be part of the initrd image? It currently is not.


    It doesn't matter. The initrd only needs modules which are necessary
    for booting. Since your boot disk isn't attached to the aic79xx
    controller there's no need to have that module in the initrd.

    > 2. Should I try loading the Adaptec module before the 3Ware one?


    It shouldn't matter.

    > 3. Should I try using a different module? aic7xxx or aic7xxx_old?


    Neither of those will work with the U320 card you have.


    > scsi5 : Adaptec AIC79XX PCI-X SCSI HBA DRIVER, Rev 1.3.11
    >
    > aic7901: Ultra320 Wide Channel A, SCSI Id=7, PCI-X 67-100Mhz,
    > 512 SCBs
    > target5:0:5: asynchronous.
    > Vendor: QUANTUM Model: DLT-V4 Rev: 0700
    > Type: Sequential-Access ANSI SCSI revision: 02
    > target5:0:5: Beginning Domain Validation
    > target5:0:5: wide asynchronous.
    > target5:0:5: Domain Validation skipping write tests
    > target5:0:5: FAST-80 WIDE SCSI 160.0 MB/s DT (12.5 ns, offset 96)
    > target5:0:5: Ending Domain Validation
    > Attached scsi generic sg3 at scsi5, channel 0, id 5, lun 0, type 1
    > Vendor: QUANTUM Model: UHDL Rev: 0031
    > Type: Medium Changer ANSI SCSI revision: 02
    > Attached scsi generic sg4 at scsi5, channel 0, id 5, lun 1, type 8
    > st: Version 20050501, fixed bufsize 32768, s/g segs 256
    > Attached scsi tape st0 at scsi5, channel 0, id 5, lun 0
    > st0: try direct i/o: yes (alignment 512 B), max page reachable by HBA
    > 1048575
    > st0: Block limits 2 - 16777214 bytes.


    Everything looks fine up to that point.

    You might want to look into updating the firmware. A quick look at the
    Quantum site suggests that version 8 firmware is available for your
    drive and version 43 is available for the changer itself. (You seem to
    have versions 7 and 31, according to the "Rev:" fields.) Consult your
    owner's manual for information on how to update the firmware for both
    devices.

    http://www.quantum.com/ServiceandSup....aspx#Firmware

+ Reply to Thread