[AMD Duron 700MHz] X a bit sluggish -> PCI video card? - Hardware

This is a discussion on [AMD Duron 700MHz] X a bit sluggish -> PCI video card? - Hardware ; Hello I'm using an older PC that has an AMD Duron 700MHz and 384MB SDRAM, and I find it a big sluggish when running X through the embedded video on the Gigabyte GA-7ZX motherboard. Do you think that getting some ...

+ Reply to Thread
Results 1 to 10 of 10

Thread: [AMD Duron 700MHz] X a bit sluggish -> PCI video card?

  1. [AMD Duron 700MHz] X a bit sluggish -> PCI video card?

    Hello

    I'm using an older PC that has an AMD Duron 700MHz and 384MB
    SDRAM, and I find it a big sluggish when running X through the
    embedded video on the Gigabyte GA-7ZX motherboard.

    Do you think that getting some PCI card from eBay or maybe using
    another X server like XFCE would speed things up a bit, or is that
    hardware just too old for snappy performances?

    Thank you.

  2. Re: [AMD Duron 700MHz] X a bit sluggish -> PCI video card?


    Vincent Delporte wrote:
    > Hello
    >
    > I'm using an older PC that has an AMD Duron 700MHz and 384MB
    > SDRAM, and I find it a big sluggish when running X through the
    > embedded video on the Gigabyte GA-7ZX motherboard.
    >
    > Do you think that getting some PCI card from eBay or maybe using
    > another X server like XFCE would speed things up a bit, or is that
    > hardware just too old for snappy performances?
    >

    Depends on what you define by "sluggish". Which operations are slow?
    Running a simple wm would definitely allow to see if it's the driver
    or the heavyweight gui (kde/gnome) that slow you down.
    If it's the driver then a pci card like matrox g200/400/450
    (is sapphire x550 available in pci?) would definitely help.
    If you run kde/gnome on that machine I don't think anything
    will help you.
    If you don't mind wasting money on the card you won't be able to
    reuse in a new system then get an agp card Provided that you verified
    that the system is still slow with xfce/twm or whatever lightweight you
    find/like.


  3. Re: [AMD Duron 700MHz] X a bit sluggish -> PCI video card?

    On Mon, 18 Dec 2006 10:47:32 +0100, Vincent Delporte wrote:

    > Hello
    >
    > I'm using an older PC that has an AMD Duron 700MHz and 384MB
    > SDRAM, and I find it a big sluggish when running X through the
    > embedded video on the Gigabyte GA-7ZX motherboard.
    >
    > Do you think that getting some PCI card from eBay or maybe using
    > another X server like XFCE would speed things up a bit, or is that
    > hardware just too old for snappy performances?
    >
    > Thank you.


    From my experience, an AMD700 should yield reasonable performance. Are you
    sure it is X that is sluggish, or are you running a resource hungry
    desktop like Gnome or KDE? It that is the case, you might try XFCE or
    Enlightenment (or any of the dozens of other lightweight managers).

  4. Re: [AMD Duron 700MHz] X a bit sluggish -> PCI video card?


    On Mon, 18 Dec 2006, Vincent Delporte wrote:

    > Hello
    >
    > I'm using an older PC that has an AMD Duron 700MHz and 384MB
    > SDRAM, and I find it a big sluggish when running X through the
    > embedded video on the Gigabyte GA-7ZX motherboard.


    I have just retired a MB that had a 900MHz Duron. What really prompted me
    to retire it: gmail took too long to load. I think it is because of
    scripts on the page. "top" mostly showed my web browser taking the most
    CPU time.

    Depending on the exact revision of your MB, you may be able to drop in a
    significantly faster processor (from eBay) for about the same cost as a
    few cups of coffee. See this page:
    http://tw.giga-byte.com/Support/Moth...x?NewTechID=42

    I think that KT133 based systems are limited to Durons at 950MHz and
    Athlons at 1.4GHz, while KT133A systems can have significantly faster
    processors (Athlon XP up to maybe 2100+?). You may need to update the BIOS
    to use anything more than 1GHz (BTDT). Even if you have a KT133 based
    system, you could use an Athlon at 1.4GHz. This would provide a very cheap
    and easy upgrade.


    >
    > Do you think that getting some PCI card from eBay or maybe using
    > another X server like XFCE would speed things up a bit, or is that
    > hardware just too old for snappy performances?


    Unless you need better 3D performance, I doubt a new graphics card will
    make a significant difference. Use "top" to see what processes are taking
    up the most CPU time -- if it is X then maybe a better accellerated
    graphics card might help, but make sure it is fully supported in your
    distribution of Linux.



  5. Re: [AMD Duron 700MHz] X a bit sluggish -> PCI video card?

    On Mon, 18 Dec 2006 10:47:32 +0100, Vincent Delporte wrote:


    >Hello


    > I'm using an older PC that has an AMD Duron 700MHz and 384MB
    >SDRAM, and I find it a big sluggish when running X through the
    >embedded video on the Gigabyte GA-7ZX motherboard.


    >Do you think that getting some PCI card from eBay or maybe using
    >another X server like XFCE would speed things up a bit, or is that
    >hardware just too old for snappy performances?


    PCI will be slower than the onboard video. Get an AGP video
    card instead.

  6. Re: [AMD Duron 700MHz] X a bit sluggish -> PCI video card?

    On Mon, 18 Dec 2006 21:52:55 GMT, AZ Nomad
    wrote:
    >PCI will be slower than the onboard video. Get an AGP video
    >card instead.


    Sorry, I meant an AGP card. I'll give XFCE a try, and if it's still
    sluggish, I'll check what CPU I can put in there.

    Thank you all.

  7. Re: [AMD Duron 700MHz] X a bit sluggish -> PCI video card?

    On Mon, 18 Dec 2006 10:47:32 +0100, Vincent Delporte wrote:

    > I'm using an older PC that has an AMD Duron 700MHz and 384MB
    > SDRAM, and I find it a big sluggish when running X through the
    > embedded video on the Gigabyte GA-7ZX motherboard.
    >
    > Do you think that getting some PCI card from eBay or maybe using
    > another X server like XFCE would speed things up a bit, or is that
    > hardware just too old for snappy performances?


    First, add more RAM, if possible. Easiest, cheapest way to performance
    enhancement. I got a noticeable boost on my 900MHz Duron system by going
    from 256 megs to 512. I used a couple of 128MB chips I had laying
    around doing nothing. Now, I almost have no use of the swap. Where as
    before, the swap was hit all the time. Sometimes to the point of
    being 90% full. Scary.

    If things still aren't fast enough, then, yes, go to XFCE, which is 100%
    compatible with all GNOME and KDE apps.

    If the system still isn't smooth enough, install a faster CPU. My
    motherboard will take up to a 1.3GHz Athlon and 1.5MB RAM, which I
    factored in for upgrade potential when I built the system 5 or 6 years ago.

    Installing an AGP video card (I assumed you meant that and not PCI)
    probably won't have any noticeable effect on overall performance.

    Stef


  8. Re: [AMD Duron 700MHz] X a bit sluggish -> PCI video card?

    On Mon, 18 Dec 2006 20:27:05 -0800, Stefan Patric
    wrote:
    >Installing an AGP video card (I assumed you meant that and not PCI)
    >probably won't have any noticeable effect on overall performance.


    Yup, it's an AGP card. I'll try what you mentionned above and see if
    it solves the "problem" (it's usable, really, but I figured I should
    ask the experts just in case).

    Thanks all.

  9. Re: [AMD Duron 700MHz] X a bit sluggish -> PCI video card?



    Whoever wrote:
    >
    > On Mon, 18 Dec 2006, Vincent Delporte wrote:
    >
    > > Hello
    > >
    > > I'm using an older PC that has an AMD Duron 700MHz and 384MB
    > > SDRAM, and I find it a big sluggish when running X through the
    > > embedded video on the Gigabyte GA-7ZX motherboard.

    >
    > I have just retired a MB that had a 900MHz Duron. What really prompted me
    > to retire it: gmail took too long to load. I think it is because of
    > scripts on the page. "top" mostly showed my web browser taking the most
    > CPU time.


    This board apparently supports AGP Graphics X4. AMD recommends this
    type card rather than a PCI-graphics card.

  10. Re: [AMD Duron 700MHz] X a bit sluggish -> PCI video card?

    On Wed, 27 Dec 2006 03:21:01 -0500, OSbandito
    wrote:
    >This board apparently supports AGP Graphics X4. AMD recommends this
    >type card rather than a PCI-graphics card.


    Yup, I meant AGP card instead of PCI. I'm waiting for an AMD CPU on
    eBay to give it a shot and see if it improves performance enough to
    solve the problem. Thanks.

+ Reply to Thread