Problem installing Catalyst (proprietary ATI driver for 3Dacceleration) - Hardware

This is a discussion on Problem installing Catalyst (proprietary ATI driver for 3Dacceleration) - Hardware ; I have ATI Radeon Mobility M6 LY and 2.6.26-ARCH #1 SMP PREEMPT I tried to follow the http://wiki.archlinux.org/index.php/...rietary_driver So I installed "catalyst", added fglrx to MODULES list in /etc/ rc.conf, and also rebooted, but fglrx can't be loaded (with modprobe ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Problem installing Catalyst (proprietary ATI driver for 3Dacceleration)

  1. Problem installing Catalyst (proprietary ATI driver for 3Dacceleration)

    I have ATI Radeon Mobility M6 LY and 2.6.26-ARCH #1 SMP PREEMPT

    I tried to follow the http://wiki.archlinux.org/index.php/...rietary_driver

    So I installed "catalyst", added fglrx to MODULES list in /etc/
    rc.conf, and also rebooted, but fglrx can't be loaded (with modprobe
    either):

    FATAL: Error inserting fglrx (/lib/modules/2.6.26-ARCH/video/
    fglrx.ko): Cannot allocate memory

    Any suggestions?

  2. Re: Problem installing Catalyst (proprietary ATI driver for 3D acceleration)

    I demand that n.torrey.pines@gmail.com may or may not have written...

    > I have ATI Radeon Mobility M6 LY and 2.6.26-ARCH #1 SMP PREEMPT


    > I tried to follow the

    http://wiki.archlinux.org/index.php/...rietary_driver
    > So I installed "catalyst", added fglrx to MODULES list in /etc/
    > rc.conf, and also rebooted, but fglrx can't be loaded (with modprobe
    > either):


    That's RV100, according to radeon(4), so the open-source drivers should be
    fine with that hardware.

    --
    | Darren Salt | linux or ds at | nr. Ashington, | Toon
    | RISC OS, Linux | youmustbejoking,demon,co,uk | Northumberland | Army
    | + Generate power using sun, wind, water, nuclear. FORGET COAL AND OIL.

    Smokey the Borg: "Only *you* can prevent futility."

  3. Re: Problem installing Catalyst (proprietary ATI driver for 3Dacceleration)

    On Tue, 26 Aug 2008 08:08:42 -0700, n.torrey.pines typed this message:

    > I have ATI Radeon Mobility M6 LY and 2.6.26-ARCH #1 SMP PREEMPT
    >
    > I tried to follow the
    > http://wiki.archlinux.org/index.php/...rietary_driver
    >
    > So I installed "catalyst", added fglrx to MODULES list in /etc/ rc.conf,
    > and also rebooted, but fglrx can't be loaded (with modprobe either):
    >
    > FATAL: Error inserting fglrx (/lib/modules/2.6.26-ARCH/video/
    > fglrx.ko): Cannot allocate memory
    >
    > Any suggestions?


    That's the old method. You should be using the ATI linux instructions on
    ATI.AMD.COM for installing ATI proprietary Linux drivers.

+ Reply to Thread