mouse pointer - Hardware

This is a discussion on mouse pointer - Hardware ; Hi all, I have a GA-M55plus-S3G mainboard, where I have installed Windows xp sp2 and tried varius flavours of Linux (FC6, FC6_64, FC8, Ubuntu), but all linux flavours have the same problem, they do not display the mouse pointer. I ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: mouse pointer

  1. mouse pointer

    Hi all,

    I have a GA-M55plus-S3G mainboard, where I have installed Windows xp sp2 and
    tried varius flavours of Linux (FC6, FC6_64, FC8, Ubuntu), but all linux
    flavours have the same problem, they do not display the mouse pointer. I
    also tried different mouses (BENQ, Trust, Tekker) both USB or PS2 without
    success. Windows works fine!!

    Does anyone have a clue of what could be going on?

    Thanks a lot
    Ivan



  2. Re: mouse pointer

    [ newsfroup list trimmed ]
    ["Followup-To:" header set to comp.os.linux.x.]
    Ivan staggered into the Black Sun and said:
    > I have a GA-M55plus-S3G mainboard, where I have tried varius [distros]
    > of Linux (FC6, FC6_64, FC8, Ubuntu), but all linux [distros] have the
    > same problem: They do not display the mouse pointer.


    This is probably an X config problem. What's your video chipset? For
    the longest time, some video cards required the "sw_cursor" Option to be
    set in xorg.conf, otherwise they didn't display the mouse cursor. If
    you don't know what your video chipset is, you can find out by doing
    "/sbin/lspci | grep VGA". Post that info for us.

    > I also tried different [mice]


    Wouldn't help.

    --
    So, what do *you* do for a living?
    I sit in a chair, pressing small plastic rectangles with my fingers
    while peering at many tiny, colored dots. --Peter Manders
    Matt G|There is no Darkness in Eternity/But only Light too dim for us to see

  3. Re: mouse pointer

    Dances With Crows wrote:

    > [ newsfroup list trimmed ]
    > ["Followup-To:" header set to comp.os.linux.x.]
    > Ivan staggered into the Black Sun and said:
    >> I have a GA-M55plus-S3G mainboard, where I have tried varius [distros]
    >> of Linux (FC6, FC6_64, FC8, Ubuntu), but all linux [distros] have the
    >> same problem: They do not display the mouse pointer.

    >
    > This is probably an X config problem. What's your video chipset? For
    > the longest time, some video cards required the "sw_cursor" Option to be
    > set in xorg.conf, otherwise they didn't display the mouse cursor. If
    > you don't know what your video chipset is, you can find out by doing
    > "/sbin/lspci | grep VGA". Post that info for us.


    sorry but could not find where/how to set sw_cursor in man or internet..

    00:05.0 VGA compatible controller: nVidia Corporation C51G [GeForce 6100]
    reva2)

    hope it helps
    >
    >> I also tried different [mice]


    ups.. I new that..
    >
    > Wouldn't help.
    >


    cheers
    ivan

  4. Re: mouse pointer

    Ivan staggered into the Black Sun and said:
    > Dances With Crows wrote:
    >> Ivan staggered into the Black Sun and said:
    >>> I have a GA-M55plus-S3G mainboard, where I have tried varius
    >>> [distros] of Linux (FC6, FC6_64, FC8, Ubuntu), but all linux
    >>> [distros] have the same problem: They do not display the mouse
    >>> pointer.

    >> This is probably an X config problem. What's your video chipset?
    >> For the longest time, some video cards required the "sw_cursor"
    >> Option to be set in xorg.conf,

    > sorry but could not find where/how to set sw_cursor in man or
    > internet..


    It's been so long since I've had to use this that I got the name wrong.
    It's "SWCursor" or "HWCursor", but read on.

    > 00:05.0 VGA compatible controller: nVidia Corporation C51G [GeForce
    > 6100] reva2)


    I have a similar card. Are you using nvidia or nv? If you don't know
    what you're using, "grep Driver /etc/X11/xorg.conf". There should be no
    problems with the cursor if you're using nvidia. If you're using nv,
    then you should try editing xorg.conf and adding the line

    Option "HWCursor" "off"

    ....in the Device section, then restarting X.

    --
    I have to carry this axe.
    It's part of my anger management therapy.
    --Patrik_Aka_RedX
    Matt G|There is no Darkness in Eternity/But only Light too dim for us to see

  5. Re: mouse pointer

    On Sat, 09 Feb 2008 00:12:18 +0000, Ivan propped his eyelids open with
    toothpicks and wrote:

    > Dances With Crows wrote:
    >
    >> [ newsfroup list trimmed ]
    >> ["Followup-To:" header set to comp.os.linux.x.] Ivan staggered into the
    >> Black Sun and said:
    >>> I have a GA-M55plus-S3G mainboard, where I have tried varius [distros]
    >>> of Linux (FC6, FC6_64, FC8, Ubuntu), but all linux [distros] have the
    >>> same problem: They do not display the mouse pointer.

    >>
    >> This is probably an X config problem. What's your video chipset? For
    >> the longest time, some video cards required the "sw_cursor" Option to
    >> be set in xorg.conf, otherwise they didn't display the mouse cursor.
    >> If you don't know what your video chipset is, you can find out by doing
    >> "/sbin/lspci | grep VGA". Post that info for us.

    >
    > sorry but could not find where/how to set sw_cursor in man or internet..
    >
    > 00:05.0 VGA compatible controller: nVidia Corporation C51G [GeForce
    > 6100] reva2)
    >
    > hope it helps
    >>
    >>> I also tried different [mice]

    >
    > ups.. I new that..
    >>
    >> Wouldn't help.
    >>
    >>

    > cheers
    > ivan


    sw_cursor would be set in /etc/X11/xorg.conf in ubuntu, but there should
    be no need to set it at all in modern distros. It looks more like a
    hardware problem. Broken ps2 interface or usb if using a usb mouse, or
    possibly some switch in the bios not set right. Maybe your mouse cable is
    broken. Have you tried another mouse?



    --

    Rob
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    C Programmers do it recursively.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  6. Re: mouse pointer


    "Dances With Crows" ha scritto nel messaggio
    news:slrnfqrmad.vbr.danceswithcrows@crow202.dyndns .org...
    > Ivan staggered into the Black Sun and said:
    >> Dances With Crows wrote:
    >>> Ivan staggered into the Black Sun and said:
    >>>> I have a GA-M55plus-S3G mainboard, where I have tried varius
    >>>> [distros] of Linux (FC6, FC6_64, FC8, Ubuntu), but all linux
    >>>> [distros] have the same problem: They do not display the mouse
    >>>> pointer.
    >>> This is probably an X config problem. What's your video chipset?
    >>> For the longest time, some video cards required the "sw_cursor"
    >>> Option to be set in xorg.conf,

    >> sorry but could not find where/how to set sw_cursor in man or
    >> internet..

    >
    > It's been so long since I've had to use this that I got the name wrong.
    > It's "SWCursor" or "HWCursor", but read on.
    >
    >> 00:05.0 VGA compatible controller: nVidia Corporation C51G [GeForce
    >> 6100] reva2)

    >
    > I have a similar card. Are you using nvidia or nv? If you don't know
    > what you're using, "grep Driver /etc/X11/xorg.conf". There should be no
    > problems with the cursor if you're using nvidia. If you're using nv,
    > then you should try editing xorg.conf and adding the line
    >
    > Option "HWCursor" "off"
    >
    > ...in the Device section, then restarting X.
    >


    it is "sw_cursor", I set it in the Device section and it seems o work..
    thanks

    > --
    > I have to carry this axe.
    > It's part of my anger management therapy.
    > --Patrik_Aka_RedX
    > Matt G|There is no Darkness in Eternity/But only Light too dim for us to
    > see




+ Reply to Thread