I was wondering if my clie will support palm os 5.2. If so, where do
I download it from, and will I have to pay for it?

Any help would be appreciated.