In installing various software for my HP Jornada 728, I noticed a newer
version of MS ActiveSynch 3.1. So I downloaded version 3.5. But it
would not install and recognize my 728. Luckily I had set a "restore"
point just before this.

I then went back and used the original install disk and now have
ActiveSynch 3.1 working just fine.

I am still wondering whether I should now upgrade to 3.5 (or higher).
Have others had problems with 3.5, or was it merely my inexperience?

Thank you
Mahl