Am Tue, 11 Nov 2008 10:55:45 -0800
schrieb "Peter Wemm" :

> Some bioses have a list of MBR partition id's and use that to
> determine what to do with the USB keyboard. One of my ol older amd64
> motherboards worked but would always disable the usb keyboard right as
> loader started. I discovered the following:
> * If I put the freebsd bootblocks and loader on a floppy drive (no
> MBR), then the bios did not turn off the keyboard. It always
> continued to work for loader.
> * If i hacked the boot bootblocks and loader and kernel to recognize
> different MBR slice id nubmers as "ours", then changing the freebsd
> MBR to be "msdos" or "linux" also worked for that BIOS. It would no
> longer turn off the USB keyboard. I don't recall which Id number I
> used instead of 165 - it was about 4 years ago.
> * There were other consequences of using the partition ID hack - I
> think I remember it turning off the apic for msdos mode.
>
> Your problems may be different, but mine were caused by a BIOS
> whitelist of MBR partition id's. What a stupid problem. On that
> motherboard I ended up taking the path of least resistance and using
> the PS/2 adapter plug on the keyboard.


Hello,

I want to add some information about USB problems which occur for me
very frequently.

I have found out that most of the problems are related to Gigabyte
mainboards. I have 2 of them now. One is "EP35C-DS3R". With this
mainboard sometimes my USB keyboard and USB mouse stop working (the
power is simply off). I can reattach them and they both power up again.

The second mainboard is "EP45-DS3R". Here the problem is even worse.
The keyboard and mouse (both USB) lose power as soon as FreeBSD scans
the USB controllers. Here, I can also reattach the devices and they are
usable again.

One further hint: it seems Vista (64 bit version) has the same problem
with this EP45-DS3R mainboard. After it boots into the login screen, I
have to reattach the devices to use them. The mainboard is not broken,
I have tried 3 so far and all have these strange effects.


And now... I want to remind you that I have already posted here about
(same) USB problems on my laptop (Lenovo Thinkpad T60p). Sometimes I
have to reattach my keyboard there, too. Of course, this is not
Gigabyte here, but the weird behaviour ressembles the one above.

--
Martin
_______________________________________________
freebsd-stable@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...freebsd-stable
To unsubscribe, send any mail to "freebsd-stable-unsubscribe@freebsd.org"