I have never used linux compatibility before. I followed the
instructions from the handbook and have the linux kernel module loaded,
a procfs filesystem mounted, and linux_base-fc4 and additional libraries
installed.

urchin# kldstat
Id Refs Address Size Name
1 11 0xffffffff80100000 6a85c8 kernel
2 1 0xffffffff807a9000 20220 geom_mirror.ko
3 2 0xffffffffb04b7000 17b8a linux.ko
4 1 0xffffffffb051f000 3457 linprocfs.ko

urchin# df -h
Filesystem Size Used Avail Capacity Mounted on
/dev/mirror/gm0s1a 496M 243M 213M 53% /
devfs 1.0K 1.0K 0B 100% /dev
/dev/mirror/gm0s1d 224G 7.7G 198G 4% /usr
linprocfs 4.0K 4.0K 0B 100% /usr/compat/linux/proc

urchin# portversion -v | grep linux
linux-expat = up-to-date with port
linux-fontconfig = up-to-date with port
linux-glib2 = up-to-date with port
linux-openmotif = up-to-date with port
linux-xorg-libs = up-to-date with port
linux_base-fc4 = up-to-date with port

I am trying to install a linux rpm of Legato Networker Backup Client.
However I get these errors:

urchin# rpm -i --dbpath /var/lib/rpm --root /compat/linux --test
lgtoclnt-7.3.4-1.i686.rpm
error: failed dependencies:
/bin/sh is needed by lgtoclnt-7.3.4-1
/bin/sh is needed by lgtoclnt-7.3.4-1
/bin/sh is needed by lgtoclnt-7.3.4-1
/bin/sh is needed by lgtoclnt-7.3.4-1
ld-linux.so.2 is needed by lgtoclnt-7.3.4-1
libICE.so.6 is needed by lgtoclnt-7.3.4-1
libSM.so.6 is needed by lgtoclnt-7.3.4-1
libX11.so.6 is needed by lgtoclnt-7.3.4-1
libXext.so.6 is needed by lgtoclnt-7.3.4-1
libXmu.so.6 is needed by lgtoclnt-7.3.4-1
libXt.so.6 is needed by lgtoclnt-7.3.4-1
libc.so.6 is needed by lgtoclnt-7.3.4-1
libdl.so.2 is needed by lgtoclnt-7.3.4-1
libncurses.so.5 is needed by lgtoclnt-7.3.4-1
libpthread.so.0 is needed by lgtoclnt-7.3.4-1
librt.so.1 is needed by lgtoclnt-7.3.4-1
libGL.so.1 is needed by lgtoclnt-7.3.4-1
libXi.so.6 is needed by lgtoclnt-7.3.4-1
libXrender.so.1 is needed by lgtoclnt-7.3.4-1
libm.so.6 is needed by lgtoclnt-7.3.4-1
/bin/ksh is needed by lgtoclnt-7.3.4-1
/bin/sh is needed by lgtoclnt-7.3.4-1
libc.so.6(GLIBC_2.0) is needed by lgtoclnt-7.3.4-1
libc.so.6(GLIBC_2.1) is needed by lgtoclnt-7.3.4-1
libc.so.6(GLIBC_2.1.2) is needed by lgtoclnt-7.3.4-1
libc.so.6(GLIBC_2.1.3) is needed by lgtoclnt-7.3.4-1
libc.so.6(GLIBC_2.2) is needed by lgtoclnt-7.3.4-1
libdl.so.2(GLIBC_2.0) is needed by lgtoclnt-7.3.4-1
libdl.so.2(GLIBC_2.1) is needed by lgtoclnt-7.3.4-1
libm.so.6(GLIBC_2.0) is needed by lgtoclnt-7.3.4-1
libm.so.6(GLIBC_2.1) is needed by lgtoclnt-7.3.4-1
libm.so.6(GLIBC_2.2) is needed by lgtoclnt-7.3.4-1
libpthread.so.0(GLIBC_2.0) is needed by lgtoclnt-7.3.4-1
libpthread.so.0(GLIBC_2.1) is needed by lgtoclnt-7.3.4-1
libpthread.so.0(GLIBC_2.2) is needed by lgtoclnt-7.3.4-1

Because so many dependencies are missing, I suspect I don't have linux
compatibility installed properly. For example, libncurses.so.5 is one
of the dependencies "missing". However:

urchin# find /compat/linux -name libncurses.so.5
/compat/linux/lib/libncurses.so.5
/compat/linux/usr/lib/libncurses.so.5

So what have I missed?

Thanks,

Drew

--
Be a Great Magician!
Visit The Alchemist's Warehouse

http://www.alchemistswarehouse.com

_______________________________________________
freebsd-emulation@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...ebsd-emulation
To unsubscribe, send any mail to "freebsd-emulation-unsubscribe@freebsd.org"