On 11/7/08, Paul B. Mahol wrote:
> On 11/7/08, Paul B. Mahol wrote:
>> On recent CURRENT when attaching rum card, strange bug appear:
>>
>> usb2_alloc_device:1417: set address 2 failed (ignored)
>> usb2_alloc_device:1452: getting device descriptor at addr 2 failed!
>> uhub_reattach_port:401: could not allocate new device!
>>
>> uhub_reattach_port:355: port 5 reset failed, error=USB_ERR_TIMEOUT
>> uhub_reattach_port:421: device problem (USB_ERR_TIMEOUT), disabling port 5
>> uhub_reattach_port:370: giving up port reset - device vanished!
>> uhub_reattach_port:370: giving up port reset - device vanished!
>> uhub_reattach_port:370: giving up port reset - device vanished!
>> uhub_reattach_port:370: giving up port reset - device vanished!
>> uhub_reattach_port:370: giving up port reset - device vanished!
>> uhub_reattach_port:370: giving up port reset - device vanished!
>> uhub_reattach_port:370: giving up port reset - device vanished!
>> uhub_reattach_port:370: giving up port reset - device vanished!
>> uhub_reattach_port:355: port 5 reset failed, error=USB_ERR_TIMEOUT
>> uhub_reattach_port:421: device problem (USB_ERR_TIMEOUT), disabling port 5
>> uhub_reattach_port:370: giving up port reset - device vanished!
>> usb2_alloc_device:1417: set address 2 failed (ignored)
>> usb2_alloc_device:1452: getting device descriptor at addr 2 failed!
>> uhub_reattach_port:401: could not allocate new device!
>>
>> usb2_alloc_device:1417: set address 2 failed (ignored)
>> usb2_alloc_device:1452: getting device descriptor at addr 2 failed!
>> uhub_reattach_port:401: could not allocate new device!
>>
>> But not so old one from svn was working fine.
>>
>>> kldstat

>> Id Refs Address Size Name
>> 1 155 0xc0400000 51f700 kernel (/boot/kernel/kernel)
>> 2 2 0xc0920000 51bb0 sound.ko (/boot/kernel/sound.ko)
>> 3 1 0xc0972000 1a5e0 snd_hda.ko (/boot/kernel/snd_hda.ko)
>> 4 2 0xc098d000 18170 agp.ko (/boot/kernel/agp.ko)
>> 5 1 0xc09a6000 c3fc random.ko (/boot/kernel/random.ko)
>> 6 2 0xc09b3000 16b14 drm.ko (/boot/kernel/drm.ko)
>> 7 1 0xc09ca000 af9c i915.ko (/boot/kernel/i915.ko)
>> 8 5 0xc09d5000 e3cc ata.ko (/boot/kernel/ata.ko)
>> 9 2 0xc09e4000 5230 ataahci.ko (/boot/kernel/ataahci.ko)
>> 10 3 0xc09ea000 88b0 atapci.ko (/boot/kernel/atapci.ko)
>> 11 1 0xc09f3000 4638 atadisk.ko (/boot/kernel/atadisk.ko)
>> 12 1 0xc09f8000 5834 ataintel.ko (/boot/kernel/ataintel.ko)
>> 13 1 0xc09fe000 be08 cpufreq.ko (/boot/kernel/cpufreq.ko)
>> 14 1 0xc0a0a000 4dc8 sysvmsg.ko (/boot/kernel/sysvmsg.ko)
>> 15 1 0xc0a0f000 5e9c sysvsem.ko (/boot/kernel/sysvsem.ko)
>> 16 1 0xc0a15000 5034 sysvshm.ko (/boot/kernel/sysvshm.ko)
>> 17 1 0xc0a1b000 6b974 acpi.ko (/boot/kernel/acpi.ko)
>> 18 9 0xc462c000 35000 usb2_core.ko (/boot/kernel/usb2_core.ko)
>> 19 4 0xc46eb000 3000 usb2_controller.ko
>> (/boot/kernel/usb2_controller.ko)
>> 20 1 0xc46f8000 a000 usb2_controller_uhci.ko
>> (/boot/kernel/usb2_controller_uhci.ko)
>> 21 1 0xc474e000 c000 usb2_controller_ehci.ko
>> (/boot/kernel/usb2_controller_ehci.ko)
>> 22 1 0xc477b000 a000 usb2_controller_ohci.ko
>> (/boot/kernel/usb2_controller_ohci.ko)
>> 23 1 0xc47a8000 a000 usb2_storage_mass.ko
>> (/boot/kernel/usb2_storage_mass.ko)
>> 24 1 0xc47b2000 43000 cam.ko (/boot/kernel/cam.ko)
>> 25 1 0xc47fe000 2000 usb2_storage.ko (/boot/kernel/usb2_storage.ko)
>> 26 1 0xc4800000 a000 usb2_wlan_rum.ko
>> (/boot/kernel/usb2_wlan_rum.ko)
>> 27 1 0xc480a000 2000 wlan_amrr.ko (/boot/kernel/wlan_amrr.ko)
>> 28 4 0xc480c000 34000 wlan.ko (/boot/kernel/wlan.ko)
>> 29 1 0xc4849000 2000 usb2_wlan.ko (/boot/kernel/usb2_wlan.ko)
>>

>
> After some time it will appear but will start attaching and dettaching
> all the time:
>
> ugen4.2: at usbus4
> rum0: on usbus4
> rum0: MAC/BBP RT2573 (rev 0x2573a), RF RT2528
> rum0: at ushub4, port 6, addr 2 (disconnected)
> rum0: detached
> ugen4.2: at usbus4
> rum0: on usbus4
> rum0: MAC/BBP RT2573 (rev 0x2573a), RF RT2528
> rum0: at ushub4, port 6, addr 2 (disconnected)
> rum0: detached
> ugen2.2: at usbus2
> rum0: on usbus2
> rum0: MAC/BBP RT2573 (rev 0x2573a), RF RT2528
> rum0: at ushub2, port 2, addr 2 (disconnected)
> rum0: detached
>


Looks like some code is missing because loading only usb2_wlan_rum do
not load ehci and uhci usb2 modules. (causing card to not attach)

I managed to get card working with usb2_controller_uhci and
usb2_controller_ehci loaded. (without ohci)
_______________________________________________
freebsd-current@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...reebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscribe@freebsd.org"