Hello,
I migrtaed this day to FreeBSD 8.0-CURRENT, most recent buildworld since
last night.

I'm about reinstalling everything I need from scratch, so OpenLDAP
2.4.11 (with SASL support).

After pulling back the backup of the LDAP configurations and assuring
that access rights etc. is in the right place, I tried starting
openldap-2.4.11 and witnessed a crash. Immediately after the
slapd-daemon starts it suffers from SIGNAL 11:

Starting slapd.
@(#) $OpenLDAP: slapd 2.4.11 (Nov 2 2008 11:42:11) $

root@foo.org:/usr/ports/net/openldap24-server/work/openldap-2.4.11/servers/slapd
Segmentation fault
/usr/local/etc/rc.d/slapd: WARNING: failed to start slapd


Well, removing all of my configurations (especially schemata, the
slapd.d-directory) and replacing everything needed by those files coming
with the installation package and trying starting this results in an
'Abort trap':

Starting slapd.
@(#) $OpenLDAP: slapd 2.4.11 (Nov 2 2008 11:42:11) $

root@foo.org:/usr/ports/net/openldap24-server/work/openldap-2.4.11/servers/slapd
Assertion failed: (schema_init_done == 1), function slap_schema_check,
file schema_prep.c, line 1340.
Abort trap
/usr/local/etc/rc.d/slapd: WARNING: failed to start slapd

The used configuration and installation works fine with FreeBSD 7.1-PRE
(exactly the same way installed ports, used the same make.conf!).

Well, before submitting a PR or investigating deeper, please can someone
using LDAP 2.4.11 (from ports) on FBSD 8.0-CUR report whether he is
successfully using LDAP or not?
If there is more than a stupid config-error I will investigate deeper
with all the debugging facilities switched on.

Regards,
thanks in advance,
oliver

_______________________________________________
freebsd-current@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...reebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscribe@freebsd.org"