Hi,

I'm new to FreeBSD-CURRENT and am having problems getting my wireless
to work on my laptop. It is an old Centrino ASUS laptop with built-in
IPW2200 wireless. I've had no problems getting wireless to work on
this for the past few years now with many flavors of linux and of
course Windows so I'm sure it should also work in FreeBSD without any
issues.

However, I'm not having much luck. I've followed the instructions in
the Handbook's Wireless page and read the iwi(4) man page and added
the following to my /boot/loader.conf:

-------------
legal.intel_iwi.license_ack=1
if_iwi_load="YES"
wlan_load="YES"
firmware_load="YES"
iwi_bss_load="YES"
iwi_ibss_load="YES"
iwi_monitor_load="YES"
hw.psm.synaptics_support=1
--------------

When I reboot and do a "dmesg | grep iwi" I get:

----------
iwi0: mem 0xff9de000-0xff9defff irq 4
at device 2.0 on pci2
iwi0: [ITHREAD]
iwi0: timeout waiting for (null) firmware initialization to complete
iwi0: could not load boot firmware (null)
iwi0: timeout waiting for (null) firmware initialization to complete
iwi0: could not load boot firmware (null)
iwi0: timeout waiting for (null) firmware initialization to complete
iwi0: could not load boot firmware (null)
iwi0: timeout waiting for (null) firmware initialization to complete
iwi0: could not load boot firmware (null)
iwi0: timeout waiting for (null) firmware initialization to complete
iwi0: could not load boot firmware (null)
iwi0: mem 0xff9de000-0xff9defff irq 4
at device 2.0 on pci2
iwi0: [ITHREAD]
iwi0: timeout waiting for (null) firmware initialization to complete
iwi0: could not load boot firmware (null)
iwi0: mem 0xff9de000-0xff9defff irq 4
at device 2.0 on pci2
iwi0: [ITHREAD]
iwi0: timeout waiting for (null) firmware initialization to complete
iwi0: could not load boot firmware (null)
iwi0: timeout waiting for (null) firmware initialization to complete
iwi0: could not load boot firmware (null)
iwi0: timeout waiting for (null) firmware initialization to complete
iwi0: could not load boot firmware (null)
iwi0: timeout waiting for (null) firmware initialization to complete
iwi0: could not load boot firmware (null)
iwi0: mem 0xff9de000-0xff9defff irq 4
at device 2.0 on pci2
iwi0: [ITHREAD]
iwi0: timeout waiting for (null) firmware initialization to complete
iwi0: could not load boot firmware (null)
----------

Am I forgetting to load the firmware somehow? In /boot/kernel, I see
the following files:

-----------
[root@asus ~]# ls -l /boot/kernel/iwi_*
-r-xr-xr-x 1 root wheel 197996 Oct 31 23:56 /boot/kernel/iwi_bss.ko
-r-xr-xr-x 1 root wheel 190182 Oct 31 23:56 /boot/kernel/iwi_ibss.ko
-r-xr-xr-x 1 root wheel 194760 Oct 31 23:56 /boot/kernel/iwi_monitor.ko
-----------

ifconfig:
bge0: flags=8843 metric 0 mtu 1500
options=9b
ether 00:11:2f:0c:e8:7f
inet 192.168.1.70 netmask 0xffffff00 broadcast 192.168.1.255
media: Ethernet autoselect (100baseTX )
status: active
fwe0: flags=8802 metric 0 mtu 1500
options=8
ether 02:e0:18:1b:1f:63
ch 1 dma -1
fwip0: flags=8802 metric 0 mtu 1500
lladdr 0.e0.18.0.3.1b.1f.63.a.2.ff.fe.0.0.0.0
iwi0: flags=8803 metric 0 mtu 2290
ether 00:0e:35:0d:7c:65
media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
status: no carrier
plip0: flags=108810 metric 0 mtu 1500
lo0: flags=8049 metric 0 mtu 16384
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x6
inet6 ::1 prefixlen 128
inet 127.0.0.1 netmask 0xff000000

But if I try to do "ifconfig iwi0 up" I get:

----------
iwi0: timeout waiting for (null) firmware initialization to complete
iwi0: could not load boot firmware (null)
----------

Any help appreciated. Thanks.
_______________________________________________
freebsd-current@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...reebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscribe@freebsd.org"