Afraid, that didn't do it.

The patch files didn't work at first but a did it by hand adding the
relevant lines. It compiled and installed fine.

So what we see is that things have changed but are not yet working, if not
actually worse. Here are my findings (all using the vge driver compiled into
kernel)

-first we fail if ifconfig media is set to auto, ifconfig reports media
Ethernet autoselect (none), status: active. No difference if LINK0 set.

-100BaseTX-FDX appears not to send, if I try to ping any other than the
local IP I 'ping: sendto: No buffer space available'. If I tcpdump on the
interface I see the traffic I would expect on the local subnet.

-1000BaseTX, still no carrier

The detailed dmesg snip shows that ip1000phy did connect rather than ukphy

pcib3: slot 0 INTA hardwired to IRQ 28
vge0: port 0xe800-0xe8ff mem
0xfeaffc00-0xfeaffcff irq 28 at device 0
..0 on pci3
vge0: Reserved 0x100 bytes for rid 0x14 type 3 at 0xfeaffc00
miibus0: on vge0
ip1000phy0: PHY 22 on miibus0
ip1000phy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX,
1000baseTX-FDX, auto
vge0: using obsoleted if_watchdog interface
vge0: bpf attached
vge0: Ethernet address: 00:40:63:f3:7e:28
ioapic1: routing intpin 4 (PCI IRQ 28) to vector 49
vge0: [MPSAFE]
vge0: [ITHREAD]


thanks again for the help, what next?

S

-----Original Message-----
From: owner-freebsd-current@freebsd.org
[mailtowner-freebsd-current@freebsd.org] On Behalf Of Pyun YongHyeon
Sent: 02 April 2008 09:52
To: Stuart Fraser
Cc: freebsd-current@freebsd.org
Subject: Re: vge(4) driver not working at 1G speeds

On Wed, Apr 02, 2008 at 09:30:40AM +0100, Stuart Fraser wrote:
> Oops, no coffee yet, here you go.
>
> pcib3: slot 0 INTA hardwired to IRQ 28 > vge0:
Ethernet> port 0xe800-0xe8ff mem > 0xfeaffc00-0xfeaffcff irq 28 at device
0.0 on pci3 > vge0: Reserved 0x100 bytes for rid 0x14 type 3 at 0xfeaffc00
> miibus0: on vge0 > ukphy0:
interface> PHY 22 on miibus0 > ukphy0: OUI 0x0090c3, model 0x0019, rev. 0
> ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, >

1000baseT-FDX, auto > vge0: using obsoleted if_watchdog interface > vge0:
bpf attached > vge0: Ethernet address: 00:40:63:f3:7e:28 > ioapic1:
routing intpin 4 (PCI IRQ 28) to vector 49 > vge0: [MPSAFE] > vge0:
[ITHREAD] >

Thanks a lot! Try attached patch and let me know how it goes.

--
Regards,
Pyun YongHyeon


_______________________________________________
freebsd-current@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...reebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscribe@freebsd.org"