Hi there,

I'm not interested in enabling support for IPv6 for now.

When I remove INET6 from the kernel configuration, I cannot compile the
kernel without disabling SCTP. With fresh 7.0-STABLE source, here's the
error output (INET6 disabled, but SCTP enabled):

uipc_syscalls.o(.text+0x3c1): In function `sctp_generic_recvmsg':
/usr/src/sys/kern/uipc_syscalls.c:2608: undefined reference to
`sctp_sorecvmsg'
uipc_syscalls.o(.text+0x21a2): In function `sctp_generic_sendmsg_iov':
/usr/src/sys/kern/uipc_syscalls.c:2486: undefined reference to
`sctp_lower_sosend'
uipc_syscalls.o(.text+0x249d): In function `sctp_generic_sendmsg':
/usr/src/sys/kern/uipc_syscalls.c:2379: undefined reference to
`sctp_lower_sosend'
uipc_syscalls.o(.text+0x266c): In function `sctp_peeloff':
/usr/src/sys/kern/uipc_syscalls.c:2246: undefined reference to
`sctp_can_peel_off'
uipc_syscalls.o(.text+0x28e6):/usr/src/sys/kern/uipc_syscalls.c:2287:
undefined reference to `sctp_do_peeloff'
rtsock.o(.text+0xb7d): In function `rt_newaddrmsg':
/usr/src/sys/net/rtsock.c:897: undefined reference to `sctp_addr_change'
in_proto.o(.data+0xa8): undefined reference to `sctp_input'
in_proto.o(.data+0xb0): undefined reference to `sctp_ctlinput'
in_proto.o(.data+0xb4): undefined reference to `sctp_ctloutput'
in_proto.o(.data+0xbc): undefined reference to `sctp_init'
in_proto.o(.data+0xc8): undefined reference to `sctp_drain'
in_proto.o(.data+0xcc): undefined reference to `sctp_usrreqs'
in_proto.o(.data+0xdc): undefined reference to `sctp_input'
in_proto.o(.data+0xe4): undefined reference to `sctp_ctlinput'
in_proto.o(.data+0xe8): undefined reference to `sctp_ctloutput'
in_proto.o(.data+0xfc): undefined reference to `sctp_drain'
in_proto.o(.data+0x100): undefined reference to `sctp_usrreqs'
in_proto.o(.data+0x110): undefined reference to `sctp_input'
in_proto.o(.data+0x118): undefined reference to `sctp_ctlinput'
in_proto.o(.data+0x11c): undefined reference to `sctp_ctloutput'
in_proto.o(.data+0x130): undefined reference to `sctp_drain'
in_proto.o(.data+0x134): undefined reference to `sctp_usrreqs'



Is this intended and/or a known issue?

Thanks,
Andy


---
Andy Dills
Xecunet, Inc.
www.xecu.net
301-682-9972
---
_______________________________________________
freebsd-stable@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...freebsd-stable
To unsubscribe, send any mail to "freebsd-stable-unsubscribe@freebsd.org"