On Sun, 2008-03-02 at 22:43 +0000, Raphael Salas wrote:
> Hi,
>
> I recently bought a Toshiba Satellite P205D-S7479, and want to run
> FreeBSD 7.0-RELEASE on it. However, during partitioning, my hard disk
> (SATA) is not found, even with ACPI disabled and during safe mode.
> pciconfig -lv says the ATA controller's vendor is ATI. Additionally,
> my BIOS doesn't provide any options regarding hard disk, therefore, I
> cannot switch it to IDE mode.


Is the controller detected at all when booting from the install CD?
When you are at the sysinstall menu, you should be able to press scroll
lock and page up back through the boot messages. Booting "verbose" may
well be useful.

If it's not detected, compare this with the boot messages from 6.3 and
see what the differences are. Does it try to attach and fail, or never
even notice the controller is there? If the controller attaches
successfully, have a look towards the end of the boot messages for where
disks get detected. What are the errors?

It sounds like you already have 6.x or something on the machine, if so
you may find that you can boot (with verbose logging) the 7.x CD, abort
the installer, reboot into 6.x and find the 7.x boot messages
in /var/log/messages. Otherwise, taking digital pictures of the boot
messages and sending links to the list may well help us diagnose the
problem.

Gavin
_______________________________________________
freebsd-current@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...reebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscribe@freebsd.org"