On Thu, Feb 21, 2008 at 01:18:18PM +0200, Ian FREISLICH wrote:
> Pyun YongHyeon wrote:
> > On Thu, Feb 21, 2008 at 02:47:43PM +1000, Robert Backhaus wrote:
> > > On Thu, Feb 21, 2008 at 1:50 PM, Pyun YongHyeon wrote:
> > > > On Thu, Feb 21, 2008 at 11:03:02AM +1000, Robert Backhaus wrote:
> > > > > I am experiencing roughly 15% packet corruption on the re interface

> on
> > > > > my freebsd 7/amd64 box.
> > > > >
> > > > > FreeBSD gw.flexi.robbak.com 7.0-PRERELEASE FreeBSD 7.0-PRERELEASE #8

> :
> > > > > Tue Feb 5 09:49:55 EST 2008
> > > > > root@gw.flexi.robbak.com:/usr/obj/usr/src/sys/GW amd64
> > > > >
> > > > > Just to make troubleshooting difficult, this problem only shows up
> > > > > after the system has been up for roughly 36 hours, depending on the
> > > > > amount of traffic.
> > > > >
> > > >
> > > > I didn't take a look attached tcpdump files but I guess the
> > > > instability issue was fixed in HEAD. It's not yet MFCed but
> > > > I'll handle it in a week.
> > > >
> > > > Would you try re(4) in HEAD?
> > > >
> > >
> > > OK, I'll do that. What is the best way to do that? csupping to "." seems a
> > > bit drastic, and I don't do much with cvs proper. I take it that I should

> use
> > > anon-cvs to grab the directory, but I don't quite know how.
> > >

> >
> > Copy sys/dev/re/if_re.c, sys/pci/if_rlreg.h in HEAD to your box.
> > Due to lack of m_defrag(9) in 7-PRERELEASE/RC, you also have to add
> > that function to if_re.c(Copy m_defrag() in sys/kern/uipc_mbuf.c on
> > HEAD/RELENG_7 to if_re.c). That would make it build on your box.

>
> This doesn't solve the problem that I'm seeing on re(4) interfaces.
> It basically shows up as quagga establishing OSPF neighours as
> "Exchange/DR" when VLAN hardware tagging is enabled. I'm running
> OSPF over 802.1Q vlans. Neighbours are correctly negotiated once
> VLAN hardware tagging is disabled on the interface.
>
> I'll do more debugging.
>


Hmm. That sounds like different issue to me. I guess I din't change
any semantics in VLAN H/W tagging. Do you still the same VLAN H/W
tagging related issues on RELENG_7?

To narrow down the issue it would be even better to know which parts
of H/W assistance was broken. For example,
- Disable checksum offload for VLAN interface first and check
whether quagga works.
- Disable checksum offload for parent interface and check again.
If you can post tcpdump output for broken conntection it may help a
lot to diagnose the issue.

--
Regards,
Pyun YongHyeon
_______________________________________________
freebsd-current@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...reebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscribe@freebsd.org"