On Mon, 11 Feb 2008 19:02:12 +0100, Greg Lewis
wrote:

> On Mon, Feb 11, 2008 at 11:08:58AM +0100, Giulio Ferro wrote:
>> Is pretty much unusable. Every now and then, when you open a dialog or
>> do some
>> operation (e.g. refactoring) everything crashes with a "problematic
>> frame" error
>> or permgen error (even though I set a high value for that in
>> config.ini).
>>
>> I already submitted more than one report on this and got no reply. Is
>> java on freebsd
>> abandoned or what?

>
> Definitely not. Although it sounds from your subsequent email that this
> is
> mainly occurring for eclipse 3.3. Thats probably the reason while this
> version of eclipse is still in the eclipse-devel port rather than having
> become the stable eclipse port . It really seems like your problems
> are specific to that version of eclipse and that you need people
> interested
> in working on that rather than Java in general.


I'm running Eclipse 3.3 on FreeBSD 7/i386 without any problems. I'm using
subclipse (not from ports). The project I'm working on has more than
900000 lines of code and things like refactoring run very well.
I'm not sure if my eclipse runs on java 5 or 6. I have them both
installed. Java -version gives me 1.5. I wil use 1.6 tomorrow.

Maybe eclipse on amd64 runs different. Eclipse has native c(++) parts.

Ronald.

--
Ronald Klop
Amsterdam, The Netherlands
_______________________________________________
freebsd-java@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-java
To unsubscribe, send any mail to "freebsd-java-unsubscribe@freebsd.org"