I have a Maestro 2E sound card that works perfectly on 6.2-RELEASE-p8,
but not on 6.3-PRERELEASE. Here's the dmesg:

> Copyright (c) 1992-2007 The FreeBSD Project.
> Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
> The Regents of the University of California. All rights reserved.
> FreeBSD is a registered trademark of The FreeBSD Foundation.
> FreeBSD 6.3-PRERELEASE #13: Thu Nov 22 06:25:22 CST 2007
> greg@localhost:/usr/obj/usr/src/sys/CUSTOM
> Timecounter "i8254" frequency 1193182 Hz quality 0
> CPU: Intel(R) Pentium(R) D CPU 3.00GHz (3606.95-MHz 686-class CPU)
> Origin = "GenuineIntel" Id = 0xf62 Stepping = 2
> Features=0xbfebfbff
> Features2=0xe43d
> AMD Features=0x20000000
> AMD Features2=0x1
> Cores per package: 2
> real memory = 1073217536 (1023 MB)
> avail memory = 1036808192 (988 MB)
> ACPI APIC Table:
> FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
> cpu0 (BSP): APIC ID: 0
> cpu1 (AP): APIC ID: 1
> ioapic0 irqs 0-23 on motherboard
> kbd1 at kbdmux0
> acpi0:
on motherboard
> acpi0: Power Button (fixed)
> Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
> acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
> cpu0: on acpi0
> acpi_throttle0: on cpu0
> cpu1: on acpi0
> pcib0: port 0xcf8-0xcff on acpi0
> pci0: on pcib0
> pcib1: irq 16 at device 1.0 on pci0
> pci3: on pcib1
> nvidia0: port 0xe800-0xe87f mem 0xdf000000-0xdfffffff,0xe0000000-0xefffffff,0xde000000-0xdeffffff irq 16 at device 0.0 on pci3
> nvidia0: [GIANT-LOCKED]
> pcm0: mem 0xdddf8000-0xdddfbfff irq 19 at device 27.0 on pci0
> pcib2: irq 16 at device 28.0 on pci0
> pci2: on pcib2
> uhci0: port 0x7000-0x701f irq 20 at device 29.0 on pci0
> uhci0: [GIANT-LOCKED]
> usb0: on uhci0
> usb0: USB revision 1.0
> uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub0: 2 ports with 2 removable, self powered
> uhci1: port 0x7400-0x741f irq 17 at device 29.1 on pci0
> uhci1: [GIANT-LOCKED]
> usb1: on uhci1
> usb1: USB revision 1.0
> uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub1: 2 ports with 2 removable, self powered
> uhci2: port 0x7800-0x781f irq 18 at device 29.2 on pci0
> uhci2: [GIANT-LOCKED]
> usb2: on uhci2
> usb2: USB revision 1.0
> uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub2: 2 ports with 2 removable, self powered
> uhci3: port 0x8000-0x801f irq 19 at device 29.3 on pci0
> uhci3: [GIANT-LOCKED]
> usb3: on uhci3
> usb3: USB revision 1.0
> uhub3: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub3: 2 ports with 2 removable, self powered
> ehci0: mem 0xdddff800-0xdddffbff irq 20 at device 29.7 on pci0
> ehci0: [GIANT-LOCKED]
> usb4: EHCI version 1.0
> usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
> usb4: on ehci0
> usb4: USB revision 2.0
> uhub4: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
> uhub4: 8 ports with 8 removable, self powered
> pcib3: at device 30.0 on pci0
> pci1: on pcib3
> sio0: configured irq 21 not in bitmap of probed irqs 0
> sio0: port may not be enabled
> sio0: <3COM PCI FaxModem> port 0xa400-0xa407 irq 21 at device 0.0 on pci1
> sio0: moving to sio4
> sio4: type 16550A
> puc0: port 0xa800-0xa81f irq 22 at device 1.0 on pci1
> sio5: on puc0
> sio5: type 16550A
> sio6: on puc0
> sio6: type 16550A
> pcm1: port 0xb000-0xb0ff irq 23 at device 2.0 on pci1
> pcm1: agg_rdcodec() RW_DONE timed out.
> pcm1: will perform cold reset.
> pcm1: agg_rdcodec() RW_DONE timed out.
> pcm1: agg_rdcodec() RW_DONE timed out.
> pcm1: agg_rdcodec() RW_DONE timed out.
> pcm1: agg_rdcodec() RW_DONE timed out.
> pcm1: agg_rdcodec() RW_DONE timed out.
> pcm1: ac97 codec invalid or not present (id == ffffffff)
> pcm1: mixer initialization failed!
> device_attach: pcm1 attach returned 6
> atapci0: port 0xc800-0xc807,0xc400-0xc403,0xc000-0xc007,0xb800-0xb803,0xb400-0xb40f irq 19 at device 4.0 on pci1
> ata2: on atapci0
> ata3: on atapci0
> isab0: at device 31.0 on pci0
> isa0: on isab0
> atapci1: port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xffa0-0xffaf at device 31.1 on pci0
> ata0: on atapci1
> ata1: on atapci1
> atapci2: port 0x9800-0x9807,0x9400-0x9403,0x9000-0x9007,0x8800-0x8803,0x8400-0x840f mem 0xdddffc00-0xdddfffff irq 23 at device 31.2 on pci0
> ata4: on atapci2
> ata5: on atapci2
> pci0: at device 31.3 (no driver attached)
> acpi_button0: on acpi0
> fdc0: port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
> fdc0: [FAST]
> fd0: <1440-KB 3.5" drive> on fdc0 drive 0
> ppc0: port 0x378-0x37f,0x778-0x77f irq 7 drq 3 on acpi0
> ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
> ppc0: FIFO with 16/16/9 bytes threshold
> ppbus0: on ppc0
> lpt0: on ppbus0
> lpt0: Interrupt-driven port
> atkbdc0: port 0x60,0x64 irq 1 on acpi0
> atkbd0: irq 1 on atkbdc0
> kbd0 at atkbd0
> atkbd0: [GIANT-LOCKED]
> can't re-use a leaf (%desc)!
> can't re-use a leaf (%driver)!
> can't re-use a leaf (%location)!
> can't re-use a leaf (%pnpinfo)!
> can't re-use a leaf (%parent)!
> sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
> sio0: type 16550A
> pmtimer0 on isa0
> sc0: at flags 0x100 on isa0
> sc0: VGA <16 virtual consoles, flags=0x300>
> vga0: at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
> Timecounters tick every 1.000 msec
> acd0: CDRW at ata0-master PIO4
> afd0: (no media) at ata0-slave PIO0
> ad4: 114473MB at ata2-master UDMA100
> pcm0:
> pcm0:
> SMP: AP CPU #1 Launched!
> acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
> afd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
> cd0 at ata0 bus 0 target 0 lun 0
> cd0: Removable CD-ROM SCSI-0 device
> cd0: 16.000MB/s transfers
> cd0: cd present [452 x 2048 byte records]
> da0 at ata0 bus 0 target 1 lun 0
> da0: Removable Direct Access SCSI-0 device
> da0: 3.300MB/s transfers
> da0: Attempt to query device size failed: NOT READY, Medium not present
> Trying to mount root from ufs:/dev/ad4s2a



--
http://www.velocityvector.com/ | http://www.classic-games.com/
I'd rather hunt with Dick Cheney than ride with Ted Kennedy.
_______________________________________________
freebsd-stable@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...freebsd-stable
To unsubscribe, send any mail to "freebsd-stable-unsubscribe@freebsd.org"