Diane Bruce wrote:
> On Sun, Oct 28, 2007 at 11:38:26PM +0100, Kris Kennaway wrote:
>> Marc UBM Bocklet wrote:
>>> On Sun, 28 Oct 2007 18:45:59 +0100
>>> Marc "UBM" Bocklet wrote:
>>>

> ...
>>> A tip from Diane Bruce (db@freebsd.org) did the trick:
>>>
>>> ----
>>>
>>> This one bit me as well. It's an obsolete library (libthr) in the
>>> binary, Recompile ruby18 and problem will go away. You'll find other
>>> programs will do this too, but a lot of them disapear after doing a
>>> portupgrade.
>>>
>>> ----

>> ...which is a necessary part of any upgrade to a new branch.
>>

>
> Just to keep it clear. ;-) I always upgrade my portupgrade manually
> after a branch, but his problems sounded like he had not. What I am
> getting bit with are things like:
>
> -rw------- 1 db wheel 1056768 Oct 28 23:12 xfce4-mixer-plugin.core
> -rw------- 1 db wheel 1159168 Oct 28 23:12 xfdesktop.core
> -rw------- 1 db wheel 1024000 Oct 28 23:12 xfce-mcs-manager.core
> -rw------- 1 db wheel 978944 Oct 28 23:12 xscreensaver-gl-hel.core
> -rw------- 1 db wheel 1032192 Oct 28 23:03 xfce4-session.core
>
> All due to obsolete libs. Since there was a gnome import lately, updating
> now seemed a good idea.


What do you mean by obsolete libs? The portupgrade -fa should have
fixed precisely that

Kris

_______________________________________________
freebsd-stable@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...freebsd-stable
To unsubscribe, send any mail to "freebsd-stable-unsubscribe@freebsd.org"