Beni wrote:
> On Friday 20 April 2007 03:55:56 Ganbold wrote:
>
>> Michael Nottebrock wrote:
>>
>>> I forwarded my mail to gnome@ (the HAL maintainers) after sending it and
>>> Joe Marcus Clarke from gnome@ had this to say on the issue:
>>>
>>> --- snip
>>>
>>> This should have been fixed a while ago by jylefort when he set the
>>> default device for ATAPI access to be the ATAPICAM device (as opposed to
>>> the ATA device). Assuming you have not undone that change, and are
>>> running the latest version of HAL, these panics should not be occurring.
>>>
>>> Even still, you're right that these are not HAL bugs, but rather an
>>> issue in the kernel. I use nautilus-cd-burner to burn CDs in GNOME, and
>>> I have never had such a panic on 6-STABLE. n-c-b uses cdrecord, cdrao,
>>> and dvd-utils under the covers to do the actual device work. Not sure
>>> what k3b is using, but maybe it diddles something it shouldn't.
>>>
>>> Joe
>>>
>>> --- snip
>>>
>>> Beni, Robert, Ganbold, are you all in fact running the latest version of
>>> the hal port and do you all have atapicam enabled in your kernel? If not,
>>> making sure of both might help avoiding the problem.
>>>

>> I see. I know I have updated my system last Saturday (14th April 2007) and
>> I think I updated both hal and kdelibs ports. I have atapicam enabled in
>> kernel.
>> Let me double check it this weekend and I will let you know.
>>
>> thanks,
>>
>> Ganbold
>>
>>
>>> ------------------------------------------------------------------------
>>>
>>> Subject:
>>> Re: Fwd: Re: [kde-freebsd] problem hal - k3b ?
>>> From:
>>> Joe Marcus Clarke
>>> Date:
>>> Thu, 19 Apr 2007 12:49:26 -0400
>>> To:
>>> Michael Nottebrock
>>>
>>> To:
>>> Michael Nottebrock
>>> CC:
>>> gnome@freebsd.org
>>>
>>> Michael Nottebrock wrote:
>>>
>>>> I forgot to cc gnome@ on my reply. I don't think this is a HAL bug, but
>>>> just FYI.
>>>>
>>>>
>>>>
>>>> ------------------------------------------------------------------------
>>>>
>>>> Subject:
>>>> Re: [kde-freebsd] problem hal - k3b ?
>>>> From:
>>>> Michael Nottebrock
>>>> Date:
>>>> Thu, 19 Apr 2007 18:12:46 +0200
>>>> To:
>>>> kde@freebsd.org
>>>>
>>>> To:
>>>> kde@freebsd.org
>>>> CC:
>>>> Beni , h.eichmann@gmx.de, current@freebsd.org,
>>>> stable@freebsd.org
>>>>
>>>> On Wednesday, 18. April 2007, Beni wrote:
>>>>
>>>>> Hi List,
>>>>>
>>>>> I think I have a problem with hal(d) and k3b (version 1.0 from ports) :
>>>>> my whole system freezes when starting up k3b. I get the splash screen
>>>>> and then it all stops and a ctrl-alt-del is the only way out.
>>>>>
>>>> Other people have reported kernel panics. It looks to me like k3b's
>>>> device probing and hald's device probing at the same time manages to
>>>> tickle a bug in ata(4).
>>>>
>>>> Ref:
>>>> http://lists.freebsd.org/pipermail/f...ril/070753.htm
>>>> l
>>>> http://lists.freebsd.org/pipermail/f...il/034486.html
>>>>
>>>> I'm afraid a true kernel hacker will have to inconvenince themselves
>>>> with running k3b and hal in order to have this one fixed. FWIW, I
>>>> haven't seen in happening on 5.5.
>>>>
>>> This should have been fixed a while ago by jylefort when he set the
>>> default device for ATAPI access to be the ATAPICAM device (as opposed to
>>> the ATA device). Assuming you have not undone that change, and are
>>> running the latest version of HAL, these panics should not be occurring.
>>>
>>> Even still, you're right that these are not HAL bugs, but rather an
>>> issue in the kernel. I use nautilus-cd-burner to burn CDs in GNOME, and
>>> I have never had such a panic on 6-STABLE. n-c-b uses cdrecord, cdrao,
>>> and dvd-utils under the covers to do the actual device work. Not sure
>>> what k3b is using, but maybe it diddles something it shouldn't.
>>>
>>> Joe
>>>

>
>
> Could it all be related to this :
> http://lists.freebsd.org/pipermail/f...il/034553.html
> and the "solution" from Shane Bell in
> http://lists.freebsd.org/pipermail/f...il/034602.html :
>
> "I believe the culprit is somewhere in a recent MFC to atapi-cam.c (rev
> 1.42.2.3) reverting to rev 1.42.2.2 fixes both the k3b system hangs
> and "INQUIRY ILLEGAL REQUEST" errors here."
>



Most probably. I updated everything, including source and ports on April
22nd and
the problem still exists. k3b hangs after loading splash screen and I
had to use
power button on my laptop to power down and up the system.

I will try to revert rev 1.42.2.2 and see what will happen.


Ganbold


> Beni.
> _______________________________________________
> freebsd-stable@freebsd.org mailing list
> http://lists.freebsd.org/mailman/lis...freebsd-stable
> To unsubscribe, send any mail to "freebsd-stable-unsubscribe@freebsd.org"
>
>
>
>


_______________________________________________
freebsd-stable@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...freebsd-stable
To unsubscribe, send any mail to "freebsd-stable-unsubscribe@freebsd.org"