This is a multi-part message in MIME format.

--Boundary_(ID_zeXsOSIV2GD0A6h4nzvLlQ)
Content-type: text/plain; charset=US-ASCII
Content-transfer-encoding: 7BIT

On Sun, 16 Jul 2006 10:05:18 -0700
Cy Schubert wrote:

> You may want to try the patch anyway. It enables EC burst mode within


I finally had time to try this patch:
http://www.freebsd.org/cgi/query-pr.cgi?pr=98171

> Anyhow, you may want to enable EC burst mode. That seems to solve the
> problems the Linux folks experience. It may solve yours too.


After bulding and installing a new kernel, I enabled EC burst with:
hw.acpi.ec.burst=1
in /boot/loader.conf

At first, the machine rebooted itself, due to these messages
in /var/log/messages:
Aug 8 20:26:44 kg-home kernel: acpi_tz0: WARNING - current temperature
(144.0C) exceeds safe limits

Setting
debug.acpi.disabled="thermal"
in /boot/loader.conf fixed that problem.
Unfortunately, it didn't solve the other acpi-related problems - bge0
still fails to attach and so on. Se attached dmesg output.
--
Regards,
Torfinn Ingolfsen,
Norway


--Boundary_(ID_zeXsOSIV2GD0A6h4nzvLlQ)
Content-type: text/plain; name=kg-home-dmesg-6.1-stable-20060808.txt
Content-transfer-encoding: 7BIT
Content-disposition: attachment; filename=kg-home-dmesg-6.1-stable-20060808.txt

Copyright (c) 1992-2006 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD 6.1-STABLE #1: Tue Aug 8 20:16:39 CEST 2006
root@kg-home.kg4.no:/usr/obj/usr/src/sys/AS5672
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Genuine Intel(R) CPU T2250 @ 1.73GHz (1733.41-MHz 686-class CPU)
Origin = "GenuineIntel" Id = 0x6e8 Stepping = 8
Features=0xbfe9fbff
Features2=0xc189,>
AMD Features=0x100000
Cores per package: 2
real memory = 2145910784 (2046 MB)
avail memory = 2095009792 (1997 MB)
ACPI APIC Table:
ioapic0: Changing APIC ID to 1
ioapic0 irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: on motherboard
ACPI-0438: *** Error: Looking up [Z006] in namespace, AE_NOT_FOUND
SearchNode 0xc63e9200 StartNode 0xc63e9200 ReturnNode 0
ACPI-0438: *** Error: Looking up [Z006] in namespace, AE_NOT_FOUND
SearchNode 0xc63e8d80 StartNode 0xc63e8d80 ReturnNode 0
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi0: Power Button (fixed)
unknown: I/O range not supported
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
acpi_ec0: port 0x62,0x66 on acpi0
cpu0: on acpi0
acpi_throttle0: on cpu0
pcib0: port 0xcf8-0xcff on acpi0
pci0: on pcib0
pcib1: irq 16 at device 1.0 on pci0
pci1: on pcib1
pci1: at device 0.0 (no driver attached)
pci0: at device 27.0 (no driver attached)
pcib2: irq 17 at device 28.0 on pci0
pci2: on pcib2
pcib3: irq 16 at device 28.1 on pci0
pci3: on pcib3
pci3: at device 0.0 (no driver attached)
pcib4: irq 18 at device 28.2 on pci0
pci4: on pcib4
bge0: irq 18 at device 0.0 on pci4
bge0: 0x10000 bytes of rid 0x10 res 3 failed (0, 0xffffffff).
bge0: couldn't map memory
device_attach: bge0 attach returned 6
pcib5: irq 19 at device 28.3 on pci0
pci5: on pcib5
uhci0: port 0x1800-0x181f irq 23 at device 29.0 on pci0
uhci0: [GIANT-LOCKED]
usb0: on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: port 0x1820-0x183f irq 19 at device 29.1 on pci0
uhci1: [GIANT-LOCKED]
usb1: on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: port 0x1840-0x185f irq 18 at device 29.2 on pci0
uhci2: [GIANT-LOCKED]
usb2: on uhci2
usb2: USB revision 1.0
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci3: port 0x1860-0x187f irq 16 at device 29.3 on pci0
uhci3: [GIANT-LOCKED]
usb3: on uhci3
usb3: USB revision 1.0
uhub3: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
ehci0: mem 0xc8004000-0xc80043ff irq 23 at device 29.7 on pci0
ehci0: [GIANT-LOCKED]
usb4: EHCI version 1.0
usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
usb4: on ehci0
usb4: USB revision 2.0
uhub4: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub4: 8 ports with 8 removable, self powered
ugen0: OEM Camera, rev 2.00/1.00, addr 2
pcib6: at device 30.0 on pci0
pci10: on pcib6
cbb0: mem 0xc8404000-0xc8404fff irq 20 at device 9.0 on pci10
cardbus0: on cbb0
pccard0: <16-bit PCCard bus> on cbb0
fwohci0: <1394 Open Host Controller Interface> mem 0xc8405000-0xc84057ff,0xc8400000-0xc8403fff irq 20 at device 9.1 on pci10
fwohci0: OHCI version 1.10 (ROM=1)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 00:c0:9f:00:00:9a:84:d3
fwohci0: Phy 1394a available S400, 3 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: on fwohci0
fwe0: on firewire0
if_fwe0: Fake Ethernet address: 02:c0:9f:9a:84:d3
fwe0: Ethernet address: 02:c0:9f:9a:84:d3
fwe0: if_start running deferred for Giant
sbp0: on firewire0
fwohci0: Initiate bus reset
fwohci0: node_id=0xc000ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
pci10: at device 9.2 (no driver attached)
isab0: at device 31.0 on pci0
isa0: on isab0
atapci0: port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x18b0-0x18bf at device 31.2 on pci0
ata0: on atapci0
ata1: on atapci0
ichsmb0: port 0x18c0-0x18df irq 19 at device 31.3 on pci0
ichsmb0: [GIANT-LOCKED]
smbus0: on ichsmb0
smb0: on smbus0
acpi_acad0: on acpi0
battery0: on acpi0
acpi_lid0: on acpi0
acpi_button0: on acpi0
acpi_button1: on acpi0
atkbdc0: port 0x60,0x64 irq 1 on acpi0
atkbd0: irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model Generic PS/2 mouse, device ID 0
sio0 port 0x2f8-0x2ff,0x6f8-0x6ff irq 3 drq 3 flags 0x10 on acpi0
sio0: type 16550A
pmtimer0 on isa0
orm0: at iomem 0xdf800-0xdffff,0xe0000-0xe17ff on isa0
ppc0: parallel port not found.
sc0: at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 1733405440 Hz quality 800
Timecounters tick every 1.000 msec
ACPI-0438: *** Error: Looking up [Z006] in namespace, AE_NOT_FOUND
SearchNode 0xc63e9200 StartNode 0xc63e9200 ReturnNode 0
ACPI-1304: *** Error: Method execution failed [\\_SB_.BAT1._BST] (Node 0xc63e9100), AE_NOT_FOUND
ad0: 114473MB at ata0-master UDMA33
acd0: DVDR at ata1-master UDMA33
Trying to mount root from ufs:/dev/ad0s3a
ACPI-0438: *** Error: Looking up [Z006] in namespace, AE_NOT_FOUND
SearchNode 0xc63e9200 StartNode 0xc63e9200 ReturnNode 0
ACPI-1304: *** Error: Method execution failed [\\_SB_.BAT1._BST] (Node 0xc63e9100), AE_NOT_FOUND
ACPI-0438: *** Error: Looking up [Z006] in namespace, AE_NOT_FOUND
SearchNode 0xc63e9200 StartNode 0xc63e9200 ReturnNode 0
ACPI-1304: *** Error: Method execution failed [\\_SB_.BAT1._BST] (Node 0xc63e9100), AE_NOT_FOUND
ACPI-0438: *** Error: Looking up [Z006] in namespace, AE_NOT_FOUND
SearchNode 0xc63e9200 StartNode 0xc63e9200 ReturnNode 0
ACPI-1304: *** Error: Method execution failed [\\_SB_.BAT1._BST] (Node 0xc63e9100), AE_NOT_FOUND
ACPI-0438: *** Error: Looking up [Z006] in namespace, AE_NOT_FOUND
SearchNode 0xc63e9200 StartNode 0xc63e9200 ReturnNode 0
ACPI-1304: *** Error: Method execution failed [\\_SB_.BAT1._BST] (Node 0xc63e9100), AE_NOT_FOUND
ACPI-0438: *** Error: Looking up [Z006] in namespace, AE_NOT_FOUND
SearchNode 0xc63e9200 StartNode 0xc63e9200 ReturnNode 0
ACPI-1304: *** Error: Method execution failed [\\_SB_.BAT1._BST] (Node 0xc63e9100), AE_NOT_FOUND
ACPI-0438: *** Error: Looking up [Z006] in namespace, AE_NOT_FOUND
SearchNode 0xc63e9200 StartNode 0xc63e9200 ReturnNode 0
ACPI-1304: *** Error: Method execution failed [\\_SB_.BAT1._BST] (Node 0xc63e9100), AE_NOT_FOUND

--Boundary_(ID_zeXsOSIV2GD0A6h4nzvLlQ)
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________
freebsd-mobile@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...freebsd-mobile
To unsubscribe, send any mail to "freebsd-mobile-unsubscribe@freebsd.org"
--Boundary_(ID_zeXsOSIV2GD0A6h4nzvLlQ)--