Unable to Install Java 1.6 from ports - FreeBSD

This is a discussion on Unable to Install Java 1.6 from ports - FreeBSD ; I just tried to install the newest version of Java 1.6 from ports. I updated my ports like the error-message said but without any success. I need to install it on a server where there is no need for an ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Unable to Install Java 1.6 from ports

  1. Unable to Install Java 1.6 from ports

    I just tried to install the newest version of Java 1.6 from ports.
    I updated my ports like the error-message said but without any success.

    I need to install it on a server where there is no need for an applet.
    Somebody any suggestion how to install it?

    Error of make install:
    ===> jdk-1.6.0.2p2 has known vulnerabilities:
    => jdk/jre -- Applet Caching May Allow Network Access Restrictions to be
    Circumvented.
    Reference:

    => Please update your ports tree and try again.
    *** Error code 1

    Stop in /usr/ports/java/jdk16.
    *** Error code 1

    Stop in /usr/ports/java/jdk16.

    Tim

    _______________________________________________
    freebsd-java@freebsd.org mailing list
    http://lists.freebsd.org/mailman/listinfo/freebsd-java
    To unsubscribe, send any mail to "freebsd-java-unsubscribe@freebsd.org"

  2. Re: Unable to Install Java 1.6 from ports

    On Nov 12, 7:36 pm, webmas...@zaaldelle.be (Webmaster Parochiale
    Werken Delle) wrote:
    > I just tried to install the newest version of Java 1.6 from ports.
    > I updated my ports like the error-message said but without any success.
    >
    > I need to install it on a server where there is no need for an applet.
    > Somebody any suggestion how to install it?
    >
    > Error of make install:
    > ===> jdk-1.6.0.2p2 has known vulnerabilities:
    > => jdk/jre -- Applet Caching May Allow Network Access Restrictions to be
    > Circumvented.
    > Reference:
    >
    > => Please update your ports tree and try again.
    > *** Error code 1
    >
    > Stop in /usr/ports/java/jdk16.
    > *** Error code 1
    >
    > Stop in /usr/ports/java/jdk16.
    >
    > Tim
    >
    > _______________________________________________
    > freebsd-j...@freebsd.org mailing listhttp://lists.freebsd.org/mailman/listinfo/freebsd-java
    > To unsubscribe, send any mail to "freebsd-java-unsubscr...@freebsd.org"


    Hello Tim,

    To install the java/jdk16, first you need to update your port tree ,
    because a new version of tz updater is available from sun.com and then
    to disable vulnerabilities you can use the option
    DISABLE_VULNERABILITIES.

    So, finally install with this command :

    sbz@atemi:/usr/ports/java/jdk16 % sudo make install clean
    DISABLE_VULNERABILITIES=YES

    Best Regards.

    Sofian 'sbz' Brabez

+ Reply to Thread