Hi all

1) portinstall

# portinstall netbeans
[Updating the pkgdb in /var/db/pkg
.... - 197 packages found (-1 +0) (...) done]
---> Installing 'netbeans-3.6' from a port
(java/netbeans)
---> Building '/usr/ports/java/netbeans'
===> Cleaning for gettext-0.13.1_1
===> Cleaning for glib-1.2.10_10
===> Cleaning for nspr-4.4.1_1
===> Cleaning for javavmwrapper-1.5
===> Cleaning for jdk-1.3.1p9_4
===> Cleaning for urwfonts-1.0
===> Cleaning for gtk-1.2.10_12
===> Cleaning for open-motif-2.2.2_2
===> Cleaning for netbeans-3.6
===> Vulnerability check disabled
===> Extracting for netbeans-3.6
>> Checksum OK for netbeans-3_6.tar.bz2.

===> Patching for netbeans-3.6
Hmm... Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|
|$FreeBSD:
ports/java/netbeans/files/bin_runide.sh.diff,v 1.3
2004/04/16 13:51:23 olgeni Exp $
|
|--- bin/runide.sh.orig Tue Jun 3 11:23:09 2003
|+++ bin/runide.sh Wed Jun 11 12:30:37 2003
--------------------------
Patching file
/usr/ports/java/netbeans/work/netbeans/bin/runide.sh
using Plan A...
Hunk #1 succeeded at 131.
done
===> Configuring for netbeans-3.6
---> Installing the new version via the port
===> Installing for netbeans-3.6
===> netbeans-3.6 depends on file:
/usr/local/jdk1.3.1/bin/java - found
===> Generating temporary packing list
===> Checking if java/netbeans already installed
===> Registering installation for netbeans-3.6
===> Cleaning for gettext-0.13.1_1
===> Cleaning for glib-1.2.10_10
===> Cleaning for nspr-4.4.1_1
===> Cleaning for javavmwrapper-1.5
===> Cleaning for jdk-1.3.1p9_4
===> Cleaning for urwfonts-1.0
===> Cleaning for gtk-1.2.10_12
===> Cleaning for open-motif-2.2.2_2
===> Cleaning for netbeans-3.6
[Updating the pkgdb in /var/db/pkg
.... - 198 packages found (-0 +1) . done]

#

% more .chsrc

set path = (/sbin /bin /usr/sbin /usr/bin /usr/games
/usr/local/sbin /usr/local/bin /usr/X11R6/bin
/usr/local/jdk1.3.1/bin $HOME/bin)

setenv JAVA_HOME /usr/local/jdk1.3.1
setenv JDK_HOME /usr/local/jdk1.3.1

jdk1.3.1 alone, works perfectly (javac, java,
javadoc, etc) but...

I take this problem when try to start netbeans:

%netbeans --jdkhome /usr/local/jdk1.3.1
Exception in thread "main"
java.lang.UnsupportedClassVersionError:
org/netbeans/Main (Unsupported major.minor version
48.0)
at java.lang.ClassLoader.defineClass0(Native
Method)
at
java.lang.ClassLoader.defineClass(ClassLoader.java :486)
at
java.security.SecureClassLoader.defineClass(Secure ClassLoader.java:111)
at
java.net.URLClassLoader.defineClass(URLClassLoader .java:248)
at
java.net.URLClassLoader.access$100(URLClassLoader. java:56)
at
java.net.URLClassLoader$1.run(URLClassLoader.java: 195)
at
java.security.AccessController.doPrivileged(Native
Method)
at
java.net.URLClassLoader.findClass(URLClassLoader.j ava:188)
at
java.lang.ClassLoader.loadClass(ClassLoader.java:2 97)
at
sun.misc.Launcher$AppClassLoader.loadClass(Launche r.java:286)
at
java.lang.ClassLoader.loadClass(ClassLoader.java:2 53)
at
java.lang.ClassLoader.loadClassInternal(ClassLoade r.java:313)
%

Can someone give me a help?

regards
Josean






__________________________________________________ ____________________
Correo Yahoo! - 6MB, más protección contra el spam ¡Gratis!
http://correo.yahoo.es
_______________________________________________
freebsd-java@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-java
To unsubscribe, send any mail to "freebsd-java-unsubscribe@freebsd.org"