> On Thu, 2007-11-15 at 22:24 -0500, Tuc at T-B-O-H.NET wrote:
> > > On Thu, 2007-11-15 at 21:04 -0500, Tuc at T-B-O-H.NET wrote:
> > > > > On Thu, 2007-11-15 at 20:27 -0500, Tuc at T-B-O-H.NET wrote:
> > > > > > Hi,
> > > > > >=3D3D20
> > > > > > If I move the file out of the way, I get :
> > > > > >=3D3D20
> > > > > > (etc)
> > > > > > ORBit-imodule-2.0 ORBit-imodule-2.0 - ORBit runtime typ=

> elib=3D
> > > gen=3D3D
> > > > > eration service.
> > > > > > gtk+ GTK+ - GIMP Tool Kit
> > > > > > Failed to open '/usr/local/libdata/pkgconfig/gail.pc': Too many o=

> pen =3D
> > > file=3D3D
> > > > > s
> > > > > > Package 'gail', required by 'libgnomecanvas-2.0', not found
> > > > >=3D20
> > > > > This sounds like some kind of recursion problem, unless your system
> > > > > really is out of files. What does the following report:
> > > > >=3D20
> > > > > sysctl kern.maxfiles
> > > > > sysctl kern.maxfilesperproc
> > > > > sysctl kern.openfiles
> > > > >=3D20
> > > > > Joe
> > > > >=3D20
> > > > himinbjorg# sysctl kern.maxfiles
> > > > kern.maxfiles: 12328
> > > > himinbjorg# sysctl kern.maxfilesperproc
> > > > kern.maxfilesperproc: 11095
> > > > himinbjorg# sysctl kern.openfiles
> > > > kern.openfiles: 247
> > >=20
> > > You should ktrace pkg-config then to see if it's looping.
> > >=20

> > Looks like its looping between gail and=20
> > libgnomecanvas-2.0 .
> >=20
> > Any more things to look for on the original silc
> > issue?
> >=20
> > (REPEAT of the gail/libgnomecanvas-2.0)
> > # cat /usr/local/libdata/pkgconfig/gail.pc
> > prefix=3D/usr/local
> > exec_prefix=3D${prefix}
> > libdir=3D${exec_prefix}/lib
> > includedir=3D${prefix}/include
> >=20
> > Name: Gail
> > Description: GNOME Accessibility Implementation Library
> > Version: 1.18.0
> > Requires: atk gtk+-2.0
> > Requires.private: libgnomecanvas-2.0
> > Libs: -L${libdir} -lgailutil
> > Cflags: -I${includedir}/gail-1.0
> >=20
> > # cat /usr/local/libdata/pkgconfig/libgnomecanvas-2.0.pc
> > prefix=3D/usr/local
> > exec_prefix=3D${prefix}
> > libdir=3D${exec_prefix}/lib
> > includedir=3D${prefix}/include
> >=20
> > Name: libgnomecanvas-2.0
> > Description: libgnomecanvas
> > Requires: libart-2.0 gtk+-2.0
> > Requires.private: pango pangoft2 gail
> > Version: 2.20.1.1
> > Libs: -L${libdir} -lgnomecanvas-2
> > Cflags: -I${includedir}/libgnomecanvas-2.0

>
> Your version of Gail is out of date. You should have 1.20.1 which no
> longer requires libgnomecanvas.
>
> Joe
>

I know its out of date. I can't remember the particulars, but
gnucash (1.8) wasn't happy with a later version, and I couldn't go to
2.X due to some issues with the files I already had.

As for the silc issue, looks like someone else ran into it
and the Xorg team already has a solution :

https://bugzilla.redhat.com/show_bug.cgi?id=384421

fix is in

https://bugs.freedesktop.org/show_bug.cgi?id=13265

Tuc
_______________________________________________
freebsd-gnome@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "freebsd-gnome-unsubscribe@freebsd.org"