+-le 07/07/2003 15:27 +0200, Mathieu Arnold =E9crivait :
| Hi,
|=20
| I recently migrated a Linux web server to FreeBSD, and I now need to put
| back OCI8 support into PHP. I tried to compile it with the old linux
| version, but apache cores dump, so, not good
|=20
| So, any ideas would be really appreciated
|=20
| The worst solution would be to run the old linux httpd + mod_php on a
| local IP and use the new one as a proxy... But, well, not really what I
| wanted to do in the first place

I've finally got it installed, thanks to :

I compiled php with it, but, well, it seems it can't do anything with it...

With apache+mod_php, it cores dump with :
(gdb) bt
#0 0x28123257 in strncmp () from /usr/lib/libc.so.4
#1 0x28ff416c in __DTOR_END__ () from /usr/compat/linux/lib//libc.so.6
#2 0x28f1c7da in _init (arg=3D0x2808ac68) at
.../sysdeps/unix/sysv/linux/init-first.c:87
#3 0x2807aacf in find_symdef () from /usr/libexec/ld-elf.so.1
#4 0x2807b3ef in dlopen () from /usr/libexec/ld-elf.so.1
#5 0x8067b17 in ap_os_dso_load ()

and with only php :
(gdb) bt
#0 0x28d75257 in strncmp () from /usr/lib/libc.so.4
#1 0x28ea516c in __DTOR_END__ () from /usr/compat/linux/lib//libc.so.6
#2 0x28dcd7da in _init (arg=3D0x281ccc68) at
.../sysdeps/unix/sysv/linux/init-first.c:87
#3 0x281bcacf in find_symdef () from /usr/libexec/ld-elf.so.1
#4 0x281bb9a4 in _rtld () from /usr/libexec/ld-elf.so.1

I don't really see what I could do to prevent this.

Does anyone ever got it to work ?

--=20
Mathieu Arnold
_______________________________________________
freebsd-emulation@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...ebsd-emulation
To unsubscribe, send any mail to "freebsd-emulation-unsubscribe@freebsd.org"