On Tue, Jul 01, 2003 at 12:43:17PM -0700, Marcel Moolenaar wrote:
> On Tue, Jul 01, 2003 at 08:34:05PM +0100, Josef Karthauser wrote:
> > On Tue, Jul 01, 2003 at 10:46:36AM -0700, Marcel Moolenaar wrote:
> > > On Tue, Jul 01, 2003 at 03:31:22PM +0100, Josef Karthauser wrote:
> > > > I've just got around to installing vmware-3.2, and it runs!
> > > > Unfortunately whenever I try and power on I get the error
> > > >
> > > > "this version of the linux kernel is not supported".
> > > >
> > > > Any tricks or tips as to how to circumnaviate this?
> > >
> > > sysctl compat.linux.osrelease?
> > >

> >
> > Probably. Any idea what to set it to?

>
> RH8 is at 2.4.18. The linuxulator sets the value to 2.4.2 as that
> was the kernel revision in RH 7.2
> Therefore: try 2.4.18
>


Ahha, that appears to work:
sysctl compat.linux.osrelease=2.4.18

I've since found that I was nailing the values in /etc/sysctl.conf,
#compat.linux.osname=FreeBSD
#compat.linux.osrelease=5.0-current
so that opera reported the correct things.

Joe
--
Josef Karthauser (joe@tao.org.uk) http://www.josef-k.net/
FreeBSD (cvs meister, admin and hacker) http://www.uk.FreeBSD.org/
Physics Particle Theory (student) http://www.pact.cpes.sussex.ac.uk/
================ An eclectic mix of fact and theory. =================
_______________________________________________
freebsd-emulation@freebsd.org mailing list
http://lists.freebsd.org/mailman/lis...ebsd-emulation
To unsubscribe, send any mail to "freebsd-emulation-unsubscribe@freebsd.org"