Hi, I'm a total newbie to setting up firewalls, but I've
been tasked to make the Cisco 501 PIX we have here at the
office do the following things:

Allow split-tunnel VPN (currently it does allow you to VPN
in, but once you've done so you cannot access the internet
at all)

Allow access to both our local and development servers
(currently we only access local) through port 80,
preferably without port mapping.

show run returns the following:

Result of firewall command: "show run"

: Saved
:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
....
hostname pixfirewall
domain-name spectrumdirect.local
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 70.168.146.6 Outside2
access-list inside_outbound_nat0_acl permit ip any
192.168.1.128 255.255.255.128
access-list inside_outbound_nat0_acl permit ip host
192.168.1.250 192.168.1.128 255.255.255.128
access-list SpectrumDirect_splitTunnelAcl permit ip any
any
access-list outside_cryptomap_dyn_40 permit ip any
192.168.1.128 255.255.255.128
access-list outside_cryptomap_dyn_60 permit ip any
192.168.1.128 255.255.255.128
access-list outside_cryptomap_dyn_80 permit ip any
192.168.1.128 255.255.255.128
access-list outside_access_in remark Web Access
access-list outside_access_in permit tcp any eq www
interface outside eq www
access-list outside_access_in permit tcp any interface
outside eq www
access-list outside_access_in remark Allow Urchin Access
to Officeserver
access-list outside_access_in permit tcp any eq 9999 host
70.168.146.5 eq 9999
access-list outside_access_in permit tcp any host
70.168.146.5 eq 9999
access-list outside_access_in remark Web Access for Dev1
access-list outside_access_in permit tcp host Outside2 eq
www host Outside2 eq www
access-list outside_access_in permit tcp host Outside2
host Outside2 eq www
access-list 101 permit tcp any any eq 9999
access-list outside_cryptomap_dyn_100 permit ip any
192.168.1.128 255.255.255.128
access-list outside_cryptomap_dyn_120 permit ip any
192.168.1.128 255.255.255.128
access-list outside_cryptomap_dyn_140 permit ip any
192.168.1.128 255.255.255.128
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 70.168.146.5 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool SpectrumDirect 192.168.1.2-192.168.1.129
ip local pool SDVPN 192.168.1.150-192.168.1.200
pdm location 192.168.1.0 255.255.255.0 outside
pdm location 192.168.1.250 255.255.255.255 inside
pdm location Outside2 255.255.255.255 outside
pdm location 192.168.1.248 255.255.255.255 inside
pdm location 192.168.1.128 255.255.255.128 outside
pdm location 192.168.2.0 255.255.255.0 inside
pdm location 192.168.1.0 255.255.255.255 inside
pdm location 192.168.2.0 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface www 192.168.1.250
www netmask 255.255.255.255 0 0
static (inside,outside) tcp 70.168.146.5 9999
192.168.1.250 9999 netmask 255.255.255.255 0 0
static (inside,outside) tcp Outside2 www 192.168.1.248 www
netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 70.168.146.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc
0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media
0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des
esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set
ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address
outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set
ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 60 match address
outside_cryptomap_dyn_60
crypto dynamic-map outside_dyn_map 60 set transform-set
ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 80 match address
outside_cryptomap_dyn_80
crypto dynamic-map outside_dyn_map 80 set transform-set
ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 100 match address
outside_cryptomap_dyn_100
crypto dynamic-map outside_dyn_map 100 set transform-set
ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 120 match address
outside_cryptomap_dyn_120
crypto dynamic-map outside_dyn_map 120 set transform-set
ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 140 match address
outside_cryptomap_dyn_140
crypto dynamic-map outside_dyn_map 140 set transform-set
ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic
outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup SpectrumDirect address-pool SDVPN
vpngroup SpectrumDirect dns-server 192.168.1.250
192.168.1.250
vpngroup SpectrumDirect wins-server 192.168.1.250
vpngroup SpectrumDirect default-domain
spectrumdirect.local
vpngroup SpectrumDirect split-tunnel
SpectrumDirect_splitTunnelAcl
vpngroup SpectrumDirect idle-time 1800
vpngroup SpectrumDirect password ********
telnet 192.168.1.0 255.255.255.0 inside
telnet 192.168.2.0 255.255.255.255 inside
telnet 192.168.1.0 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.25-192.168.1.149 inside
dhcpd dns 192.168.1.250 68.6.16.30
dhcpd wins 192.168.1.250
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
username SpectrumDirect password *********** encrypted
privilege 15
terminal width 80
Cryptochecksum:e5a9d5141722a831514044b9a20c9f84
: end

Is there anything obvious that the gurus could point out
to me, or resources I might take a look at to puzzle this
out for myself? I noticed that there's a third subnet on
some of the access-list commands, and some of the stuff
I've read suggests that there should be for the split-vpn
access list too, but I'm not sure how that needs to be set
up. Thanks!

--Matt
_______________________________________________
firewall-wizards mailing list
firewall-wizards@honor.icsalabs.com
http://honor.icsalabs.com/mailman/li...rewall-wizards