Xorg on AMD geode LX800 - Embedded

This is a discussion on Xorg on AMD geode LX800 - Embedded ; Hi, has anyone accomplished to run the xorg X-server on the AMD embedded lx800 board (geode processor) with a resolution of 320x240 pixel? I am running linux-2.6.11.12 and xorg 6.8.2, both patched with the patches from http://makeashorterlink.com/?J25A42ABC The system is ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Xorg on AMD geode LX800

  1. Xorg on AMD geode LX800

    Hi,

    has anyone accomplished to run the xorg X-server on the AMD embedded lx800
    board (geode processor) with a resolution of 320x240 pixel?

    I am running linux-2.6.11.12 and xorg 6.8.2, both patched with the patches
    from http://makeashorterlink.com/?J25A42ABC

    The system is working fine except of the display output:

    The display is a Sharp TFT flat panel with a resolution of 320x240 pixel.
    (http://www.sharpsma.com/part.php?PartID=4817)

    I can run the X server in 640x480 mode, which does not fit on the display,
    so I get some distorted X screen.

    I have used the sample xorg.conf included in the above patch archive but
    also tried to calculate my own modelines using some of the modeline
    calculators available on the internet.


    The xorg.conf config file contains the following entries:

    Section "Device"
    Identifier "AMD LX800 onboard video card"
    Driver "amd"
    BusID "PCI:0:1:1"
    Option "FlatPanel"
    Option "NoCrtEnable"
    # Option "FPDestGeom" "320x240"
    EndSection
    Section "Screen"
    Identifier "Default Screen"
    Device "AMD LX800 onboard video card"
    Monitor "Generic Monitor"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "320x240"
    EndSubSection
    EndSection

    The 320x240 modes do not work and lead to the following output in the
    logfile:
    (II) AMD(0): Not using default mode "320x240" (bad mode
    clock/interlace/doublescan)
    (II) AMD(0): Not using mode "320x240" (no mode of this name)

    The option Option "FPDestGeom" "320x240"
    leads to the error messages:
    FP_DEST_GEOM "320x240" out of range
    FP_DEST_GEOM "320x240" not recognized


    I would be very pleased, if someone can help me to find a
    solution in this case.

    best regards,
    Harald.



  2. Re: Xorg on AMD geode LX800

    Harald Haspl wrote:
    > has anyone accomplished to run the xorg X-server on the AMD embedded lx800
    > board (geode processor) with a resolution of 320x240 pixel?


    I finally got it running.

    But it works only with one specific configuration:
    Color depth: 16, Mode 320x480, Virtual resolution 800x600.
    and the option "ShadowFB" enabled.

    It is very strange: if I change any of those settings (color depth, mode),
    the screen gets distorted.
    If I drop the option "ShadowFB", artefacts of windows are left on the screen
    when I move a window.

    And another nasty fact is that the X-server uses 100% of my CPU time. Do you
    know how the acceleration works for that chip?

    Section "Device"
    Identifier "AMD LX800 onboard video card"
    Driver "amd"
    BusID "PCI:0:1:1"

    Option "FlatPanel"
    Option "NoCrtEnable"
    # Option "FPDestGeom" "320x240"
    Option "Accel"
    Option "ShadowFB"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "AMD LX800 onboard video card"
    Monitor "Generic Monitor"

    DefaultDepth 16
    SubSection "Display"
    Depth 16
    Modes "320x480"
    Virtual 800 600
    EndSubSection
    EndSection

    best regards,
    Harald


+ Reply to Thread