Hello,

Below, there is a statement:
"If it's occasional, that may be a known bug in 9.5 about
cache entry management, and will be fixed in the next beta"

I am testing 9.5.1b2.

Is*9.5.1b2 affected by this "known bug"?
If so, do we have any details on this bug as well as*any ETA on the "will be fixed in the next beta"?

Do you recommend downgrading to 9.5.1b1?

Thank you.

*


----- Original Message ----
From: JINMEI Tatuya / 神明達哉
To: bsfinkel@anl.gov
Cc: bind-users@isc.org
Sent: Monday, October 27, 2008 2:57:32 PM
Subject: Re: DNS "chicken-and-egg" Problem

At Mon, 27 Oct 2008 10:32:59 -0500 (CDT),
bsfinkel@anl.gov wrote:
>
> I am having problems resolving
>
>* * * igpp.ucla.edu


[snip]

> This looks like a proper referral to the one name server for the igpp
> sub-domain.* I also get the "A" record for that name server.
> But when I dump the cache on the nameserver on which I was doing my
> queries, I do not see this glue information cached.* If the information
> is not in the cache, then when I do a query for the "A" record, I find
> that I need that "A" record to be able to query the authoritative
> name server for that sub-domain.* There seems to be a "chicken-and-egg"
> problem.* Why does BIND 9.5.0-P2 not cache the glue information that
> it receives from the four authoritative name servers for ucla.edu?


I'm not sure if I understand your problem.* Did you actually have any
trouble resolving the name, or are you just wondering about the cache
content (without having any actual trouble)?* If it's the latter,
please be more specific about what you did, what you expected, and
what you actually got.

If it's the former, does that always happen, or is it an occasional
problem?* If it's occasional, that may be a known bug in 9.5 about
cache entry management, and will be fixed in the next beta.

---
JINMEI, Tatuya
Internet Systems Consortium, Inc.